Bug 205970 - text install from cdrom fails, cdrom is not mounted for rpm
text install from cdrom fails, cdrom is not mounted for rpm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-10 23:11 EDT by John Bass
Modified: 2008-05-06 12:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Bass 2006-09-10 23:11:51 EDT
Description of problem: text install fails at package installation because cdrom
is not mounted on /mnt/source


Version-Release number of selected component (if applicable): 5.91 (FC 6 Test 2)


How reproducible: Always on Supermicro i2DMR system with internal CDROM


Steps to Reproduce:
1. perform text install from CDROM, any configuration.
2.
3.
  
Actual results:
/mnt/cdrom should be mounted at package install, but is not

Expected results:
system should install normally, just as RH AS 3.0 does on this system.

Additional info:
Comment 1 Chris Lumens 2006-09-12 12:53:05 EDT
This works on our FC6t3 test trees.  Please try again with that release and
reopen this bug if you are still experiencing problems.
Comment 2 John Bass 2006-09-12 15:33:49 EDT
From jbass Tue Sep 12 11:47:53 2006
To: clumens@redhat.com, jbass@dmsd.com
Subject: Re: [Bug 205970] text install from cdrom fails, cdrom is not mounted
for rpm
Cc: fedora-ia64-list@redhat.com

I've tried this some half dozen times already, and it always fails at the same spot.
At first I thought it was a package managment issue, and just a particular package
was missing, so I tried the install with various package options, and it failed with
a different package each time.

In debugging, I used the text console on F3, and found there was no CD mounted,
and no device for the CD created in /dev.

It creates the root file system, populates a small collection of directories,
installs some network configuration files, a few rpm files, then dies.

Install is from the built in IDE/ATA cdrom on this Supermicro Itanium 2 server,
in text mode, because the gui dies on this machine because of an unsupported
Rage XL chip ... as per another bug report.

Closing this without asking for additional information, and entering into a dialog
with the person reporting the bug to discover it's root clause is in poor form.

For some 35 years I've made a living porting cross architecture, including a lot
of UNIX kernel and applications porting. IA64 doesn't have a chance if bugs are
closed this easily.

John Bass
Owner/DMS Design


Prarit Bhargava <prarit@redhat.com> writes:
> John L. Bass wrote:
> > Thanks ... I don't see an updated schedule, so i guess the Sept 14 date
> > is still a go for FC6T3 release ... I can wait a couple days. Good luck
> > on the panic resolution.
> >
> > What IA64 machines are your QA guys regression testing against?

> SGI, HP, Fujitsu ...

I understand that HP is using their own I/O chips, that are not clones of the
Intel PCI/ISA bridges. What about the other guys? This Supermicro box is using:

[root@ollie root]# cat /etc/issue
Red Hat Enterprise Linux AS release 3 (Taroon)
Kernel \r on an \m

[root@ollie root]# lspci
00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB USB2 (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801DB Ultra ATA Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM SMBus Controller (rev 02)
01:02.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
02:1c.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
02:1d.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
02:1e.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
02:1f.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
03:02.0 Ethernet controller: Intel Corp. 82546EB Gigabit Ethernet Controller
(Copper) (rev 01)
03:02.1 Ethernet controller: Intel Corp. 82546EB Gigabit Ethernet Controller
(Copper) (rev 01)

The box didn't have a problem installing or running with the ATA CDROM under RH AS3,
as you might note.

> > I'm
> > a little concerned the NPF reply to this install bug from your QA
> > lab is likely the same regression set used to test FC6T2 last month.
> > I can only assume the problem wasn't seen that cycle either.
> >
> >

> We haven't seen anything like this.  Could you update the closed BZ with
> the info in your original reply?

Will do. I suggest that your staff reopen it until formally resolved, as an NPF
just because the QA regression didn't see it for either FC6T2 or FC6T3 isn't
enough data to close the ticket.

John

PS ... this is how far the text install got before failing without a cdrom:

[root@ollie root]# ls -R /fedora
/fedora:
boot  dev  etc  lost+found  proc  rhinstall-stage2.img  root  selinux  sys  tmp  var

/fedora/boot:
efi

/fedora/boot/efi:

/fedora/dev:

/fedora/etc:
fstab  hosts  modprobe.conf  mtab  resolv.conf  rpm  sysconfig  X11

/fedora/etc/rpm:
macros  platform

/fedora/etc/sysconfig:
network  network-scripts

/fedora/etc/sysconfig/network-scripts:
ifcfg-eth0  ifcfg-eth1

/fedora/etc/X11:

/fedora/lost+found:

/fedora/proc:

/fedora/root:
install.log  install.log.syslog

/fedora/selinux:

/fedora/sys:

/fedora/tmp:

/fedora/var:
cache  lib  tmp

/fedora/var/cache:
yum

/fedora/var/cache/yum:

/fedora/var/lib:
rpm

/fedora/var/lib/rpm:
__db.001  __db.002  __db.003  Packages  Providename

/fedora/var/tmp:
[root@ollie root]#
Comment 4 Prarit Bhargava 2006-09-12 19:07:17 EDT
John, could you try grabbing the latest fedora development tree and http/ftp/nfs
installing it?

Thanks,

P.
Comment 5 John Bass 2006-10-25 08:23:46 EDT
See: [Bug 211963] Text Install failes with RPM unable to access packages, cdrom
not mounted

Posted with log files from install attempt based on FC6T3 iso images on a
different machine.
Comment 6 Matthew Miller 2007-04-06 12:34:41 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 7 Bug Zapper 2008-04-03 23:41:51 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 8 Bug Zapper 2008-05-06 12:19:31 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.