Bug 205982 - xterm hangs on xinerama
Summary: xterm hangs on xinerama
Status: CLOSED DUPLICATE of bug 134930
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 240428 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-11 07:31 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-03-29 12:53:19 UTC


Attachments (Terms of Use)
xorg.conf for xinerama (3.50 KB, text/plain)
2006-09-11 07:32 UTC, Ralf Ertzinger
no flags Details
List of all installed xorg packages (I hope) (3.24 KB, text/plain)
2006-09-11 07:33 UTC, Ralf Ertzinger
no flags Details
strace output for the first (failed), second (failed) and third (succeeded) xterm start attempt while running xinerama (102.58 KB, application/octet-stream)
2006-09-11 07:43 UTC, Ralf Ertzinger
no flags Details
Backtrace (3.91 KB, text/plain)
2007-02-13 16:35 UTC, Lukas Doktor
no flags Details

Description Ralf Ertzinger 2006-09-11 07:31:39 UTC
Description of problem:
OK, this one is pretty strange.
I am running a dualhead xinerama setup (two graphics cards). Config is attached.
Immediately after logging into gnome it takes several attempts to start a
working xterm. The first attempt usually results in a black window (I use
yellowish-on-black) which does not react to any input and has to be xkill-ed.
The second start attempt gets a bit further and displays some characters of my
prompt and hangs then. The third attempt usually produces a workable xterm. All
further opened xterms work as intended.

The funny thing is that xterm behaves completely normally if I go back to a
single screen X setup (just disabling the second screen)

Version-Release number of selected component (if applicable):
xterm-215-3.fc6


How reproducible:
Always (on xinerama)

Steps to Reproduce:
1. configure xinerama setup
2. log in
3. start xterm
  
Actual results:
Takes several attempts to create a working xterm

Expected results:
Immediate working xterm (as in single screen mode)

Additional info:

Comment 1 Ralf Ertzinger 2006-09-11 07:32:33 UTC
Created attachment 135974 [details]
xorg.conf for xinerama

Comment 2 Ralf Ertzinger 2006-09-11 07:33:06 UTC
Created attachment 135975 [details]
List of all installed xorg packages (I hope)

Comment 3 Ralf Ertzinger 2006-09-11 07:43:29 UTC
Created attachment 135976 [details]
strace output for the first (failed), second (failed) and third (succeeded) xterm start attempt while running xinerama

Comment 4 Miroslav Lichvar 2006-09-21 11:13:34 UTC
I didn't manage to reproduce it and the strace logs don't have much difference.
More info would be appreciated.

Did it start with some specific version of xterm? Was it ok in FC5? Have you
more than one CPU?

Comment 5 Ralf Ertzinger 2006-09-22 08:26:34 UTC
I just tried to install the xterm packages from FC5 and FC4. Both show the same
behaviour.

So... I am inclined to believe that this is not xterm issue but has something to
do with the rest of X. I can not tell when this behaviour started, since it
started right after adding a second screen.

Is there some kind of "strace for X" that can deliver more information about
what exactly is going on?

Comment 6 Miroslav Lichvar 2006-09-22 11:40:21 UTC
Ok, you can compile xterm with tracing enabled:
rpmbuild -bb -D 'enable_trace 1' xterm.spec

xterm compiled with this option will produce Trace-*.out files in current directory.

Comment 7 Lukas Doktor 2007-02-13 16:35:58 UTC
Created attachment 148002 [details]
Backtrace

Hi, I'm having the same problem. When I run anything what use ncurses
(mc,centericq..) it sometime freeze.

Xinerama "On"
Graphic Driver "fglrx"
xterm-215-4.el5, xterm-223-3.fc7  (both i386, x86_64)
Xdefaults:  xterm*scrollBar: False, *background: Black, *foreground: White

Comment 8 Chris Underhill 2007-03-28 20:28:03 UTC
I can reproduce this problem on FC7 Test 2. Release is xterm-224-2.fc7.x86_64.
Setup is triple-headed using the latest NVidia driver (1.0-9755), with two
PCI-Express GeForce 7300GS cards. With xinerama switched off, xterm works fine.

Comment 9 Miroslav Lichvar 2007-03-29 12:53:19 UTC
I finally reproduced the problem and it looks like duplicate of bug #134930,
reported upstream at https://bugs.freedesktop.org/show_bug.cgi?id=3040.

If you don't need UTF-8 mode, you can avoid the bug with resource:
XTerm.vt100.utf8: 0

*** This bug has been marked as a duplicate of 134930 ***

Comment 10 Miroslav Lichvar 2007-05-17 14:58:20 UTC
*** Bug 240428 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.