Bug 240428 - xterm hangs when reattaching to a remote screen session
xterm hangs when reattaching to a remote screen session
Status: CLOSED DUPLICATE of bug 205982
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-17 10:31 EDT by David Aquilina
Modified: 2014-06-23 20:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 10:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of xterm hanging when attempting to attach to a screen session (98.98 KB, application/octet-stream)
2007-05-17 10:31 EDT, David Aquilina
no flags Details

  None (edit)
Description David Aquilina 2007-05-17 10:31:39 EDT
Description of problem:
xterm will hang when you try to reattach to a screen session on a remote system.
I'm logged into the remote system via ssh. It happens on multiple remote systems
as well - one is an FC6 x86_64 system, the other is an Irix system. 

Version-Release number of selected component (if applicable):
xterm-225-2.fc7.i386

How reproducible:
Almost always. If I kill xterm and try again repeatedly, sometimes it will work.
If it does work, xterm will then function normally for as long as the system is up. 

Steps to Reproduce:
1. Start xterm
2. Login to remote system via ssh (simple "ssh hostname") 
3. Attach to a screen session ("screen -dr")
  
Actual results:
xterm hangs after printing one or two lines of the screen session

Expected results:
xterm should not hang 

Additional info:
This problem does not occur when attaching to a local screen session. This
problem also does not occur on gnome-terminal, so I don't believe this is a
networking or ssh problem.
Comment 1 David Aquilina 2007-05-17 10:31:39 EDT
Created attachment 154920 [details]
strace of xterm hanging when attempting to attach to a screen session
Comment 2 Miroslav Lichvar 2007-05-17 10:58:18 EDT

*** This bug has been marked as a duplicate of 205982 ***

Note You need to log in before you can comment on or make changes to this bug.