Bug 206001 - [si_LK][Glyphs] shape for characters (glyphs) are wrong
[si_LK][Glyphs] shape for characters (glyphs) are wrong
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lklug-fonts (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
: i18n, Reopened
Depends On:
Blocks: Sinhala 209572
  Show dependency treegraph
 
Reported: 2006-09-11 09:33 EDT by A S Alam
Modified: 2013-07-02 20:40 EDT (History)
9 users (show)

See Also:
Fixed In Version: lklug-fonts-0.6-1.20090803cvs.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 03:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Wrong Image (675 bytes, image/png)
2006-09-11 09:33 EDT, A S Alam
no flags Details
Correct image (675 bytes, image/png)
2006-09-11 09:34 EDT, A S Alam
no flags Details
Wrong Image (1.71 KB, image/png)
2006-09-11 09:46 EDT, A S Alam
no flags Details
Final Fixed font file to this bug (309.58 KB, application/x-font-ttf)
2006-11-28 01:55 EST, Parag Nemade
no flags Details
Fixed Font file (309.52 KB, application/x-font-ttf)
2006-12-14 00:47 EST, Parag Nemade
no flags Details
Al-Mayanna (U+0DB8,U+0DCA) (2.79 KB, image/png)
2009-07-21 02:06 EDT, Harshula Jayasuriya
no flags Details
Miyanna (U+0DB8,U+0DD2) (2.70 KB, image/png)
2009-07-21 02:18 EDT, Harshula Jayasuriya
no flags Details
showing all combination involved in bug (37.57 KB, image/png)
2009-07-22 01:25 EDT, Pravin Satpute
no flags Details
Pure consonants (Al letters) containing an ascender (11.45 KB, image/png)
2009-07-23 02:46 EDT, Harshula Jayasuriya
no flags Details

  None (edit)
Description A S Alam 2006-09-11 09:33:46 EDT
Description of problem:
Shape for character combination is wrong with following unicode
0db8+0dca

Version-Release number of selected component (if applicable):
fonts-sinhala-0.2-4

How reproducible:


Steps to Reproduce:
1.open gedit
2. type with Raw unicode
3. 0DB8+0DCA
  
Actual results:
Image attached

Expected results:
Image attached

Additional info:
Comment 1 A S Alam 2006-09-11 09:33:46 EDT
Created attachment 135987 [details]
Wrong Image
Comment 2 A S Alam 2006-09-11 09:34:34 EDT
Created attachment 135988 [details]
Correct image
Comment 3 A S Alam 2006-09-11 09:46:49 EDT
Created attachment 135992 [details]
Wrong Image
Comment 6 Lawrence Lim 2006-10-06 00:31:19 EDT
Rahul,
Could you please let me knoe what is the priority of this Bug? A, B or C? 
Comment 7 Rahul Bhalerao 2006-10-06 02:29:12 EDT
This is priority B bug.
Comment 9 Parag Nemade 2006-11-28 01:55:04 EST
Created attachment 142264 [details]
Final Fixed font file to this bug
Comment 10 Parag Nemade 2006-12-14 00:47:09 EST
Created attachment 143594 [details]
Fixed Font file
Comment 11 Parag Nemade 2007-01-05 00:13:11 EST
This Fix has been tested in its clone RHEL BUG 209752. 
This Fix is included now in fonts-sinhala-0.2.2-1.fc6 rpm 
Comment 12 Danishka Navin 2007-11-21 05:16:06 EST
working on RHEL 5.1
Comment 13 Harshula Jayasuriya 2009-07-21 02:06:42 EDT
Created attachment 354436 [details]
Al-Mayanna (U+0DB8,U+0DCA)
Comment 14 Harshula Jayasuriya 2009-07-21 02:18:14 EDT
Created attachment 354437 [details]
Miyanna (U+0DB8,U+0DD2)
Comment 15 Harshula Jayasuriya 2009-07-21 03:44:33 EDT
Hi,

I recently noticed that Al-Mayanna (U+0DB8,U+0DCA) on Fedora 11 looks incorrect:
https://bugzilla.redhat.com/attachment.cgi?id=142050

It looks like a Mayanna (U+0DB8) which has been compressed vertically and then an is-pilla (U+0DD2) placed on it. The particular is-pilla glyph that has been used is meant only for glyphs without an ascender. Furthermore, due to this change Al-Mayanna now looks inconsistent with the Al (Virama) form of all the other letters that contain an ascender.

My view is that Al-Mayanna (U+0DB8,U+0DCA) looked *more* correct before this change. i.e. This change causes a regression.

Furthermore, I think these are all valid Al-Mayanna glyphs:
* https://bugzilla.redhat.com/attachment.cgi?id=135992
* https://bugzilla.redhat.com/attachment.cgi?id=135988
* https://bugzilla.redhat.com/attachment.cgi?id=354436

Whereas, this is a Miyanna:
https://bugzilla.redhat.com/attachment.cgi?id=354437

I think the difference between the Al-Mayanna and Miyanna is the sharp point at the top left corner of the Al-Mayanna. I will double check on this.

It would appear that Bug 209572 contains most of the discussion regarding this particular bug.

My recommendation is to revert back to the previous Al-Mayanna glyph.

cya,
#
Comment 16 Pravin Satpute 2009-07-22 01:25:28 EDT
Created attachment 354651 [details]
showing all combination involved in bug

hi harshula,

i think whatever we have presently is correct? i.e style of showing cap on MAYANNA is same, sharp edge is present

also danishka has also added Comment #12 that all thing are ok and same thing is available from fc6

do you want it to revert back as it was previously previously?
Comment 17 Harshula Jayasuriya 2009-07-22 01:36:20 EDT
Hi Pravin,
Comment 18 Harshula Jayasuriya 2009-07-22 01:52:19 EDT
I've added Danishka to the CC list.

Hi Danishka,

Can you please have a look at ම් (Al-Mayanna) on Fedora. Do you think that looks correct? Have a look at ච්, ට්, ඩ්, ඬ්, බ්, ම්, ඹ්, ව්, which one do you think looks out of place?

In https://bugzilla.redhat.com/show_bug.cgi?id=206001#c12 you say "working on RHEL 5.1". It clearly looks incorrect. The Mayanna has been compressed vertically and an Is-Pilla glyph placed on top.

cya,
#
Comment 19 Danishka Navin 2009-07-22 12:36:07 EDT
Hi Harshula,

Right now i am not on RHEL 

 ම් (Al-Mayanna) is fine for me on Fedora 11

but i want to double check " ච්, ට්, ඩ්, ඬ්, බ්, ඹ්, ව්" with a language expert. 

cya.
Comment 20 Harshula Jayasuriya 2009-07-22 21:56:20 EDT
Hi Danishka,

1) Can you please describe what is wrong with the original Al-Mayanna:
https://bugzilla.redhat.com/attachment.cgi?id=135992

2) Can you please describe any problems with this Al-Mayanna:
https://bugzilla.redhat.com/attachment.cgi?id=354436

cya,
#
Comment 21 Harshula Jayasuriya 2009-07-23 02:46:11 EDT
Created attachment 354818 [details]
Pure consonants (Al letters) containing an ascender
Comment 22 Danishka Navin 2009-07-24 12:55:06 EDT
(In reply to comment #16)
> Created an attachment (id=354651) [details]
> showing all combination involved in bug
> 
> hi harshula,
> 
> i think whatever we have presently is correct? i.e style of showing cap on
> MAYANNA is same, sharp edge is present
> 
> also danishka has also added Comment #12 that all thing are ok and same thing
> is available from fc6
> 
> do you want it to revert back as it was previously previously?  

Hi Pravin,

I agree with Harshula.

Yes we need to revert al-mayanna

pls note, it is hard to find the difference between ව and ව් .
we need to modify "ච්, ට්, ඩ්, ඬ්, බ්, ඹ්, ව්"  near future.
Comment 23 Parag Nemade 2009-08-07 03:05:15 EDT
Fixed in lklug-fonts-0.6-1.20090803cvs.fc12

Note You need to log in before you can comment on or make changes to this bug.