Bug 206108 - [si_LK] Rendering problem in OOo for "kRoo" key combination (same as gnome)
[si_LK] Rendering problem in OOo for "kRoo" key combination (same as gnome)
Status: CLOSED DUPLICATE of bug 206261
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 02:25 EDT by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 04:52:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
picture of gedit and OOo side by side (6.29 KB, image/png)
2006-09-15 06:02 EDT, Caolan McNamara
no flags Details
The correct visual representation (10.06 KB, image/png)
2006-09-15 12:41 EDT, Tyronne Wickramarathne
no flags Details

  None (edit)
Description Jens Petersen 2006-09-12 02:25:23 EDT
+++ This bug was initially created as a clone of Bug #200403 +++

Description of problem:
with m17n-db-sinhala and scim-sinhala package, there are 3 layouts
>sinhala
>wijesekera
>samanala
with sinhala/wijesekera, there is problem with input some characters, but same
characters are work properly with 'samanala'. C 'n' P is also working from gedit

Version-Release number of selected component (if applicable):

scim-1.4.4-25.fc6
scim-sinhala-0.1.0-3.fc6
m17n-db-sinhala-1.3.3-14.fc6

How reproducible:


Steps to Reproduce:
1. open kedit
2. select scim-sinhala 
3. type  ko
4. with  wijesekera
5. type  fdl
6. repeat step with gedit to see correct output

Actual results:
wrong rendering in kedit/Openoffice

Expected results:
Result should be like gedit

Additional info:

-- Additional comment from llch@redhat.com on 2006-07-28 00:59 EST --
Aman, Can you cut and paste the characters and see if OOo or kedit renders
correctly? If not then it is not about input method but it is a rendering problem.

-- Additional comment from aalam@redhat.com on 2006-07-28 04:31 EST --
Yes,
copy 'n' paste is also working from gedit

-- Additional comment from llch@redhat.com on 2006-08-07 02:44 EST --
My question was: Does cut and paste works with OOo and kedit?

-- Additional comment from aalam@redhat.com on 2006-08-24 09:54 EST --
correct in kedit, but not correct in Openoffice (copy Paste from gedit)

-- Additional comment from petersen@redhat.com on 2006-08-25 08:30 EST --
Hopefully this will be fixed when we upgrade to scim-sinhala-0.2.0
which no longer uses surrounding text.

-- Additional comment from petersen@redhat.com on 2006-08-25 08:35 EST --
I confirmed this with a local snapshot build of scim-sinhala-trans cvs.


-- Additional comment from petersen@redhat.com on 2006-08-27 22:57 EST --
scim-sinhala should be fixed in 0.2.0-1.fc6.  Please open
a separate bug for si-wijesekera.mim if necessary.
(Note that scim-sinhala-wijesekera exists in sinhala cvs on sourceforge
which should also solve this problem for wijesekera.)

-- Additional comment from caolanm@redhat.com on 2006-08-28 07:15 EST --
FWIW I implemented the "surrounding text" callbacks in OOo recently (through a
mighty hack), so this had begun to work the same as gedit anyway with the
existing sinhala im engine in OOo in rawhide.

-- Additional comment from tagoh@redhat.com on 2006-08-29 04:40 EST --
(In reply to comment #8)
> FWIW I implemented the "surrounding text" callbacks in OOo recently (through a
> mighty hack), so this had begun to work the same as gedit anyway with the
> existing sinhala im engine in OOo in rawhide.

the problem is that it works on gtkimm and probably on qtimm - depends on which
version of qtimm we use - but there are no "surrounding text" support on XIM. so
it may be not help if one inputs through XIM on OOo, (and OOo is running on KDE
if qtimm doesn't support it)

-- Additional comment from aalam@redhat.com on 2006-08-31 10:16 EST --
Openoffice it is ok, but for kde, it is not working.

-- Additional comment from petersen@redhat.com on 2006-08-31 17:07 EST --
(In reply to comment #10)
> Openoffice it is ok, but for kde, it is not working.

Which IME is that for?  HAve you tested scim-sinhala-0.2.0?

-- Additional comment from aalam@redhat.com on 2006-08-31 23:14 EST --
yes, with scim-sinhala:
scim-sinhala-0.2.0-1.fc6

-- Additional comment from petersen@redhat.com on 2006-09-01 04:34 EST --
Could you attach some screenshots to show an example of the problem?
Please include the keyboard input too.

You may want to test with scim-bridge-qtimm too to see if that it any better.

-- Additional comment from tywickra@redhat.com on 2006-09-06 10:43 EST --
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. open kedit
> 2. select scim-sinhala 
> 3. type  ko

works fine with scim-sinhala-0.2.0

> 4. with  wijesekera
> 5. type  fdl

this has to be fld

> 6. repeat step with gedit to see correct output

-- Additional comment from llch@redhat.com on 2006-09-11 02:28 EST --
Tyronne reporetd scim-sinhala-0.2.0 is fine, but not with scim-m17n. Reassigning
to scim-m17n.

Jens, Mayank, does scim-m17n-sinhala use surrounding text callback?

-- Additional comment from majain@redhat.com on 2006-09-11 02:55 EST --
Hi Leon,

The characters "ko" (scim-sinhala) and "fld" (wijesekera) are showing exactly
the same ligerature.

Do you still need the NEEDINFO? 
I think this bug is fixed already in Rawhide.

-- Additional comment from majain@redhat.com on 2006-09-12 02:05 EST --
Tested on fc6t3 with following results

Kedit - combinations work as expected
oowriter - broken rendering - on both kde & gnome desktops.

As discussed, lets close this bug for kedit & file a new one for oowriter.

Versions tested with
oowriter - openoffice.org-writer-2.0.4-3.1
kedit - kdeutils-3.5.4-2.fc6
Pango - pango-1.14.3-1.fc6
libicu - libicu-3.6-1
Comment 1 Mayank Jain 2006-09-12 06:42:30 EDT
Changing the component to ICU as its a rendering problem.

Also, Tyronne tested "kRoo" key combination with icu-3.6-2.i386.rpm & it was
still not working, however, when he copied & pasted the output of this key
combination from oo.org-writer to gedit, it showed up properly.

Thanks,
Mayank
Comment 2 Mayank Jain 2006-09-12 06:46:37 EDT
Changing bug description from "[si_LK] input is problem in OOo" to more
appropriate text :)
Comment 3 Tyronne Wickramarathne 2006-09-15 02:20:20 EDT
i have both open office 1.1.5 and 2.0.3 installed. 

> Also, Tyronne tested "kRoo" key combination with icu-3.6-2.i386.rpm & it was
> still not working, however, when he copied & pasted the output of this key
> combination from oo.org-writer to gedit, it showed up properly.
> 
scenario 1: open office 1.1.5
when you select scim-sinhala and type "kRoo" on open office, it doesn't appear
properly but when you copy and paste it on gedit, it looks fine.

---
scenario 2: open office 2.0.3
when you select scim-sinhala and type "kRoo" on open office, it doesn't appear
properly, even if you copy and paste it on gedit, it doesn't appear properly.
Comment 4 Caolan McNamara 2006-09-15 05:50:43 EDT
> rpm -q openoffice.org-core icu
openoffice.org-core-2.0.4-3.1
icu-3.6-1

> oowriter
ctrl+space, select sinhala
> kRoo

works fine (for me)

a) I'd expect cut and paste to work in 1.1.5 but input not to work because the
surrounding text for the IM was not implemented
b) I'd expect neither to work in 2.0.3 < 2.0.3-7.8 as the ZWJ was additionally
filtered out when rendereding from 2.0.X until then
c) but I'd expect for 2.0.4 that the ZWJ is not filtered out so the cut and
paste would work again, and the surrounding text implementation was added so
that the input mechanism would also work

I'll attach a picture of what I get in OOo and gedit for 
kRoo
ko
and fld
Comment 5 Caolan McNamara 2006-09-15 06:02:41 EDT
Created attachment 136338 [details]
picture of gedit and OOo side by side

so it looks the same for me in OOo and gedit when I type with scim-sinhala
Comment 6 Tyronne Wickramarathne 2006-09-15 12:41:20 EDT
Created attachment 136374 [details]
The correct visual representation

i have attached the correct visual representation of the said.
Comment 7 Tyronne Wickramarathne 2006-09-15 12:49:28 EDT
(In reply to comment #5)
> Created an attachment (id=136338) [edit]
> picture of gedit and OOo side by side
> 
> so it looks the same for me in OOo and gedit when I type with scim-sinhala
yes, gedit sufferrs with the same problem. (pls ref bug id 204922)

it doesn't render properly on gedit. but on kedit, it does. i have attached the
correct visual representation of kRoo under the comment #6.
Comment 8 Jens Petersen 2006-09-18 04:11:16 EDT
So this is a pango issue?
Comment 9 Caolan McNamara 2006-09-18 05:04:30 EDT
Ok, I inputted the keystrokes into kedit and pasted that text into gedit and it
renders fine, similiarly the text renders fine in OOo so it's not a rendering
problem IMO.

so...
a) taking the final text and pasting into gedit/kedit and OOo shows the same
text, agreed ?
b) typing the keystrokes into writer and gedit give the same wrong results
c) typing the keystrokes into kedit gives the correct result

-> I reckon it's a problem with the IM, presumably solely the gtk-im

I'm sure this was working until recently, perhaps the scim-sinhala rework has
triggered this change.
Comment 10 Tyronne Wickramarathne 2006-09-18 10:57:09 EDT
(In reply to comment #9)
> I'm sure this was working until recently, perhaps the scim-sinhala rework has
> triggered this change.

i have scim-sinhala-0.2.0-1.fc6 installed on RHEL5 beta 1. but quite
surprisingly the problem i have indicated under bug id 204922 is not appearing
on RHEL5 beta-1. so it works fine in both Gedit and Kedit.
Comment 11 Caolan McNamara 2006-09-26 04:52:59 EDT
ok, this issue boils down to the difference shown in the pic in comment 6, and
that difference (and it's variability in occuring) is not icu and rendering, but
what characters actually get committed to gedit and OOo from the IM.

When the scim-bridge gtk im commits a backspace and then commits a new string
the desire is to replace the previous character with the new string, but the
order that the events are processed by gtk are actually string commit and then
the backspace, cancelling out the effect of the 2nd character of any double
vowel sequences. The original scim gtk im has some specific code to avoid this
scenario which probably needs to be cloned into scim-bridge

*** This bug has been marked as a duplicate of 206261 ***

Note You need to log in before you can comment on or make changes to this bug.