Bug 200403 - [si_LK] Qt IM lacks surrounding-text support
[si_LK] Qt IM lacks surrounding-text support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: FutureFeature, i18n, Reopened
Depends On:
Blocks: SCIM Sinhala
  Show dependency treegraph
 
Reported: 2006-07-27 10:37 EDT by A S Alam
Modified: 2013-07-02 20:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 12:31:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Problem with wijesekera (1.13 MB, image/png)
2006-09-26 08:25 EDT, Mayank Jain
no flags Details
test case with fld (7 bytes, text/plain)
2006-09-27 07:04 EDT, Mayank Jain
no flags Details

  None (edit)
Description A S Alam 2006-07-27 10:37:25 EDT
Description of problem:
with m17n-db-sinhala and scim-sinhala package, there are 3 layouts
>sinhala
>wijesekera
>samanala
with sinhala/wijesekera, there is problem with input some characters, but same
characters are work properly with 'samanala'. C 'n' P is also working from gedit

Version-Release number of selected component (if applicable):

scim-1.4.4-25.fc6
scim-sinhala-0.1.0-3.fc6
m17n-db-sinhala-1.3.3-14.fc6

How reproducible:


Steps to Reproduce:
1. open kedit
2. select scim-sinhala 
3. type  ko
4. with  wijesekera
5. type  fdl
6. repeat step with gedit to see correct output

Actual results:
wrong rendering in kedit/Openoffice

Expected results:
Result should be like gedit

Additional info:
Comment 1 Leon Ho 2006-07-28 00:59:30 EDT
Aman, Can you cut and paste the characters and see if OOo or kedit renders
correctly? If not then it is not about input method but it is a rendering problem.
Comment 2 A S Alam 2006-07-28 04:31:38 EDT
Yes,
copy 'n' paste is also working from gedit
Comment 3 Leon Ho 2006-08-07 02:44:49 EDT
My question was: Does cut and paste works with OOo and kedit?
Comment 4 A S Alam 2006-08-24 09:54:38 EDT
correct in kedit, but not correct in Openoffice (copy Paste from gedit)
Comment 5 Jens Petersen 2006-08-25 08:30:30 EDT
Hopefully this will be fixed when we upgrade to scim-sinhala-0.2.0
which no longer uses surrounding text.
Comment 6 Jens Petersen 2006-08-25 08:35:18 EDT
I confirmed this with a local snapshot build of scim-sinhala-trans cvs.
Comment 7 Jens Petersen 2006-08-27 22:57:01 EDT
scim-sinhala should be fixed in 0.2.0-1.fc6.  Please open
a separate bug for si-wijesekera.mim if necessary.
(Note that scim-sinhala-wijesekera exists in sinhala cvs on sourceforge
which should also solve this problem for wijesekera.)
Comment 8 Caolan McNamara 2006-08-28 07:15:39 EDT
FWIW I implemented the "surrounding text" callbacks in OOo recently (through a
mighty hack), so this had begun to work the same as gedit anyway with the
existing sinhala im engine in OOo in rawhide.
Comment 9 Akira TAGOH 2006-08-29 04:40:47 EDT
(In reply to comment #8)
> FWIW I implemented the "surrounding text" callbacks in OOo recently (through a
> mighty hack), so this had begun to work the same as gedit anyway with the
> existing sinhala im engine in OOo in rawhide.

the problem is that it works on gtkimm and probably on qtimm - depends on which
version of qtimm we use - but there are no "surrounding text" support on XIM. so
it may be not help if one inputs through XIM on OOo, (and OOo is running on KDE
if qtimm doesn't support it)
Comment 10 A S Alam 2006-08-31 10:16:25 EDT
Openoffice it is ok, but for kde, it is not working.
Comment 11 Jens Petersen 2006-08-31 17:07:12 EDT
(In reply to comment #10)
> Openoffice it is ok, but for kde, it is not working.

Which IME is that for?  HAve you tested scim-sinhala-0.2.0?
Comment 12 A S Alam 2006-08-31 23:14:31 EDT
yes, with scim-sinhala:
scim-sinhala-0.2.0-1.fc6
Comment 13 Jens Petersen 2006-09-01 04:34:21 EDT
Could you attach some screenshots to show an example of the problem?
Please include the keyboard input too.

You may want to test with scim-bridge-qtimm too to see if that it any better.
Comment 14 Tyronne Wickramarathne 2006-09-06 10:43:48 EDT
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. open kedit
> 2. select scim-sinhala 
> 3. type  ko

works fine with scim-sinhala-0.2.0

> 4. with  wijesekera
> 5. type  fdl

this has to be fld

> 6. repeat step with gedit to see correct output
Comment 15 Leon Ho 2006-09-11 02:28:33 EDT
Tyronne reporetd scim-sinhala-0.2.0 is fine, but not with scim-m17n. Reassigning
to scim-m17n.

Jens, Mayank, does scim-m17n-sinhala use surrounding text callback?
Comment 16 Mayank Jain 2006-09-11 02:55:33 EDT
Hi Leon,

The characters "ko" (scim-sinhala) and "fld" (wijesekera) are showing exactly
the same ligerature.

Do you still need the NEEDINFO? 
I think this bug is fixed already in Rawhide.
Comment 17 Mayank Jain 2006-09-12 02:05:34 EDT
Tested on fc6t3 with following results

Kedit - combinations work as expected
oowriter - broken rendering - on both kde & gnome desktops.

As discussed, lets close this bug for kedit & file a new one for oowriter.

Versions tested with
oowriter - openoffice.org-writer-2.0.4-3.1
kedit - kdeutils-3.5.4-2.fc6
Pango - pango-1.14.3-1.fc6
libicu - libicu-3.6-1
Comment 18 Jens Petersen 2006-09-12 02:38:29 EDT
OO.o issue was cloned to bug 206108.
Comment 19 Mayank Jain 2006-09-26 08:25:57 EDT
Created attachment 137130 [details]
Problem with wijesekera

Scim-sinhala works fine with kedit, while wijesekera does not.
qt-3.3.6-13
kdeutils-3.5.4-3.fc6
Comment 20 Tyronne Wickramarathne 2006-09-26 09:38:31 EDT
(In reply to comment #19)
> Created an attachment (id=137130) [edit]

select M17N-wijesekara
open kedit
type fld

referring to the attached image, when the M17N-wijesekara is used. a dotted
circle gets appeared between SINHALA VOWEL SIGN KOMBUWA (U+0DD9) and SINHALA
LETTER ALPAPRAANA KAYANNA (U+0D9A).

this is a bug, and the circle should get dissappeared when SINHALA LETTER
ALPAPRAANA KAYANNA (U+0D9A) is typed.

the key sequencec to type in this test case are as follows:fld

Pre Conditions :
----------------
Select M17N-wijesekara in SCIM
Open Kedit


STEP #1
-------
type "f" ;
SINHALA VOWEL SIGN KOMBUWA (U+0DD9) appears with a dotted circle. 


STEP #2
-------
type "l" ;
SINHALA LETTER ALPAPRAANA KAYANNA (U+0D9A) appears and the dotted circle, which
appeared at STEP #1 should get dissappeared.

but this is not happenning. the dotted circle remains the same. that's the bug
we have to fix.
Comment 21 Jens Petersen 2006-09-26 11:15:29 EDT
As noted in bug 208104 some recent patches to scim-m17n and m17n-lib
I believe should allow it to fallback to preedit when the client does
not support surrounding-text.

I suggest filing a new rfe bug to track qtimm getting surrounding-text support.
Comment 22 Mayank Jain 2006-09-27 07:02:40 EDT
Okay, did a small test...
Wrote "fld" on a test machine where it was working, scp'd the file to a rawhide
machine & then opened it in all 3 - gedit/kedit/oo.o and it shows up perfectly
in all 3.

Hence I can now confirm that its a scim-sinhala bug.

Had it been a font issue, the ligerature had not rendered on any of 3 editors,
had it been a pango issue, it must have rendered incorrectly for gedit, same
with qt/icu.

Jens... anything on this?
Comment 23 Mayank Jain 2006-09-27 07:04:17 EDT
Created attachment 137208 [details]
test case with fld

Open this file in gedit/kedit/oo.o
Comment 24 Mayank Jain 2006-09-27 07:06:39 EDT
Oops, i'm completely sorry, I meant its a wijesekera bug (surrounding text maybe).
Comment 25 Jens Petersen 2006-10-01 00:46:58 EDT
(In reply to comment #21)
> As noted in bug 208104 some recent patches to scim-m17n and m17n-lib
> I believe should allow it to fallback to preedit when the client does
> not support surrounding-text.

Okay, I looked into this a bit further and it is not quite as high level
as I had initially optimistically thought.  Basically the fallback currently
has to be implemented in the map itself: upstream has does this so far in cvs
for the Thai maps but not for Wijesekera: so currently either Wijesekera needs
to be redone from scratch not to use surrounding-text or better add the
the new test for whether surrounding-text is available and provide alternative
input processing using preedit when it is not.  Ie the new feature is basically
just to allow maps to test whether surrounding-text is available or not.
Comment 26 Jens Petersen 2006-10-06 09:00:41 EDT
M17N upstream has created a Wijesekera test input map that uses preedit.
Comment 27 Mayank Jain 2006-11-06 06:51:23 EST
Since this is fixed in current release for devel branch, moving to modified.
Comment 28 Jens Petersen 2006-11-06 20:10:37 EST

*** This bug has been marked as a duplicate of 208104 ***
Comment 29 Mayank Jain 2006-11-07 00:37:20 EST
Thanks Jens :)
Comment 30 Ngo Than 2006-11-10 10:41:23 EST
Mayank, Jens, is the new package m17n-db already included in RHEL5-beta2?
Can i now change state of #208104 to Modified since it's duplicate of this 
bug? thanks
Comment 31 Jens Petersen 2006-11-12 20:46:21 EST
Not really this bug is now intended as a rfe to track adding
surrounding text support to Qt IM.
Comment 32 Mayank Jain 2006-11-13 01:50:37 EST
Yes, the builds should be there... as per comment 15 in bug 208104, builds were
sent for Beta2 on 2006-11-07.
Comment 33 Ngo Than 2006-11-28 06:23:26 EST
it's a feature request, so i close it as DEFFERRED.
Comment 34 Jens Petersen 2006-11-28 19:05:19 EST
Ok, but the idea of this bug was to track this for Fedora devel.

Note You need to log in before you can comment on or make changes to this bug.