Bug 206177 - crash on ESC to interrupt slideshow with transisitions
crash on ESC to interrupt slideshow with transisitions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 13:37 EDT by Alexey Titov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.2-5.19.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 04:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Open office debug info (5.37 KB, application/octet-stream)
2006-09-12 13:37 EDT, Alexey Titov
no flags Details
next crash debug info (2.32 KB, application/octet-stream)
2006-09-12 13:39 EDT, Alexey Titov
no flags Details
next crash debug info (5.10 KB, application/octet-stream)
2006-09-12 13:40 EDT, Alexey Titov
no flags Details
next crash debug info (4.72 KB, application/octet-stream)
2006-09-12 13:42 EDT, Alexey Titov
no flags Details
one more crash (4.36 KB, application/octet-stream)
2006-09-14 15:28 EDT, Alexey Titov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 69236 None None None Never

  None (edit)
Description Alexey Titov 2006-09-12 13:37:28 EDT
Description of problem:
Open office became to crash very often after system update. It happens too often
and it is very hard to work now...

Version-Release number of selected component (if applicable):
2.0.2

How reproducible:
I cannot reproduce the crash, it seems it occurs unexpectedly...

Additional info:
There is debug info in attachment. I hope it can help...
Comment 1 Alexey Titov 2006-09-12 13:37:28 EDT
Created attachment 136091 [details]
Open office debug info
Comment 2 Alexey Titov 2006-09-12 13:39:34 EDT
Created attachment 136092 [details]
next crash debug info
Comment 3 Alexey Titov 2006-09-12 13:40:51 EDT
Created attachment 136093 [details]
next crash debug info
Comment 4 Alexey Titov 2006-09-12 13:42:49 EDT
Created attachment 136094 [details]
next crash debug info
Comment 5 Alexey Titov 2006-09-14 15:28:30 EDT
Created attachment 136296 [details]
one more crash
Comment 6 Caolan McNamara 2006-09-15 05:08:29 EDT
try and upgrade db4 again to the latest fc5 update

*** This bug has been marked as a duplicate of 205315 ***
Comment 7 Alexey Titov 2006-09-15 11:57:11 EDT
I updated db4, but impress crashes, however (may be not so often)...
It crashes after I press ESC at the end of slideshow, I thik. But I can mistake...
Here is it's dying message:

Video Driver is probably: radeon
Desktop is: GNOME
libgcj version is: libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.17.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x217640: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e640
0x217e80: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1ee80
0x4e0f1420:  + 0x420 (__kernel_sigreturn + 0x0)
0x5bfd75e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x2d75e
0x5c0bb97: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3bb97
0x5c0bfa3: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3bfa3
0x5c0c15a: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c15a
0x5c0c189: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c189
0x5c0c1ae: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c1ae
0x5c0c3cb: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c3cb
0x5c0c3eb: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c3eb
0x5c947aa: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc47aa
0x5c944f1: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc44f1
0x5c7f247: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xaf247
0x5c7f270: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xaf270
0x5bfd73e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x2d73e
0x5bfd75e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x2d75e
0x5c7d2fd: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xad2fd
0x5c7d406: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xad406
0x5c7a893: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xaa893
0x5c7b104: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xab104
0x5c67b80: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x97b80
0x5c67e01: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x97e01
0x3c914d: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x1c14d (cppu::WeakComponentImplHelperBase::dispose() + 0x75)
0x5c6f7cf: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x9f7cf
0x7baf00d: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2ea00d
0x7babeff: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2e6eff
0x7babf13: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2e6f13
0x79e4901: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x11f901
0x79e4ff0: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x11fff0
0x79fc248: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x137248
0x61c2bb4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aebb4
0x61c1821: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad821
0x61c19ab: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad9ab
0x61c1a4e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ada4e
0x60bd0bc: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa90bc
0x61dafd5: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6fd5
0x61dad90: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6d90
0x61dafea: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6fea
0x61dad7c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6d7c
0xbb7246: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x83246
0xd050d2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d10d2
0x345b6f8: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1e6f8
0x347df0c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x40f0c
(SalDisplay::DispatchInternalEvent() + 0x64)
0xe09c4c: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14c4c
0x11c17a1: /usr/lib/libglib-2.0.so.0 + 0x237a1
0x11c315d: /usr/lib/libglib-2.0.so.0 + 0x2515d (g_main_context_dispatch + 0x16d)
0x11c63ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
0x11c6955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe08c23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13c23
0x34801a9: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x431a9
(X11SalInstance::Yield(unsigned char) + 0x27)
0xbbeaba: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8aaba
(Application::Yield() + 0x48)
0xbbeb3e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ab3e
(Application::Execute() + 0x26)
0x6edbf73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24f73
(desktop::Desktop::Main() + 0x15af)
0xbc296a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e96a
0xbc2a1d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea1d (SVMain()
+ 0x2b)
0x6ed5e53: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee53 (sal_main
+ 0x57)
0x6ed5e9f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee9f (main + 0x27)
0x4e994724: /lib/libc.so.6 + 0x15724 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4d1
Comment 8 Alexey Titov 2006-09-16 04:42:39 EDT
Crashed again... not after slideshow...

Video Driver is probably: radeon
Desktop is: GNOME
libgcj version is: libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.17.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x217640: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e640
0x217e80: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1ee80
0x4e0f1420:  + 0x420 (__kernel_sigreturn + 0x0)
0xcb8bce: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x184bce
0xcb8cdc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x184cdc
(FloatingWindow::EndPopupMode(unsigned short) + 0x12)
0x7396e86: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3d1e86
0x7396ea0: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3d1ea0
0x7221bb2: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x25cbb2
0x73b9429: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3f4429
0x73b9ea7: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3f4ea7
0xd04382: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d0382
0xd05b69: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d1b69
0xd049a9: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d09a9
0xe25820: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x30820
0xe23ebf: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x2eebf
0xf5958e: /usr/lib/libgtk-x11-2.0.so.0 + 0x12358e
0x122bf8b: /usr/lib/libgobject-2.0.so.0 + 0x8f8b (g_closure_invoke + 0x12b)
0x123ce3d: /usr/lib/libgobject-2.0.so.0 + 0x19e3d
0x123e10f: /usr/lib/libgobject-2.0.so.0 + 0x1b10f (g_signal_emit_valist + 0x68f)
0x123e509: /usr/lib/libgobject-2.0.so.0 + 0x1b509 (g_signal_emit + 0x29)
0x1044858: /usr/lib/libgtk-x11-2.0.so.0 + 0x20e858
0xf52f63: /usr/lib/libgtk-x11-2.0.so.0 + 0x11cf63 (gtk_propagate_event + 0x183)
0xf541b7: /usr/lib/libgtk-x11-2.0.so.0 + 0x11e1b7 (gtk_main_do_event + 0x317)
0x7f8685a: /usr/lib/libgdk-x11-2.0.so.0 + 0x4085a
0x14e815d: /usr/lib/libglib-2.0.so.0 + 0x2515d (g_main_context_dispatch + 0x16d)
0x14eb3ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
0x14eb955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe08c23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13c23
0x56941a9: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x431a9
(X11SalInstance::Yield(unsigned char) + 0x27)
0xbbeaba: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8aaba
(Application::Yield() + 0x48)
0xbbeb3e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ab3e
(Application::Execute() + 0x26)
0x6edbf73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24f73
(desktop::Desktop::Main() + 0x15af)
0xbc296a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e96a
0xbc2a1d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea1d (SVMain()
+ 0x2b)
0x6ed5e53: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee53 (sal_main
+ 0x57)
0x6ed5e9f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee9f (main + 0x27)
0x4e994724: /lib/libc.so.6 + 0x15724 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4d1
Comment 9 Trevor Cordes 2006-09-24 07:56:32 EDT
"Me too".  oocalc crashes on start (ex: "oocalc foo.ods") about every 10th time
or so now, more so after I've been working on the system for a few days, it
would seem.  Was fine a few weeks ago -- never crashed on me once before that
(FC5 or FC3).

Comment 10 Caolan McNamara 2006-09-25 15:30:34 EDT
a) Trevor Cordes, I just *so* bet that your problem is not this one, check that
you have the latest db4 :-)
b) Alexey, you've got a mixture of traces here, I need something I can
reproduce. Can you attach the slideshow which when you press ESC at the end
seemed to trigged a crash ?
Comment 11 Alexey Titov 2006-09-26 15:17:41 EDT
Here is the last crash's trace...
This but is reproduceable not for all presentations. But here is description of
 bug that looks like mine. There is presentation in attachment that crashes my
openoffice too. 
Description:
http://www.openoffice.org/issues/show_bug.cgi?id=69236
Presentation:
http://www.openoffice.org/nonav/issues/showattachment.cgi/38936/Constructing_triangles.odp

Video Driver is probably: radeon
Desktop is: GNOME
libgcj version is: libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.17.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x217640: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e640
0x217e80: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1ee80
0x4e0f1420:  + 0x420 (__kernel_sigreturn + 0x0)
0x26ef75e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x2d75e
0x26fdb97: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3bb97
0x26fdfa3: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3bfa3
0x26fe15a: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c15a
0x26fe189: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c189
0x26fe1ae: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c1ae
0x26fe3cb: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c3cb
0x26fe3eb: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3c3eb
0x27867aa: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc47aa
0x27864f1: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc44f1
0x2771247: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xaf247
0x2771270: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xaf270
0x26ef73e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x2d73e
0x26ef75e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x2d75e
0x276f2fd: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xad2fd
0x276f406: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xad406
0x276c893: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xaa893
0x276d104: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xab104
0x2759b80: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x97b80
0x2759e01: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x97e01
0x3c914d: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x1c14d (cppu::WeakComponentImplHelperBase::dispose() + 0x75)
0x27617cf: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x9f7cf
0x7baf00d: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2ea00d
0x7babeff: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2e6eff
0x7babf13: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2e6f13
0x79e4901: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x11f901
0x79e4ff0: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x11fff0
0x79fc248: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x137248
0x61c2bb4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aebb4
0x61c1821: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad821
0x61c19ab: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ad9ab
0x61c1a4e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ada4e
0x60bd0bc: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa90bc
0x61dafd5: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6fd5
0x61dad90: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6d90
0x61dafea: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6fea
0x61dad7c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6d7c
0xbb7246: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x83246
0xd050d2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d10d2
0x139c6f8: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1e6f8
0x13bef0c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x40f0c
(SalDisplay::DispatchInternalEvent() + 0x64)
0xe09c4c: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14c4c
0x130f7a1: /usr/lib/libglib-2.0.so.0 + 0x237a1
0x131115d: /usr/lib/libglib-2.0.so.0 + 0x2515d (g_main_context_dispatch + 0x16d)
0x13143ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
0x1314955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe08c23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13c23
0x13c11a9: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x431a9
(X11SalInstance::Yield(unsigned char) + 0x27)
0xbbeaba: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8aaba
(Application::Yield() + 0x48)
0xbbeb3e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ab3e
(Application::Execute() + 0x26)
0x6edbf73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24f73
(desktop::Desktop::Main() + 0x15af)
0xbc296a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e96a
0xbc2a1d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea1d (SVMain()
+ 0x2b)
0x6ed5e53: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee53 (sal_main
+ 0x57)
0x6ed5e9f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee9f (main + 0x27)
0x4e994724: /lib/libc.so.6 + 0x15724 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4d1
Comment 12 Caolan McNamara 2006-09-27 04:19:40 EDT
ug!, indeed, crash reproducable for me.
Comment 13 Caolan McNamara 2006-09-27 04:29:15 EDT
looks like it is that issue alright, also affects FC6 2.0.4, patch applied to
FC-5/FC6 branches, rebuild scheduled
Comment 14 Alexey Titov 2006-09-27 12:25:43 EDT
So this is a bug and we will wait for patches, right?
Comment 15 Caolan McNamara 2006-09-27 12:35:55 EDT
yeah, the esc causing a crash in a slideshow is a bug, and wait for the fc-5
update rebuild to be finished and pushed, maybe a day or two.
Comment 16 Fedora Update System 2006-09-28 14:04:50 EDT
openoffice.org-2.0.2-5.19.2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.