Bug 205315 - [db4] Unknown instabilities in OpenOffice help.
[db4] Unknown instabilities in OpenOffice help.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 205453 205525 205550 205572 205579 205580 205621 205709 206233 206299 206583 210811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-05 19:29 EDT by Jake Gage
Modified: 2013-07-02 19:17 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 03:29:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jake Gage 2006-09-05 19:29:33 EDT
Description of problem:
OpenOffice help does not display help pages correctly, and can cause an evenutal
crash on my Fedora Core 5 system.  This could be due to a missing resource.

Version-Release number of selected component (if applicable):
(~){dispader}05:40pm] rpm -qa | grep -i office | sort
openoffice.org-calc-2.0.2-5.17.2
openoffice.org-core-2.0.2-5.17.2
openoffice.org-draw-2.0.2-5.17.2
openoffice.org-graphicfilter-2.0.2-5.17.2
openoffice.org-impress-2.0.2-5.17.2
openoffice.org-langpack-ar-2.0.2-5.17.2
openoffice.org-langpack-da_DK-2.0.2-5.17.2
openoffice.org-langpack-de-2.0.2-5.17.2
openoffice.org-langpack-el_GR-2.0.2-5.17.2
openoffice.org-langpack-es-2.0.2-5.17.2
openoffice.org-langpack-fr-2.0.2-5.17.2
openoffice.org-langpack-ga_IE-2.0.2-5.17.2
openoffice.org-langpack-nb_NO-2.0.2-5.17.2
openoffice.org-langpack-nn_NO-2.0.2-5.17.2
openoffice.org-langpack-ru-2.0.2-5.17.2
openoffice.org-langpack-zh_CN-2.0.2-5.17.2
openoffice.org-langpack-zh_TW-2.0.2-5.17.2
openoffice.org-math-2.0.2-5.17.2
openoffice.org-writer-2.0.2-5.17.2
openoffice.org-xsltfilter-2.0.2-5.17.2

How reproducible:
Help is never displayed from the "Index", "Find", or "Bookmarks" tab (verified
after a manual re-install of OpenOffice components with rpm --force, in case
there was file corruption).  Eventually, doing various sporatic tests with both
the "Find" and "Contents" tabs caused an application crash, described below.

Steps to Reproduce:
1. Open an OpenOffice document (from the command line gives a little more
debugging information).
2. Navigate to "Help"/"OpenOffice.org Help F1".
STERR: I/O warning : failed to load external entity "vnd.sun.star.pkg:/"
3. Help does not work in various ways.
  
Actual results:
1. As above, starting help gives a STDERR message:
I/O warning : failed to load external entity "vnd.sun.star.pkg:/"
2. Subsequent navigation tasks produce the same error.
3. Sporadically, the "Index" tab shows no entries; but, at other times, it
displays entries, with the first two entries looking strange:
#NAME error message
#REF error message
4. With enough navigation, twice I was able to produce a crash with the
following debug information:

---- BEGIN ----

Video Driver is probably: nvidia nvidia
Desktop is: GNOME
libgcj version is: libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.17.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x67c1640: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e640
0x67c1e80: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1ee80
0x970420:  + 0x420 (__kernel_sigreturn + 0x0)
0x9b7671: /lib/libc.so.6 + 0x29671 (abort + 0x101)
0x9eaa4b: /lib/libc.so.6 + 0x5ca4b
0x9f1f18: /lib/libc.so.6 + 0x63f18
0x9f53ef: /lib/libc.so.6 + 0x673ef (__libc_free + 0x78)
0x52383a8: /lib/libdb-4.3.so + 0xc43a8 (__os_free + 0x38)
0x5247dca: /lib/libdb-4.3.so + 0xd3dca
0x3639b77: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x35b77
0x3633f4d: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x2ff4d
0x36340aa: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x300aa
0x3634df1: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x30df1
0x362050a: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x1c50a
0x3620afc: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x1cafc
0x6a88911: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1c911
0x6a89f23: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1df23
(ucb::Content::getPropertyValuesInterface(com::sun::star::uno::Sequence<rtl::OUString>
const&) + 0xaf)
0x6a89fa2: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1dfa2
(ucb::Content::getPropertyValues(com::sun::star::uno::Sequence<rtl::OUString>
const&) + 0x24)
0x743d937: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xe8937
0x743e4e7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xe94e7
0x743e522: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xe9522
0x6e54246: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x83246
0x6e5fcd2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ecd2
(Timer::Timeout() + 0x10)
0x6e5fe6c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ee6c
0x1c3d3eb: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3c3eb
0x1c3d224: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3c224
(SalData::Timeout() const + 0x24)
0xe0bcc9: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14cc9
0xfea876: /usr/lib/libglib-2.0.so.0 + 0x25876
0xfea15d: /usr/lib/libglib-2.0.so.0 + 0x2515d (g_main_context_dispatch + 0x16d)
0xfed3ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
0xfed955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe0ac23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13c23
0x1c441a9: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x431a9
(X11SalInstance::Yield(unsigned char) + 0x27)
0x6e5baba: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8aaba
(Application::Yield() + 0x48)
0x6e5bb3e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ab3e
(Application::Execute() + 0x26)
0x7f28f73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24f73
(desktop::Desktop::Main() + 0x15af)
0x6e5f96a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e96a
0x6e5fa1d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea1d (SVMain()
+ 0x2b)
0x7f22e53: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee53 (sal_main
+ 0x57)
0x7f22e9f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee9f (main + 0x27)
0x9a3724: /lib/libc.so.6 + 0x15724 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/scalc.bin + 0x4d1

---- END ----

Expected results:
Not the above.

Additional info:
There may be corrupted files somewhere in the operating system; however, all the
package files directly in the openoffice.org packages are verified correct
(yeah... that was fun).  Anyhow, I hope this actually is still useful and
helpful, as it appears that a missing resource can cause application instability.

Thus, I'm really wagering that this one should go to OpenOffice, as an error
trap; but I'm open to any interperetations just now.

Hope everybody that reads this is having a great day.
Comment 1 Caolan McNamara 2006-09-06 03:28:19 EDT
Can you do...

rpm -q db4 

I suspect that was has changed is that a new testing db4 is installed.
Comment 2 Caolan McNamara 2006-09-06 03:30:52 EDT
caolanm->jnovy: I bet the new testing db4 causes this. Quite likely a
problematic usage in OOo, but do we really have to push this new db4 for FC-5 ?
Comment 3 Jindrich Novy 2006-09-06 08:31:23 EDT
Confirmed it's caused by the db4 leak fix. I'm going to revert the change.

Caolan, have you tried to open databases in OOo with db_create(&db, NULL, 0)
instead of db_create(&cb, NULL, DB_XA_CREATE)? are you sure that OOo uses
Transaction Manager?

The latest upstream db-4.4 has the XA part mostly rewritten so that it's likely
it's already fixed there.
Comment 4 Caolan McNamara 2006-09-06 08:41:46 EDT
yeah, we almost certainly have the wrong flags for db_create in OOo as you
suggested in the leak fixing issue. And for the FC-6 OOo that I'm building at
the moment I fix that so all will be well for rawhide.

I can make the same fix for FC-5 to avoid this problem (and I've a build in the
queue just in case we want to do this), but I'd rather avoid a FC-5 update of
OOo unless I have to.

Comment 5 Jindrich Novy 2006-09-06 08:50:45 EDT
Sounds reasonable, unfortunatelly db4 is now released to final so I need to
release another db4 FC5 update. But without pushing the db4 to final we wouldn't
discover this OOo behaviour in time before the FC6 release. Thanks Jake for
reporting!
Comment 6 Caolan McNamara 2006-09-06 09:59:30 EDT
*** Bug 205453 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2006-09-07 02:51:36 EDT
*** Bug 205525 has been marked as a duplicate of this bug. ***
Comment 8 Caolan McNamara 2006-09-07 02:52:26 EDT
*** Bug 205550 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2006-09-07 08:15:14 EDT
*** Bug 205572 has been marked as a duplicate of this bug. ***
Comment 10 Jindrich Novy 2006-09-07 08:24:10 EDT
FC5 update for this fix should occur in the tomorrows push.
Comment 11 Michal Piotrowski 2006-09-07 08:33:49 EDT
(In reply to comment #10)
> FC5 update for this fix should occur in the tomorrows push.

Ok. Thanks!
Comment 12 Fedora Update System 2006-09-07 08:54:11 EDT
db4-4.3.29-8.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 13 Caolan McNamara 2006-09-07 09:43:49 EDT
*** Bug 205579 has been marked as a duplicate of this bug. ***
Comment 14 Caolan McNamara 2006-09-07 09:44:33 EDT
*** Bug 205580 has been marked as a duplicate of this bug. ***
Comment 15 Jake Gage 2006-09-07 12:07:38 EDT
Not a problem, Jindrich.  Glad to help.  Thank you guys for the quick response.
 You rule.
Comment 16 Felix Luk 2006-09-07 23:45:53 EDT
Has this bug been fixed? I have been encountering a similar error in OO Calc.
Whenever I try to get help (F1) there is no text in the right hand box, and when
I try doing a search or click around the links OO crashes.
Comment 17 Jindrich Novy 2006-09-08 00:33:24 EDT
Felix, have you updated to db4-4.3.29-8.fc5?
Comment 18 Felix Luk 2006-09-08 02:42:56 EDT
Initially there was nothing to update, though after I ran 'yum clean all' the
package appeared on the update list.

So I will see how it goes.
Comment 19 Caolan McNamara 2006-09-08 03:20:40 EDT
*** Bug 205621 has been marked as a duplicate of this bug. ***
Comment 20 Felix Luk 2006-09-08 03:28:07 EDT
Help works again. Thanks.
Comment 21 Jindrich Novy 2006-09-08 03:29:26 EDT
Ok, closing ERRATA then. Please reopen if you see this OOo issue again.
Comment 22 David Cartwright 2006-09-08 06:09:05 EDT
However based on my latest yum update of FC6T2, the current FC6 package is still:
db4-4.3.29-7.fc6

Per duplicate bug 205550 above.

Therefore hoping the FC6T2 update isn't far behind the FC5 fix!
Comment 23 Caolan McNamara 2006-09-08 06:45:28 EDT
For FC-6, all should be well with this morning's OOo 2.0.4-3.1 
Comment 24 Jake Gage 2006-09-08 19:47:17 EDT
Positively heroic.
Comment 25 Caolan McNamara 2006-09-09 11:16:39 EDT
*** Bug 205709 has been marked as a duplicate of this bug. ***
Comment 26 Steven Rubenstein 2006-09-09 14:12:57 EDT
Fixed 205709 for me.

Thanks,

Steven Rubenstein (205709 reporter)
Comment 27 David Cartwright 2006-09-09 19:44:45 EDT
The OOo 2.0.4-3.1 FC6 update ran smoothly all day yesterday and looks to have
eliminated the crashes.

Thanks for the quick fix guys.
Comment 28 Caolan McNamara 2006-09-15 05:03:48 EDT
*** Bug 206583 has been marked as a duplicate of this bug. ***
Comment 29 Caolan McNamara 2006-09-15 05:06:59 EDT
*** Bug 206233 has been marked as a duplicate of this bug. ***
Comment 30 Caolan McNamara 2006-09-15 05:08:31 EDT
*** Bug 206177 has been marked as a duplicate of this bug. ***
Comment 31 Caolan McNamara 2006-09-15 05:28:57 EDT
*** Bug 206299 has been marked as a duplicate of this bug. ***
Comment 32 Caolan McNamara 2006-10-16 04:50:20 EDT
*** Bug 210811 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.