Bug 206234 - Shell connection in mc not working
Summary: Shell connection in mc not working
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-13 05:11 UTC by Piotr Wojciechowski
Modified: 2013-07-02 23:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-23 09:48:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Piotr Wojciechowski 2006-09-13 05:11:26 UTC
Description of problem:
Can't use shell connection, after connecting can't list directory of remote
host, panel is empty like if there were nothing

Version-Release number of selected component (if applicable):
mc-4.6.1a-26.fc5
were working perfectly in previous update to FC5, mc-4.6.1a-14.fc5

How reproducible:
every time

Steps to Reproduce:
1. start mc
2. open shell connection to remote host
  
Actual results:
panel with no files nor directories listed

Expected results:
listed files and directories on remote host and ability to work with them

Additional info:
Bug tested on i386 and x86_64

Comment 1 Piotr Wojciechowski 2006-11-01 22:55:23 UTC
Bug still exist in mc-4.6.1a-30.fc6 from FC6

Comment 2 Leonard den Ottolander 2006-11-02 21:26:41 UTC
Problem does *not* seem to exist for mc-4.6.1a-33 (anymore) (rebuild on FC4).
Compare bug #213212.

Comment 3 Piotr Wojciechowski 2006-11-02 21:39:51 UTC
Will test it soon, but mine problem is with shell connection not FTP.

And update. version mc-4.6.1a-30.fc6 works fine while connecting to FC6 station
or FC5 station. Its still not working while connecting to Solaris SunOS 5.9

Comment 4 Leonard den Ottolander 2006-11-03 18:36:10 UTC
The issue is not whether you use ftp or ssh, but if you use ipv4 or ipv6 (at
least that is where I assume the bug was).


Comment 5 Piotr Wojciechowski 2006-11-15 23:51:41 UTC
I tried mc without ipv6 patch you provided but it doesn't solve the problem

Comment 6 Jindrich Novy 2006-11-20 14:26:23 UTC
This should be fixed since mc-4.6.1a-35 which is now built in rawhide. Please
let me know whether the passive ftp mode now works for you. I'll release FC5/FC6
updates as soon as I see possitive feedback.

Comment 7 Piotr Wojciechowski 2006-11-21 14:40:21 UTC
Hi, I tested this version and its working fine. I could connect to FTP sites in
passive mode and using shell connection to SunOS 5.9 I reported before as
broken. For me it seems that problem is solved. I'm waiting now for official FC5
and FC6 package so I can update all my systems. Thanks!

Comment 8 Fedora Update System 2006-11-22 16:25:34 UTC
mc-4.6.1a-35.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 9 Piotr Wojciechowski 2006-11-22 16:40:45 UTC
Thanks, can we have official update for FC5 too ?

Comment 10 Jindrich Novy 2006-11-22 17:05:01 UTC
Yes, the FC5 update was pushed to testing first and I will move it to final in a
few days if no breakage is reported.


Note You need to log in before you can comment on or make changes to this bug.