Bug 206278 - svn checkout fails from https://svn.sourceforge.net/svnroot/yumex/trunk
svn checkout fails from https://svn.sourceforge.net/svnroot/yumex/trunk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-subclipse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Marcano
Fedora Extras Quality Assurance
:
Depends On: 206904
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 09:55 EDT by Tim Lauridsen
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: jessie-1.0.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 15:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Lauridsen 2006-09-13 09:55:51 EDT
Description of problem:

The i try to checkout out a svn project from
https://svn.sourceforge.net/svnroot/yumex/trunk.
I get the following error:

An internal error occured during: "Fetching Childred of
https://svn.sourceforge.net/svnroot/yumex/trunk"
1.4 Methods not enabled.

Version-Release number of selected component (if applicable):

Installed eclipse & subversion packages:

[tim@localhost ~]$ rpm -qa | grep eclipse
eclipse-ecj-3.2.0-5.fc6
eclipse-subclipse-book-1.1.5-2.fc6
eclipse-platform-3.2.0-5.fc6
eclipse-rcp-3.2.0-5.fc6
eclipse-subclipse-1.1.5-2.fc6

[tim@localhost ~]$ rpm -qa | grep svn
javasvn-1.1.0-0.3.beta4.fc6

[tim@localhost ~]$ rpm -qa | grep subversion
subversion-javahl-1.3.2-6
subversion-1.3.2-6


How reproducible:

Every time

Not problem making the checkout using commandline svn.
Comment 1 Robert Marcano 2006-09-13 14:40:15 EDT
I find this error on my FC-5 install (see <workspace>/.metadata/.log) I think it
is the same problem you experience. It appears to be some API limitation of the
cryto implamentation of GCJ

java.lang.UnsupportedOperationException: 1.4 methods not enabled
   at org.metastatic.jessie.provider.SSLSocket.setReuseAddress(jsse-1.0.1.jar.so)
   at
org.tmatesoft.svn.core.internal.util.SVNSocketFactory.createSSLSocket(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.connect(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVConnection.doPropfind(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVUtil.getProperties(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVUtil.getResourceProperties(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVUtil.getStartingProperties(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVUtil.findStartingProperties(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVUtil.getBaselineProperties(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVUtil.getBaselineInfo(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.wc.SVNBasicClient.getRevisionNumber(javasvn-1.1.0.jar.so)
   at org.tmatesoft.svn.core.wc.SVNBasicClient.getLocations(javasvn-1.1.0.jar.so)
   at
org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(javasvn-1.1.0.jar.so)
   at org.tmatesoft.svn.core.wc.SVNLogClient.doList(javasvn-1.1.0.jar.so)
   at org.tmatesoft.svn.core.wc.SVNLogClient.doList(javasvn-1.1.0.jar.so)
   at org.tmatesoft.svn.core.javahl.SVNClientImpl.list(javasvn-1.1.0.jar.so)
   at org.tmatesoft.svn.core.javahl.SVNClientImpl.list(javasvn-1.1.0.jar.so)
   at
org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getList(svnClientAdapter.jar.so)
   at
org.tigris.subversion.subclipse.core.resources.RemoteFolder.getMembers(SVNPluginCore.jar.so)
   at
org.tigris.subversion.subclipse.core.resources.RemoteFolder.members(SVNPluginCore.jar.so)
   at
org.tigris.subversion.subclipse.ui.operations.FetchMembersOperation.execute(SVNPluginUI.jar.so)
   at
org.tigris.subversion.subclipse.ui.operations.SVNOperation.run(SVNPluginUI.jar.so)
   at
org.tigris.subversion.subclipse.ui.repository.model.SVNRepositoryRootElement.fetchDeferredChildren(SVNPluginUI.jar.so)
   at
org.eclipse.ui.progress.DeferredTreeContentManager$1.run(org.eclipse.ui.workbench_3.1.2.jar.so)
   at
org.eclipse.core.internal.jobs.Worker.run(org.eclipse.core.runtime_3.1.2.jar.so)

I am sure that solving the problem of native subclicpse with javahl (not yet
filled bug, my mistake) can solve this problem, but I still will investigate
this problem using the javasvn (javahl interface in currently disabled)
Comment 2 Robert Marcano 2006-09-13 21:23:56 EDT
The jessie library has been merged with GNU Classpath, but still those methods
remain disabled. In
http://www.mail-archive.com/jessie-discuss@nongnu.org/msg00000.html is discussed
that those methods where disabled in order to be able to build the independent
jessie releases with free runtimes. I will try enabling them to see if works

This is found on GNU Classpath source in gnu.javax.net.ssl.provider.SSLSocket:

  public void setReuseAddress(boolean flag) throws SocketException
  {
    //if (underlyingSocket != null)
    //  {
    //    underlyingSocket.setReuseAddress(flag);
    //  }
    //else
    //  {
    //    super.setReuseAddress(flag);
    //  }
    throw new UnsupportedOperationException("1.4 methods not enabled");
  }

The removal of the "throw new UnsupportedOperationException ..." was commited
sometime (http://www.mail-archive.com/jessie-discuss@nongnu.org/msg00059.html)
maybe the merge was made using the latest release version
Comment 3 Tim Lauridsen 2006-09-14 06:01:47 EDT
I have test on my FC5 system with Native Eclipse 3.1, and i get the samme error
and there i no problem making a SVN checkout from a http://.... svn site, so
there  problem is clearly releated to SSL stuff.

Comment 4 Ben Konrath 2006-09-14 13:03:32 EDT
Tom, Do you have any thoughts about what's going on here?
Comment 5 Thomas Fitzsimmons 2006-09-14 13:45:32 EDT
(In reply to comment #4)
> Tom, Do you have any thoughts about what's going on here?

Looks like we need a libgcj backport for FC-5.  Unfortunately, that probably
won't happen.  In FC-6 libgcj will be a separate RPM, so fixes like this will be
much easier, but for FC-5 we're stuck with the current gcc release.
Comment 6 Robert Marcano 2006-09-17 20:36:45 EDT
Bug against gcc created, bug #206904
Comment 7 Tom Tromey 2006-09-18 16:51:23 EDT
In re comment #5: do we need an FC 5 backport?
I thought FC 5 still had a separate jessie RPM; we could fix it there.

FYI I'm going to pull the libgcj fix in to the RH 4.1 branch today.
I don't know when this will show up in rawhide however.
Comment 8 Thomas Fitzsimmons 2006-09-18 17:16:19 EDT
(In reply to comment #7)
> In re comment #5: do we need an FC 5 backport?
> I thought FC 5 still had a separate jessie RPM; we could fix it there.

Yes, good call.  I'm building jessie-1.0.1-5, with this patch, into
dist-fc5-update-candidates now.
Comment 9 Thomas Fitzsimmons 2006-09-19 13:49:10 EDT
jessie-1.0.1-5 has been pushed to FC-5 updates-testing.  Robert, can you try it
and confirm that it fixes your problem?
Comment 10 Robert Marcano 2006-09-19 14:26:49 EDT
Confirmed.. jessie-1.0.1-5 fix the problem on FC-5
Comment 11 Thomas Fitzsimmons 2006-09-19 15:51:32 EDT
jessie-1.0.1-5 has been pushed to FC-5 updates.  Closing.
Comment 12 Tim Lauridsen 2006-09-20 04:53:05 EDT
What about FC6/Rawhide, does it work too ???
Comment 13 Thomas Fitzsimmons 2006-09-20 13:39:26 EDT
(In reply to comment #12)
> What about FC6/Rawhide, does it work too ???

That's being tracked as 206904.  We'll close 206904 when the fix makes it into
Rawhide.
Comment 14 Tim Lauridsen 2006-09-28 09:14:03 EDT
Thanks a lot, it works as a charm in FC6/Rawhide.

Note You need to log in before you can comment on or make changes to this bug.