Bug 206286 - [bn_IN] Missing glyphs for 4 conjunct characters.
[bn_IN] Missing glyphs for 4 conjunct characters.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
: 206414 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 10:26 EDT by Runa Bhattacharjee
Modified: 2013-03-03 21:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 08:49:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Details of the missing conjunct glyphs (26.58 KB, image/png)
2006-09-13 10:26 EDT, Runa Bhattacharjee
no flags Details
Patch with added glyphs and their GSUB rules (85.31 KB, patch)
2006-09-28 21:12 EDT, Rahul Bhalerao
no flags Details | Diff
Verified Image (41.85 KB, image/png)
2007-04-27 08:48 EDT, A S Alam
no flags Details

  None (edit)
Description Runa Bhattacharjee 2006-09-13 10:26:22 EDT
Description of problem:

Glyphs for 4 conjuncts are not available in the bengali font.
1.  U0995+U09CD+U099F+U09CD+U09B0
2.  U09AE+U09CD+U09A5
3.  U09B2+U09CD+U09A4
4.  U09B2+U09CD+U09A7

Details of conjuncts and glyph images in newglphys-bn.png

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Log in to Bengali India locale from gdm
2. Open gedit
3. Press ctrl-space and select bn-probhat from the scim-toolbar
4. type the following key sequences:
4a:k/t/r
4b:m/F
4c:l/f
4d:l/Q
  
Actual results:

Glyphs for the above conjuncts are missing. Displayed as consonant+halant+consonant.

Expected results:
Glyphs should be present (details in newglyphs-bn.png)

Additional info:
Fixed in the patch in the following url:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169110#c1
Comment 1 Runa Bhattacharjee 2006-09-13 10:26:23 EDT
Created attachment 136157 [details]
Details of the missing conjunct glyphs
Comment 3 Rahul Bhalerao 2006-09-28 18:44:23 EDT
*** Bug 206414 has been marked as a duplicate of this bug. ***
Comment 6 Rahul Bhalerao 2006-09-28 21:12:46 EDT
Created attachment 137354 [details]
Patch with added glyphs and their GSUB rules

This Patch is based on the fixes provided by Baishampayan Ghose
(b.ghose@ubuntu.com). I modified the glyphs to scale them down 
to the size of the glyphs in 2.0.1 release.
Comment 7 Leon Ho 2006-09-29 02:58:01 EDT
Built in 2.0.5-1.
Comment 8 A S Alam 2007-04-27 08:48:07 EDT
Created attachment 153615 [details]
Verified Image
Comment 9 A S Alam 2007-04-27 08:49:33 EDT
Tested with following version:
fonts-bengali-2.1.5-1.fc7

Note You need to log in before you can comment on or make changes to this bug.