Bug 2063040 - Can shell integration not be enabled by default or put into a subpackage
Summary: Can shell integration not be enabled by default or put into a subpackage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kitty
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Artem
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2053975 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-11 08:08 UTC by Jamie Nguyen
Modified: 2022-03-26 15:19 UTC (History)
4 users (show)

Fixed In Version: kitty-0.24.4-2.fc37 kitty-0.24.4-2.fc35 kitty-0.24.4-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-18 20:06:16 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Patch for subpackages (1.70 KB, application/mbox)
2022-03-11 08:43 UTC, Jamie Nguyen
no flags Details

Description Jamie Nguyen 2022-03-11 08:08:44 UTC
Description of problem:

Thank you for maintaining Kitty on Fedora! :-)

The kitty package on Fedora installs /etc/profile.d/kitty.sh, which enables shell integration even if the user hasn't modified their kitty.conf to enable it. And if the user has explicitly disabled shell integration in their kitty.conf, it remains enabled without the user knowing why or how.

Obviously the addition of this file was intended to be helpful, but I think this is a case where it would be better to leave this to the user and not do something surprising.

1. Kitty's documentation is simple and clear on how to enable shell integration, and without reading the documentation the user wouldn't know how to use the shell integration anyway.

2. kitty.conf is where users expect to be able to configure Kitty. They would have to know that the packager has decided to install a file that auto-enables Kitty's shell integration outside of kitty.conf. (Principle of least surprise and all that.)

3. From what I can see, Ubuntu, OpenSUSE and Arch Linux don't install a similar file. Arch Linux has a separate kitty-shell-integration package but that doesn't actually auto-enable shell integration, it just installs the /usr/lib/kitty/shell-integration files.

Thank you!


Version-Release number of selected component (if applicable):

Name         : kitty
Version      : 0.24.4
Release      : 1.fc35
Architecture : x86_64

Comment 1 Artem 2022-03-11 08:15:49 UTC
Thanks for reporting. I wanted as well to made separate sub-packages for shell integrations and they should disabled by default IMO. Hope @zawertun could help with fix due lack of time now.

Comment 2 Jamie Nguyen 2022-03-11 08:43:04 UTC
Wow, thanks for the very prompt reply Artem! No worries, I know the feeling. 

I don't think there's a good reason to move /usr/lib/kitty/shell-integration files into a subpackage or multiple subpackages. Ubuntu and OpenSUSE don't do that. So from my perspective this is just about kitty.sh and kitty.fish, which are files only Fedora is installing.

Personally I think the solution is as simple as removing kitty.fish and kitty.sh from the package. If you want to keep them then I attached a patch, though I'm dubious about their value. (I'm a Fedora packager, but stepped away from all but one package a few years ago and I'm not currently interested in getting back into maintenance/co-maintenance!)

I can see from commit history that zawertun had to revert auto-enabling ZSH integration. I think all of this should just be left to the user :-)

Comment 3 Jamie Nguyen 2022-03-11 08:43:28 UTC
Created attachment 1865385 [details]
Patch for subpackages

Comment 4 Fedora Update System 2022-03-11 09:37:03 UTC
FEDORA-2022-a92544aa9c has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a92544aa9c

Comment 5 Fedora Update System 2022-03-11 09:37:54 UTC
FEDORA-2022-a92544aa9c has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2022-03-11 09:55:39 UTC
FEDORA-2022-27a289eaa6 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-27a289eaa6

Comment 7 Fedora Update System 2022-03-11 09:56:19 UTC
FEDORA-2022-d2c9637537 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d2c9637537

Comment 8 Jamie Nguyen 2022-03-11 10:03:51 UTC
Thanks very much Artem :-)

Comment 9 Jamie Nguyen 2022-03-11 10:05:02 UTC
*** Bug 2053975 has been marked as a duplicate of this bug. ***

Comment 10 grumpey0 2022-03-11 10:43:00 UTC
Thanks Everyone!

Comment 11 Fedora Update System 2022-03-11 15:46:16 UTC
FEDORA-2022-d2c9637537 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-d2c9637537`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d2c9637537

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-03-11 19:26:21 UTC
FEDORA-2022-27a289eaa6 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-27a289eaa6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-27a289eaa6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-03-18 20:06:16 UTC
FEDORA-2022-d2c9637537 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2022-03-26 15:19:23 UTC
FEDORA-2022-27a289eaa6 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.