Bug 206387 - [ml_IN] the glyph of the conjuction of 0x0d32 + 0x0d4d + 0x0d32 is wrong.
[ml_IN] the glyph of the conjuction of 0x0d32 + 0x0d4d + 0x0d32 is wrong.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
: 207093 (view as bug list)
Depends On:
Blocks: FC6Blocker 206431
  Show dependency treegraph
 
Reported: 2006-09-13 22:52 EDT by Liang Zhang
Modified: 2015-04-06 23:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 08:52:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The image of comparing (10.55 KB, image/png)
2006-09-13 22:52 EDT, Liang Zhang
no flags Details
Verified Image (2.11 KB, image/png)
2007-04-27 08:51 EDT, A S Alam
no flags Details

  None (edit)
Description Liang Zhang 2006-09-13 22:52:25 EDT
Description of problem:
The glyph of the conjuction of 0x0d32 + 0x0d4d + 0x0d32 is wrong with using
lohit_ml.ttf of fonts-indic-2.0.1-1. But it is right with using Lohit_Malayalam.ttf.
The image of comparing the results is below:


Version-Release number of selected component (if applicable):
fonts-indic-2.0.1-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Liang Zhang 2006-09-13 22:52:26 EDT
Created attachment 136222 [details]
The image of comparing
Comment 2 Rahul Bhalerao 2006-09-15 04:11:33 EDT
The effect is due to the general below base implementation of 0x0d32 in Pango. 
Earlier font had a rule compatible with this implementation. Then it was reported 
by LM, Ani, that below base form takes place only when 0x0d32 combines with
itself. In every other case, such below base forms should be formed using 0x0d33.
But it seems that every other system has implemented 0x0d32 as genneral below
base form for all the consonants it combines with. Their is a disput among
community 
about the valid correct character i.e. either 0x0d32 or 0x0d33. This bug can be
fixed in Pango assuming 0x0d33 is the correct below base character. But it needs 
information from Ani about the confirmation and a strong community feedback on
the issue.
Ani, could you get a feedback or some official documents supporting any of the
stands?
Comment 3 Ani Peter 2006-09-15 05:36:06 EDT
Rahul,

Give me two days time. By Monday I will let you know the final stand.

Thanks
Ani
Comment 4 Rahul Bhalerao 2006-09-26 18:21:56 EDT
The patch on bug #192934 (attachment id=137177) makes the rendering of 0d32 and
0d33 conjuncts identical to each other and special for 0d32+0d4d+0d32 and
0d33+0d4d+0d33 combinations. 
Comment 5 Lawrence Lim 2006-09-29 03:41:21 EDT
*** Bug 207093 has been marked as a duplicate of this bug. ***
Comment 6 A S Alam 2007-04-27 08:51:43 EDT
Created attachment 153617 [details]
Verified Image
Comment 7 A S Alam 2007-04-27 08:52:48 EDT
tested version:
fonts-malayalam-2.1.5-1.fc7

Note You need to log in before you can comment on or make changes to this bug.