Bug 206408 - UnboundLocalError: local variable 'errNum' referenced before assignment. (when upgrading from FC4 to FC5)
UnboundLocalError: local variable 'errNum' referenced before assignment. (whe...
Status: CLOSED DUPLICATE of bug 185853
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 02:33 EDT by Zafer Kiziltoprak
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 09:47:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zafer Kiziltoprak 2006-09-14 02:33:37 EDT
Description of problem:
when upgraging from FC4 to FC5 or installing fresh FC5, the installation always
breaks down after managing the partitions. A window opens and its says somthing
like that (i cut some part of it): 
An unhandled exception has occured. This is most likely a bug...
...
File "/us/lib/anaconda/upgrade.py", line 147 in mountRootPartition 
    oldffset.mountFileSystems(instPath, readOnly=readOnly)

File "/us/lib/anaconda/fsset.py", line 1637 in mountFileSystems
    entry.mount(instPath, readOnly=readOnly)

File "/usr/lib/anaconda/ffset.py", line 1840 in mount
    BindMountDevice))

File "/usr/lib/anaconda/ffset.py", line 1051 in mount 
    raise SystemError(errNum, errMsg)
UnboundLocalError: local variable 'errNum' referenced before assignment. 
.....

And this goes on with the list of rpm packages. 

I thought that it was a DVD hardware problem(reading) i changed my DVD with a
working one. And same thing happened. 

and Hardware :
ASUS Gigabyte GA-K8NS Mainboard.
AMD Athlon(tm) 64 Processor 3000+
MemTotal:       515504 kB
ATI RV280 Radeon 9200 Pro. 





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2006-09-14 09:47:39 EDT
This traceback is fixed in the test releases of FC6.  Marking as a duplicate of
the underlying cause.

*** This bug has been marked as a duplicate of 185853 ***

Note You need to log in before you can comment on or make changes to this bug.