Bug 206461 - [or_IN] Combinations with U0D5F are not formed(u0B4D+u0B5F)( i18n )
[or_IN] Combinations with U0D5F are not formed(u0B4D+u0B5F)( i18n )
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
:
Depends On:
Blocks: 206581
  Show dependency treegraph
 
Reported: 2006-09-14 10:48 EDT by Rahul Bhalerao
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 07:34:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of wrong and right glyph for yya-phala (7.68 KB, image/jpeg)
2006-09-14 10:48 EDT, Rahul Bhalerao
no flags Details
Patch (2.72 KB, patch)
2006-09-18 03:09 EDT, Rahul Bhalerao
no flags Details | Diff
Verified Image (1.97 KB, image/png)
2007-04-27 07:33 EDT, A S Alam
no flags Details

  None (edit)
Description Rahul Bhalerao 2006-09-14 10:48:39 EDT
Description of problem:
Combinations of following type are not formed:

   Consonant + U0B4D + U0B5F

A GSUB rule has to be written for (U0B4D+U0B5F) with 'pstf' tag.
 
Version-Release number of selected component (if applicable):
2.0.1-1

How reproducible:


Steps to Reproduce:
1. Open gedit
2. Enable Oriya inscript Layout
3. Type the folowing key sequence:
     Any consonant(e.g 'k') + d + ('/' or rawcode[0b5f])
  
Actual results:
No substitution happens and the character follow each other as shown in the
attached image.

Expected results:
The combination of (U0B4D + U0B5F) should be substituted by yyy-phala and final
glyph should look like the correct glyph in the attached image.

Additional info:
The incsript lay may have mapped 0b5f wrongly on 'shift+/' i.e. '?'
Best way is to use rawcode.
Comment 1 Rahul Bhalerao 2006-09-14 10:48:39 EDT
Created attachment 136269 [details]
Image of wrong and right glyph for yya-phala
Comment 2 Rahul Bhalerao 2006-09-18 02:39:14 EDT
This combination works with the latest release of Pango i.e. version 1.14.3.
Actually the similar combination,
consonant+ u0b4d + u0b2f 
does not work in latest release of the font due to problem in GSUB rule and a
wrong glyph in place.
Comment 3 Rahul Bhalerao 2006-09-18 03:09:13 EDT
Created attachment 136507 [details]
Patch
Comment 4 Rahul Bhalerao 2006-09-18 03:11:32 EDT
Above is Patch 3.
Comment 5 Matthew Miller 2007-04-06 12:11:34 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 6 Rahul Bhalerao 2007-04-16 06:53:01 EDT
Fixed in FC6.
Comment 7 A S Alam 2007-04-27 07:33:47 EDT
Created attachment 153605 [details]
Verified Image
Comment 8 A S Alam 2007-04-27 07:34:46 EDT
verified version is:
fonts-oriay-2.1.5-1.fc7

Note You need to log in before you can comment on or make changes to this bug.