Bug 206581 - [or_IN] - Some GSUB Conjuncts are not appearing with its correct shape - Priority - A
[or_IN] - Some GSUB Conjuncts are not appearing with its correct shape - Prio...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
: 194066 (view as bug list)
Depends On: 187481 206291 206301 206446 206461 206469 206550 206587 206589 206597
Blocks: FC6Blocker 208813
  Show dependency treegraph
 
Reported: 2006-09-15 00:40 EDT by Satyabrata Maitra
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 07:08:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GSUB changes in accordance with the Pango-1.14.3. (4.30 KB, patch)
2006-09-18 03:03 EDT, Rahul Bhalerao
no flags Details | Diff
Patch (10.57 KB, text/x-patch)
2006-09-21 03:50 EDT, Rahul Bhalerao
no flags Details
Patch (10.57 KB, patch)
2006-09-21 03:51 EDT, Rahul Bhalerao
no flags Details | Diff
Screenshots of GSUB combinations (or_IN) (108.98 KB, image/jpeg)
2006-10-12 08:53 EDT, subhransu behera
no flags Details

  None (edit)
Description Satyabrata Maitra 2006-09-15 00:40:20 EDT
Description of problem:
Some of the Conjuncts in GSUB category are not appearing with its correct shape
after combine. Those Lists are mentioned in the 1st Comment as its a big list!!

Version-Release number of selected component (if applicable):
fonts-oriya-2.0.1-1
pango-1.14.3-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Open gedit
2. Activate SCIM with CTRL+SPACE.
3. Select RAWCODE from the scim-table in Others
4. Type the unicode sequentially as given in the 1st comment but without 'U' and 
   '+'.
5. Observe the result.
  
Actual results:
Shapes, appearing is not correct. 

Expected results:
Shape should be correctly appearing.

Additional info:
Please see the 1st Comment for the List of Unicode Combinations of conjuncts,
those are showing incorrectly.
Comment 1 Satyabrata Maitra 2006-09-15 01:12:35 EDT
List of Conjuncts :

Unicode Combinations :

U+0B15 U+0B4D U+0B2E
U+0B15 U+0B4D U+0B2F
U+0B15 U+0B4D U+0B30
U+0B15 U+0B4D U+0B33
U+0B15 U+0B4D U+0B2C
U+0B15 U+0B4D U+0B28
U+0B15 U+0B4D U+0B24
U+0B15 U+0B4D U+0B25
U+0B15 U+0B4D U+0B1F
U+0B15 U+0B4D U+0B1C
U+0B2A U+0B4D U+0B1F
U+0B39 U+0B4D U+0B28
U+0B38 U+0B4D U+0B24
U+0B38 U+0B4D U+0B24 U+0B4D U+0B30
U+0B38 U+0B4D U+0B2C
U+0B36 U+0B4D U+0B15
U+0B2E U+0B4D U+0B2E
U+0B2E U+0B4D U+0B2D
U+0B36 U+0B4D U+0B2A
U+0B26 U+0B4D U+0B2F
U+0B28 U+0B4D U+0B24
U+0B28 U+0B4D U+0B24 U+0B4D U+0B30
U+0B28 U+0B4D U+0B28
U+0B24 U+0B4D U+0B24
U+0B24 U+0B4D U+0B28
U+0B30 U+0B4D U+0B24 U+0B4D U+0B24
U+0B30 U+0B4D U+0B2F U+0B4D U+0B2F
U+0B16 U+0B4D U+0B30
U+0B17 U+0B4D U+0B30
U+0B18 U+0B4D U+0B30
U+0B1A U+0B4D U+0B1A U+0B4D U+0B30
U+0B1A U+0B4D U+0B1B U+0B4D U+0B30
U+0B1A U+0B4D U+0B30
U+0B1B U+0B4D U+0B30
U+0B1C U+0B4D U+0B30
U+0B1D U+0B4D U+0B30
U+0B1F U+0B4D U+0B30
U+0B20 U+0B4D U+0B30
U+0B21 U+0B4D U+0B30
U+0B22 U+0B4D U+0B30
U+0B23 U+0B4D U+0B30
U+0B24 U+0B4D U+0B30
U+0B24 U+0B4D U+0B24 U+0B4D U+0B30
U+0B25 U+0B4D U+0B30
U+0B26 U+0B4D U+0B30
U+0B26 U+0B4D U+0B26 U+0B4D U+0B30
U+0B26 U+0B4D U+0B27 U+0B4D U+0B30
U+0B27 U+0B4D U+0B30
U+0B28 U+0B4D U+0B30
U+0B2A U+0B4D U+0B30
U+0B2B U+0B4D U+0B30
U+0B2C U+0B4D U+0B30
U+0B2D U+0B4D U+0B30
U+0B2E U+0B4D U+0B30
U+0B2F U+0B4D U+0B30
U+0B36 U+0B4D U+0B30
U+0B37 U+0B4D U+0B30
U+0B38 U+0B4D U+0B30
U+0B39 U+0B4D U+0B30
U+0B5C U+0B4D U+0B30
U+0B5D U+0B4D U+0B30
Comment 2 Rahul Bhalerao 2006-09-18 03:03:44 EDT
Created attachment 136505 [details]
GSUB changes in accordance with the Pango-1.14.3.

GSUB rules for 0x0b4d+0x0bxx changed, where xx are,
24, 2c, 2d, 2e, 2f, 30, 32, 33.
Comment 3 Rahul Bhalerao 2006-09-18 03:10:41 EDT
Above Attachment is the Patch No.1
Comment 4 Rahul Bhalerao 2006-09-21 03:50:52 EDT
Created attachment 136828 [details]
Patch
Comment 5 Rahul Bhalerao 2006-09-21 03:51:51 EDT
Created attachment 136829 [details]
Patch

This Patch is dependent on the Pango patch submited on the bug #207456
Comment 6 Satyabrata Maitra 2006-09-26 03:54:20 EDT
I tested the Font Test Cases with the latest version of fonts available in the
Rawhide. But Fot some pango issue, its showing wrong!! The patch that has
claimed already been developed for this issue resolution, has still not been
built in pango and available as rpm. So, whenever it will be available, I will
again perform the test and the result will be reflected on this bug as comment.

Version tested :

fonts-oriya-2.0.4-1
pango-1.14.4-1.fc6
pango-devel-1.14.4-1.fc6 
Comment 7 Lawrence Lim 2006-09-28 22:40:27 EDT
U+0B38 U+0B4D U+0B2C does not look quite right compare with the image in the TC.
Could you please confirm?
Comment 8 Lawrence Lim 2006-09-28 22:53:53 EDT
U+0B15 U+0B4D U+0B1C and U+0B15 U+0B4D U+0B25 are definitely wrong. 

Tested with the following packages, bug still exist.

fonts-oriya-2.0.4-1 (dist-fc6)
pango-1.14.4-3 (test rpm)

Comment 9 Rahul Bhalerao 2006-09-29 00:39:26 EDT
Could you provide the screenshots for outputs you get in these cases:

U+0B38 U+0B4D U+0B2C
U+0B15 U+0B4D U+0B1C
U+0B15 U+0B4D U+0B25

They are rendered properly for me and font has the GSUB table for them.

Actually I found the images in test cases to be wrong. Atleast the image of
U+0B15 U+0B4D U+0B1C is certainly wrong in the test case. S Behera actually
demanded the image font currently renders and it was confirmed with Dr. Cooper
as well.

U+0B38 U+0B4D U+0B2C has similar image and one in font is the better.
U+0B15 U+0B4D U+0B25 is also supposedly wrong image in test case. LM sbehera
never asked for that shape. And current shape is present for long time without
any objetion from S Behera. 


Comment 10 Rahul Bhalerao 2006-10-03 10:11:51 EDT
*** Bug 194066 has been marked as a duplicate of this bug. ***
Comment 11 subhransu behera 2006-10-12 08:53:49 EDT
Created attachment 138323 [details]
Screenshots of GSUB combinations (or_IN)

There were some images wrong in the testcase because some has been taken from
the out put of utkal font.

I have reported the list of wrong images to llim earlier and it has been
modified in the current test case.

U+0B38 U+0B4D U+0B2C (TC - 64)
U+0B15 U+0B4D U+0B1C (TC - 76)
U+0B15 U+0B4D U+0B25 (TC - 84)

The latest test cases are available in the following link:

http://batman.brisbane.redhat.com/~indic/IndicTC/lang/or_IN/font/IndicFontTestCaseGSUB-Oriya.html


In the earlier test case only the image of 76 was drawn wrong. And the image of
TC - 84 was an alias of the output what is dislplayed now. As both the
combinations are correct. 

I have given two examples in the screenshots. Where example 1 and 2 shows the
output generated by two different consonants with U+0B25. And both are correct
according to their uses. As the combination given in TC-84 is rarely used, so
it
can be made either way.

And as per as I have noticed the image of TC-64 was correct earlier as well.
There was only problem in the missing rules which has been resolved now
dispaying the correct output.
Comment 12 A S Alam 2007-05-02 07:08:31 EDT
All combinations are verified by LM and those are fixed now.
Tested with following Package:
fonts-oriya-2.1.5-1.fc7

Note You need to log in before you can comment on or make changes to this bug.