Bug 206513 - fc6test3/64-bit: anaconda fails to create initrd
fc6test3/64-bit: anaconda fails to create initrd
Status: CLOSED DUPLICATE of bug 206453
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On: 205194
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-14 15:46 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 11:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot_messages (19.21 KB, text/plain)
2006-09-14 15:48 EDT, IBM Bug Proxy
no flags Details
requested install log (54.92 KB, text/plain)
2006-09-15 09:50 EDT, Robbie Williamson
no flags Details
install.log (54.92 KB, text/plain)
2006-09-15 09:51 EDT, IBM Bug Proxy
no flags Details
install.log (55.98 KB, text/plain)
2006-09-15 10:06 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 27225 None None None Never

  None (edit)
Description IBM Bug Proxy 2006-09-14 15:46:30 EDT
LTC Owner is: thinh@us.ibm.com
LTC Originator is: thinh@us.ibm.com


Problem description:
CellBlade CB1 keeps rebooting after install FC6-Test3
(installation details are in LTC bug 27222/ RedHat Bugzilla 206509.)


Hardware Environment
    Machine type (p650, x235, SF2, etc.): BladeCenter QS20

Is this reproducible? YES
    If so, how long does it (did it) take to reproduce it? 1 minutes
    Describe the steps:
     - install the machine, and watch it reboots

Additional information:


The yaboot.conf

sh-3.1# cat yaboot.conf
# yaboot.conf generated by anaconda

boot=/dev/hda1
init-message=Welcome to Fedora Core!\nHit <TAB> for boot options

partition=2
timeout=80
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
nonvram
fstype=raw

image=/vmlinuz-2.6.17-1.2630.fc6
        label=linux
        read-only
        root=/dev/hda5
        append="console=hvc0 rhgb quiet"


there is no initrd

#ls boot
System.map-2.6.17-1.2630.fc6  lost+found
config-2.6.17-1.2630.fc6      symsets-2.6.17-1.2630.fc6.tar.gz
etc                           symvers-2.6.17-1.2630.fc6.gz
grub                          vmlinuz-2.6.17-1.2630.fc6


I got it up.
Starting smartd: [  OK  ]

Fedora Core release 5.92 (FC6 Test3)
Kernel 2.6.17-1.2630.fc6 on an ppc64

login: root
Password:
# uname -a
Linux localhost 2.6.17-1.2630.fc6 #1 SMP Wed Sep 6 17:17:26 EDT 2006 ppc64 ppcx


this is the issue without initrd as Arnd mentioned in the email.

The work-around:
1- do netboot as normal vnc installation steps, until anaconda start vncserver
   and gives back the shell prompt
2- mount the '/' and '/boot' partitions from local hard drive.
   in my case: 
       mount /dev/hda5 /oldtmp
       mount /dev/hda2 /oldtmp/boot
3- do chroot to "/oldtmp"
       chroot /oldtmp
4- run mkinitrd to create initrd image
       mkinitrd initrd-2.6.17-1.2630.fc6 2.6.17-1.2630.fc6
5- edit yaboot.conf to add initrd

       # yaboot.conf generated by anaconda

        boot=/dev/hda1
        init-message=Welcome to Fedora Core!\nHit <TAB> for boot options

        partition=2
        timeout=80
        install=/usr/lib/yaboot/yaboot
        delay=5
        enablecdboot
        enableofboot
        enablenetboot
        nonvram
        fstype=raw

        image=/vmlinuz-2.6.17-1.2630.fc6
               label=linux
               read-only
               initrd=/initrd-2.6.17-1.2630.fc6
               root=/dev/hda5
               append="console=hvc0 rhgb quiet"

6- restart the blade
Comment 1 IBM Bug Proxy 2006-09-14 15:48:35 EDT
Created attachment 136300 [details]
boot_messages
Comment 2 IBM Bug Proxy 2006-09-14 19:05:51 EDT
----- Additional Comments From thinh@us.ibm.com (prefers email at th2tran@austin.ibm.com)  2006-09-14 19:04 EDT -------
for the work-around:
 - Don't reboot the machine after installation completed, just go to the shell
prompt and do create the initrd image from step #2 above.

Regards,
Thinh Tran 
Comment 3 Jeremy Katz 2006-09-15 06:14:15 EDT
Can you provide /root/install.log?
Comment 4 Robbie Williamson 2006-09-15 09:50:23 EDT
Created attachment 136357 [details]
requested install log 

Here is an install.log file from a Cell blade exhibiting this behaviour.
Comment 5 IBM Bug Proxy 2006-09-15 09:51:18 EDT
Created attachment 136358 [details]
install.log
Comment 6 IBM Bug Proxy 2006-09-15 09:52:05 EDT
----- Additional Comments From robbiew@us.ibm.com  2006-09-15 09:48 EDT -------
 
requested install log 
Comment 7 IBM Bug Proxy 2006-09-15 09:57:14 EDT
----- Additional Comments From arndb@de.ibm.com (prefers email at arnd.bergmann@de.ibm.com)  2006-09-15 09:54 EDT -------
The bug is probably related to this snipped from the install log

WARNING: /lib/modules/2.6.17-1.2630.fc6/kernel/fs/cachefiles/cachefiles.ko 
needs unknown symbol copy_4K_page
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
no temporary directory could be found.
mkinitrd failed
error: %post(kernel-2.6.17-1.2630.fc6.ppc64) scriptlet failed, exit status 1

Maybe a dependency in the kernel package to nash is missing? 
Comment 8 IBM Bug Proxy 2006-09-15 10:06:01 EDT
Created attachment 136359 [details]
install.log
Comment 9 IBM Bug Proxy 2006-09-15 10:06:26 EDT
----- Additional Comments From thinh@us.ibm.com (prefers email at th2tran@austin.ibm.com)  2006-09-15 10:02 EDT -------
 
/root/install.log

mkinitrd fails:
....
Installing kernel - 2.6.17-1.2630.fc6.ppc64
WARNING: /lib/modules/2.6.17-1.2630.fc6/kernel/fs/cachefiles/cachefiles.ko
needs unknown symbol copy_4K_page
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
no temporary directory could be found.
mkinitrd failed
error: %post(kernel-2.6.17-1.2630.fc6.ppc64) scriptlet failed, exit status 1
Installing firstboot-tui - 1.4.19-1.noarch
.... 
Comment 10 Arnd Bergmann 2006-09-15 10:10:17 EDT
this bug seems to be the same as 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=205194.
Comment 11 IBM Bug Proxy 2006-09-15 10:16:43 EDT
----- Additional Comments From thinh@us.ibm.com (prefers email at th2tran@austin.ibm.com)  2006-09-15 10:12 EDT -------
Redhat,
Sorry for sending duplicated data. 
Comment 12 Jeremy Katz 2006-09-15 11:12:30 EDT
Hmm... what's happening is that we're having things sorted such that
mkinitrd.ppc64 is installed later than the kernel and rpm is only putting down
the ppc64 binary
Comment 13 Arnd Bergmann 2006-09-15 11:41:39 EDT
two points:

- mkinitrd.ppc is installed just before the kernel, mkinitrd.ppc64 is installed 
much later. Why do we install them both in the first place? why doesn't 
mkinitrd.ppc do the right thing? 

- the last three changelog entries in mkinitrd.spec refer to bug 205194, but 
none of them actually fixed it...
Comment 14 Gene Czarcinski 2006-09-15 16:11:01 EDT
Bingo!  This same problem occurs on a x86_64 system installing the 64 bit
fc6test3.  Doing a 32 bit install works ok.

In both cases there is a 32 bit and a 64 bit mkinitrd being installed but the 64
bit one is installed AFTER the kernel is installed.
Comment 15 Gene Czarcinski 2006-09-15 16:30:09 EDT
If you indicate here when this is fixed in rawhide, I will take a shot at
testing the fix.
Comment 16 IBM Bug Proxy 2006-09-19 11:10:51 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |gerhard.stenzel@de.ibm.com




------- Additional Comments From gerhard.stenzel@de.ibm.com  2006-09-19 11:09 EDT -------
The same problem (and workaround) occur also on a JS20 
Comment 17 Peter Jones 2006-09-20 11:19:04 EDT

*** This bug has been marked as a duplicate of 206453 ***

Note You need to log in before you can comment on or make changes to this bug.