Bug 206583 - oowriter crashes while handling Arabic fonts
oowriter crashes while handling Arabic fonts
Status: CLOSED DUPLICATE of bug 205315
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 00:53 EDT by Craig Pemberton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 05:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ogden's British American Scientific International Commercial panoptic lexicon, translated into Arabic (13.49 KB, text/plain)
2006-09-15 00:53 EDT, Craig Pemberton
no flags Details

  None (edit)
Description Craig Pemberton 2006-09-15 00:53:46 EDT
Description of problem: 
I had a file of almost 1000 arabic words open in oowriter, numbered with roman
numerals. I closed this file and oowriter genrated a report.

Version-Release number of selected component (if applicable):
See report.

How reproducible:
I will attach the guilty file.

Steps to Reproduce:
1. Open this file.
2. If I made any changes to the file at all, it was only adding one or two
whitespaces. . . I don't recall.
3. Close the file.
  
Actual results:
Report generated.

Expected results:
No report.

Additional info:

Video Driver is probably: radeon fglrx (true)
Desktop is: not GNOME (KDE)
libgcj version is: libgcj-4.1.1-1.fc5
kernel is: Linux 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 athlon i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.17.2
accessibility is: false
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 20
Policy from config file:        targeted
...end sestatus details ...
0x565640: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e640
0x565e80: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1ee80
0x44b9e420:  + 0x420 (__kernel_sigreturn + 0x0)
0x17bca5f: /lib/libdb-4.3.so + 0xa0a5f (__db_e_detach + 0x15f)
0x17b83ad: /lib/libdb-4.3.so + 0x9c3ad
0x17b860c: /lib/libdb-4.3.so + 0x9c60c (__dbenv_close + 0x6c)
0x1793da9: /lib/libdb-4.3.so + 0x77da9 (__db_close + 0xf9)
0x17a30a9: /lib/libdb-4.3.so + 0x870a9 (__db_close_pp + 0x99)
0x17efc4a: /lib/libdb-4.3.so + 0xd3c4a
0x1697bb1: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x35bb1
0x16930eb: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x310eb
0x167b2ae: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x192ae
0x74a754: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x21754 (cppu::OWeakObject::release() + 0x44)
0x167b237: /usr/lib/openoffice.org2.0/program/libucpchelp1.so + 0x19237
0x22883c6: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xa3c6
0x22972cb: /usr/lib/openoffice.org2.0/program/libucb1.so + 0x192cb
0x74a754: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x21754 (cppu::OWeakObject::release() + 0x44)
0x22971a3: /usr/lib/openoffice.org2.0/program/libucb1.so + 0x191a3
0x22883c6: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xa3c6
0x22887da: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xa7da
0x22887ed: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xa7ed
0x2289f33: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xbf33
0x2289f7b: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xbf7b
0x2289fa5: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xbfa5
0x2289fc5: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xbfc5
0x2289ff1: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xbff1
0x228a019: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xc019
0x228a061: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xc061
0x228a08b: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xc08b
0x228a099: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xc099
0x228a145: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xc145
0x228a16f: /usr/lib/openoffice.org2.0/program/libucb1.so + 0xc16f
0x228763f: /usr/lib/openoffice.org2.0/program/libucb1.so + 0x963f
0x74a754: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x21754 (cppu::OWeakObject::release() + 0x44)
0x228756f: /usr/lib/openoffice.org2.0/program/libucb1.so + 0x956f
0x73f15c: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x1615c
0x750fd7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x27fd7
0x756e53: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x2de53 (cppu::OComponentHelper::release() + 0x51)
0x751fc7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x28fc7
0x741648: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x18648
0x7531fd: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x2a1fd
0x74a754: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x21754 (cppu::OWeakObject::release() + 0x44)
0x74b4bd: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x224bd (cppu::OWeakAggObject::release() + 0x39)
0x756e8e: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x2de8e (cppu::OComponentHelper::release() + 0x8c)
0x751fc7: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x28fc7
0x74fdb5: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x26db5
0x13c5f36: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xaf36
0x13c66b9: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xb6b9
0x13c9cf8: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xecf8
0x13c9d3f: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xed3f
0x13c9edd: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xeedd
0x13c9f07: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xef07
0x13c38f2: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x88f2
0x74514d: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x1c14d (cppu::WeakComponentImplHelperBase::dispose() + 0x75)
0x13c9013: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0xe013
0x13c0e93: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x5e93
0x13c4206: /usr/lib/openoffice.org2.0/program/servicemgr.uno.so + 0x9206
0x753791: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x2a791
0x754c6d: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x2bc6d
0x74514d: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x1c14d (cppu::WeakComponentImplHelperBase::dispose() + 0x75)
0x755d1b: /usr/lib/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 + 0x2cd1b
0xab7228: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x31228
(desktop::Desktop::DestroyApplicationServiceManager(com::sun::star::uno::Reference<com::sun::star::lang::XMultiServiceFactory>&)
+ 0xa8)
0xaa8f0c: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x22f0c
(desktop::Desktop::DeInit() + 0x3c)
0xbcc548: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e548
(DeInitVCL() + 0x1ee)
0xbcc9b3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e9b3
0xbcca1d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea1d (SVMain()
+ 0x2b)
0xaa4e53: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee53 (sal_main +
0x57)
0xaa4e9f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1ee9f (main + 0x27)
0x45441724: /lib/libc.so.6 + 0x15724 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4d1
Comment 1 Craig Pemberton 2006-09-15 00:53:46 EDT
Created attachment 136323 [details]
Ogden's British American Scientific International Commercial panoptic lexicon, translated into Arabic
Comment 2 Caolan McNamara 2006-09-15 05:03:44 EDT
I think you have been bitten by bug 205315

yum updating your db4 should resolve this

*** This bug has been marked as a duplicate of 205315 ***

Note You need to log in before you can comment on or make changes to this bug.