Bug 206745 - Liferea requires a specific Firefox
Liferea requires a specific Firefox
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 206770 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 22:10 EDT by Pete Zaitcev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-16 00:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2006-09-15 22:10:29 EDT
Description of problem:

A run of "yum update" ends with an error:
Error: Missing Dependency: firefox = 1.5.0.6 is needed by package liferea

Version-Release number of selected component (if applicable):

liferea-1.0.22-1.fc6

How reproducible:

Always reproducible with "rpm -q --whatrequires", but an actual
failure only happens when rebuilds are in progress.

Steps to Reproduce:
1. Run yum
  
Actual results:

Error (see above)

Expected results:

No error

Additional info:

This is obviously nothing a simple rebuild won't fix, but I would think
that there's no need to be so specific about the version of Firefox
that Liferea needs. Please feel free to close as NOTABUG, with explanation
why a specific version of Firefox is needed.
Comment 1 Pete Zaitcev 2006-09-15 22:12:31 EDT
BTW
[root@lembas zaitcev]# rpm -q --provides firefox | grep firefox
firefox = 1.5.0.6-9

So maybe it was an automatically generated dependancy that tripped Liferea.
Comment 2 Pete Zaitcev 2006-09-15 23:21:24 EDT
Here's one e-mail from today:

----------------------------
From: Louis Garcia <louisg00@bellsouth.net>
To: fedora-devel-list@redhat.com
Subject: Apps that depend on firefox
Date: Fri, 15 Sep 2006 16:07:51 -0400

When firefox was updated to 1.5.0.7 the apps that depend on gecko were
not rebuild. Apps like epiphany and yelp and will not run now.

-Louis
----------------------------

It should be clear, because Liferea renders HTML. Right? There remains
a mystery, however. When I look at what libraries /usr/bin/liferea-bin
loads, there's nothing from Firefox. Maybe Gecko is linked statically
or we use some built-in in reality... Either way, I'd like someone who
knows how it works to investigate if the precise dependency is needed.
Comment 3 Brian Pepple 2006-09-16 00:34:05 EDT
Yeah, this has already been rebuilt earlier today, the extras packages just
haven't been pushed out yet.

http://buildsys.fedoraproject.org/build-status/job.psp?uid=17593

The reason for a specific firefox:
https://sourceforge.net/tracker/index.php?func=detail&aid=1455278&group_id=87005&atid=581684
Comment 4 Pete Zaitcev 2006-09-16 01:18:41 EDT
You still haven't mentioned why this requrement exists.
Since no dynamic libraries are used, there's no runtime dependency.
The dependency could be just on firefox, or even on gnome-moz-remote.
Comment 5 Brian Pepple 2006-09-16 09:01:58 EDT
*** Bug 206770 has been marked as a duplicate of this bug. ***
Comment 6 Michael Schwendt 2006-09-16 11:16:47 EDT
Pete, the reason for the strict dependency is given in comment 3,
see the ticket at SF. The background is explained there. You are mistaken
about the runtime deps. There are dependencies on firefox libs in Liferea's
"Mozilla" rendering plugin (this could be moved into a sub-package, though).
With recent releases of Liferea, the Firefox home directory path is hardcoded
into the binary, which is an upstream decision.
Comment 7 Pete Zaitcev 2006-09-16 14:02:51 EDT
Sorry. I felt that I was missing something, so didn't reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.