Bug 206755 - yum list available ( or any other action) results in "Metadata file does not match checksum". Inconsistent behavior, sometimes it works.
yum list available ( or any other action) results in "Metadata file does not ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
:
: 208547 (view as bug list)
Depends On:
Blocks: 207318
  Show dependency treegraph
 
Reported: 2006-09-16 02:59 EDT by Michael Kearey
Modified: 2013-01-10 05:11 EST (History)
4 users (show)

See Also:
Fixed In Version: rhn4141
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 09:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Kearey 2006-09-16 02:59:03 EDT
Description of problem:
Running yum on a RHEL5 Beta, registered to RHN. More often than not, yum will
fail with the message as shown in the Summary. I have seen this problem with yum
in Fedora Core [1-6] over a number of years. I think it may be due to
inconsistent cached files in a proxy, yet I am not using a proxy.

Our Hosted RHN does some form of reverse proxy yes? 





Version-Release number of selected component (if applicable):
[root@unused-138 rhel-i386-server-5-beta]# rpm -qa \*yum\*
yum-2.9.3-2
yum-metadata-parser-1.0-7.1.fc6
yum-rhn-plugin-0.0.8-2.el5

How reproducible:
7 out of ten times, the failure occurs


Steps to Reproduce:
1. Install the Beta RHEL5
2. Register to RHN 
3. Run 'yum list available'
  
Actual results:

#  yum list available
Setting up repositories
rhel-i386-server-5-beta   100% |=========================|  672 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 504 kB    00:01
https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5-beta/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from rhel-i386-server-5-beta: [Errno
256] No more mirrors to try.


Expected results:

A list of packages available returned by yum.

Additional info:
Comment 1 James Bowes 2006-09-18 10:04:58 EDT
Because there are multiple physical machines serving up the repodata files, and
because gziped files may contain a timestamp, the files served from each machine
have identical content, but different checksums. The fix will be to not include
a timestamp on the compressed files.
Comment 4 Beth Nackashi 2006-09-27 14:44:03 EDT
This appears to be working with

yum-rhn-plugin-0.1.4-1.el5
yum-2.9.6-1
yum-metadata-parser-1.0-7.1.fc6
yum-updatesd-2.9.6-1

talking to RHN414.  Tested in stage environment.
Comment 5 James Bowes 2006-09-29 09:00:33 EDT
*** Bug 208547 has been marked as a duplicate of this bug. ***
Comment 6 Beth Nackashi 2006-10-04 09:56:40 EDT
Verified in prod with

yum-updatesd-2.9.7-1
yum-rhn-plugin-0.1.5-1.el5
yum-2.9.7-1
yum-metadata-parser-1.0-7.1.fc6


Note You need to log in before you can comment on or make changes to this bug.