Bug 208547 - Metadata file does not match checksum
Metadata file does not match checksum
Status: CLOSED DUPLICATE of bug 206755
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 07:15 EDT by Ola Thoresen
Modified: 2013-01-10 05:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 09:00:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ola Thoresen 2006-09-29 07:15:23 EDT
Description of problem:
We are unable to use yum on a RHEL-5-beta due to wrong checksum

Version-Release number of selected component (if applicable):

# rpm -q redhat-release
redhat-release-4.91Server-1

# rpm -qa | grep yum
yum-rhn-plugin-0.0.8-2.el5
yum-2.9.3-2
yum-metadata-parser-1.0-7.1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Run yum update (or any other yum command)
2. Error
3.
  
Actual results:

https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-i386-server-5-beta/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from rhel-i386-server-5-beta: [Errno
256] No more mirrors to try.

Expected results:
yum should do its thing

Additional info:
This also affects rhn_check as it uses yum as a backend:

# rhn_check 
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 314, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 194, in handle_action
    (status, message, data) = run_action(method, params)
  File "/usr/sbin/rhn_check", line 150, in run_action
    (status, message, data) = do_call(method, params)   
  File "/usr/sbin/rhn_check", line 68, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 171, in update
    return runTransaction(transaction_data)
  File "/usr/share/rhn/actions/packages.py", line 196, in runTransaction
    yum_base = YumAction()
  File "/usr/share/rhn/actions/packages.py", line 50, in __init__
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 312, in doSackSetup
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 200, in populateSack
    sack.populate(repo, with, callback, cacheonly)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 88, in populate
    xml = repo.getPrimaryXML()
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 655, in getPrimaryXML
    return self.retrieveMD('primary')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 153, in retrieveMD
    return YumRepository.retrieveMD(self, mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 642, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 458, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
yum.Errors.RepoError: failure: repodata/primary.xml.gz from
rhel-i386-server-supplementary-5-beta: [Errno 256] No more mirrors to try.


The checksum is indeed wrong:

# cat /var/cache/yum/rhel-i386-server-5-beta/repomd.xml 
<?xml version="1.0" encoding="UTF-8"?>
<repomd xmlns="http://linux.duke.edu/metadata/repo">
  <data type="filelists">
    <location href="repodata/filelists.xml.gz"/>
    <checksum type="sha">ea14a7d159442b132ec43d00410b879d2335ef54</checksum>
    <timestamp>1158758462</timestamp>
    <open-checksum
type="sha">776f14885ded7b38b12320d69801e9d3f7ce061d</open-checksum>
  </data>
  <data type="primary">
    <location href="repodata/primary.xml.gz"/>
    <checksum type="sha">a3a9f2c503eca6c338ec1fa338f7e075648d9699</checksum>
    <timestamp>1158758462</timestamp>
    <open-checksum
type="sha">b7e4c0fbadf269a08a827bbc23f15aebfd713f8d</open-checksum>
  </data>
</repomd>


# sha1sum /var/cache/yum/rhel-i386-server-5-beta/primary.xml.gz 
84814d82ac310eb7655a1a60bec2f12261ac4412 
/var/cache/yum/rhel-i386-server-5-beta/primary.xml.gz
Comment 1 James Bowes 2006-09-29 09:00:17 EDT

*** This bug has been marked as a duplicate of 206755 ***

Note You need to log in before you can comment on or make changes to this bug.