Bug 206807 - FC6 T3 fails to install on a Dell Latitude D610
FC6 T3 fails to install on a Dell Latitude D610
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 207647 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 17:35 EDT by John Baer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 18:12:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Baer 2006-09-16 17:35:46 EDT
Description of problem:

Booting to either a CD or DVD install disk anaconda hangs after loading the AHCI
driver on a Dell Latitude D610.

Version-Release number of selected component (if applicable):

FC6 Test 3

How reproducible:

Very

Steps to Reproduce:
1. Boot to cd or dvd
2. Press enter to load graphical installer
3.
  
Actual results:

Hangs after loading ahci driver.

Expected results:

Anaconda to load.

Additional info:
Comment 1 Trond Eivind Glomsrød 2006-09-17 16:28:30 EDT
Same for Latitude D810  (both USB storage and CD)
Comment 2 David Miller 2006-09-20 16:05:34 EDT
I get the same exact problem on a Thinkpad T43p.

I tried both the normal default graphical installer, and "linux text",
both hang right after loading the AHCI driver.

There is also a bunch of garbage characters on the screen, these are
printed right before the "Loading AHCI driver" dialogue comes up.
These garbage characters were also present in FC6 Test2, but Test2
did not have the hang.
Comment 3 Dave Jones 2006-09-20 16:29:00 EDT
the garbage is pretty much guaranteed to be either an oops or a lockdep trace.
(It turns into junk because we print text from the kernel in the middle of a
multi-byte unicode sequence).

Can you try and flip to another tty just before it happens, and see if there's
anything useful spewed there ?
Comment 4 David Miller 2006-09-23 18:38:39 EDT
Right before the hang:

libata version 2.00 loaded.
ahci: 0000:00:1f.2: version 2.0
ahci: probe of 0000:00:1f.2 failed with error -12
IBM TrackPoint firmware: 0x0e, buttons: 3/3
input: TPPS/2 IBM TrackPoint as /class/input/input4
---

And at the point the machine is locked solid.
Comment 5 David Miller 2006-09-25 22:35:44 EDT
Oddly enough with the current rawhide boot.iso the problem doesn't
occur (although a post-install failure occurs which I'll make
a seperate bugzilla for).

This doesn't mean the bug is fixed, it could still be something
specific to a full DVD install.
Comment 6 Jeremy Katz 2006-09-27 16:42:50 EDT
It's probably worth trying with the rescuecd.iso -- that has the second stage on
the same disc and so exercises most of the same loader code as doing a CD install
Comment 7 Trond Eivind Glomsrød 2006-10-02 04:51:13 EDT
It happened with all sorts of installation methods for me (long before selecting
full or not), while it no longer seems to be an issue with FC6pre
Comment 8 David Miller 2006-10-04 21:09:22 EDT
*** Bug 207647 has been marked as a duplicate of this bug. ***
Comment 9 David Miller 2006-10-04 21:10:50 EDT
This bug no longer occurs in current rawhide.
Comment 10 Trond Eivind Glomsrød 2006-10-28 18:12:56 EDT
And it didn't happen with Fedora Core 6.

Note You need to log in before you can comment on or make changes to this bug.