Bug 206817 - possible recursive locking in PS/2 driver
possible recursive locking in PS/2 driver
Status: CLOSED DUPLICATE of bug 200025
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 19:00 EDT by Han-Wen Nienhuys
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 00:20:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of thinkpad t60 (28.58 KB, text/plain)
2006-09-16 19:00 EDT, Han-Wen Nienhuys
no flags Details

  None (edit)
Description Han-Wen Nienhuys 2006-09-16 19:00:19 EDT
upon boot (kernel-2.6.17-1.2647.fc6) on my thinkpad t60, I get a stacktrace.
Full dmesg output attached.

hub 4-0:1.0: 2 ports detected
input: SynPS/2 Synaptics TouchPad as /class/input/input1
PM: Adding info for serio:serio2

=============================================
[ INFO: possible recursive locking detected ]
2.6.17-1.2647.fc6 #1
---------------------------------------------
kseriod/139 is trying to acquire lock:
 (&ps2dev->cmd_mutex#2){--..}, at: [<c0614318>] mutex_lock+0x21/0x24

but task is already holding lock:
 (&ps2dev->cmd_mutex#2){--..}, at: [<c0614318>] mutex_lock+0x21/0x24

other info that might help us debug this:
4 locks held by kseriod/139:
 #0:  (serio_mutex){--..}, at: [<c0614318>] mutex_lock+0x21/0x24
 #1:  (&serio->drv_mutex){--..}, at: [<c0614318>] mutex_lock+0x21/0x24
 #2:  (psmouse_mutex){--..}, at: [<c0614318>] mutex_lock+0x21/0x24
 #3:  (&ps2dev->cmd_mutex#2){--..}, at: [<c0614318>] mutex_lock+0x21/0x24
stack backtrace:
 [<c04051ee>] show_trace_log_lvl+0x58/0x171
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b9e1>] __lock_acquire+0x778/0x99c
 [<c043c176>] lock_acquire+0x4b/0x6d
 [<c06141a9>] __mutex_lock_slowpath+0xbc/0x20a
 [<c0614318>] mutex_lock+0x21/0x24
 [<c05970ac>] ps2_command+0x7e/0x2cd
 [<c059c5a9>] psmouse_sliced_command+0x1c/0x5a
 [<c059faa7>] synaptics_pt_write+0x1e/0x43
 [<c0596f96>] ps2_sendbyte+0x3e/0xd6
 [<c0597126>] ps2_command+0xf8/0x2cd
 [<c059c1dc>] psmouse_probe+0x1d/0x68
 [<c059d150>] psmouse_connect+0xfa/0x221
 [<c05949c9>] serio_connect_driver+0x1e/0x2e
 [<c05949ef>] serio_driver_probe+0x16/0x18
 [<c05552d6>] driver_probe_device+0x45/0x92
 [<c055532b>] __device_attach+0x8/0xa
 [<c0554c6b>] bus_for_each_drv+0x3a/0x65
 [<c0555386>] device_attach+0x59/0x6e
 [<c05549a9>] bus_attach_device+0x16/0x2b
 [<c0553dfb>] device_add+0x1f8/0x2e0
 [<c059544b>] serio_thread+0xc6/0x283
 [<c0436575>] kthread+0xc3/0xf2
 [<c0402005>] kernel_thread_helper+0x5/0xb

DWARF2 unwinder stuck at kernel_thread_helper+0x5/0xb
Leftover inexact backtrace:
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b9e1>] __lock_acquire+0x778/0x99c
 [<c043c176>] lock_acquire+0x4b/0x6d
 [<c06141a9>] __mutex_lock_slowpath+0xbc/0x20a
 [<c0614318>] mutex_lock+0x21/0x24
 [<c05970ac>] ps2_command+0x7e/0x2cd
 [<c059c5a9>] psmouse_sliced_command+0x1c/0x5a
 [<c059faa7>] synaptics_pt_write+0x1e/0x43
 [<c0596f96>] ps2_sendbyte+0x3e/0xd6
 [<c0597126>] ps2_command+0xf8/0x2cd
 [<c059c1dc>] psmouse_probe+0x1d/0x68
 [<c059d150>] psmouse_connect+0xfa/0x221
 [<c05949c9>] serio_connect_driver+0x1e/0x2e
 [<c05949ef>] serio_driver_probe+0x16/0x18
 [<c05552d6>] driver_probe_device+0x45/0x92
 [<c055532b>] __device_attach+0x8/0xa
 [<c0554c6b>] bus_for_each_drv+0x3a/0x65
 [<c0555386>] device_attach+0x59/0x6e
 [<c05549a9>] bus_attach_device+0x16/0x2b
 [<c0553dfb>] device_add+0x1f8/0x2e0
 [<c059544b>] serio_thread+0xc6/0x283
 [<c0436575>] kthread+0xc3/0xf2
 [<c0402005>] kernel_thread_helper+0x5/0xb
Comment 1 Han-Wen Nienhuys 2006-09-16 19:00:19 EDT
Created attachment 136459 [details]
dmesg of thinkpad t60
Comment 2 Dave Jones 2006-09-17 00:20:06 EDT

*** This bug has been marked as a duplicate of 200025 ***

Note You need to log in before you can comment on or make changes to this bug.