Bug 206870 - xfsprogs prior to 2.8.10 have a really serious bug
xfsprogs prior to 2.8.10 have a really serious bug
Status: CLOSED DUPLICATE of bug 206869
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-09-17 09:25 EDT by Valent Turkovic
Modified: 2015-01-04 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-17 09:29:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2006-09-17 09:25:19 EDT
Description of problem:
I know that you officially doesn't support anything but ext3 but you still put 
xfsprogs package with fedora and there is a really big problem with it.

xfsprogs prior to 2.8.10 have a really serious bug which leads to xfs partition 
errors and xfs_repair can't repair the errorous partition.

xfs partition crashes, gives read and write errors and running xfs_repair 
doesn't repair it. 

The bug is described in here:

You need to put an updated xfsprogs 2.8.10 or newer package for fedora core 5, 
and all other.

Thank you.

Version-Release number of selected component (if applicable):
xfs 2.6, fedora core 5

How reproducible:
just work with files on xfs partition, and soon they break

Steps to Reproduce:
Actual results:
fatal error -- can't read block 16777216 for directory inode 23727780

Expected results:
xfs_repair should repair all errors on xfs partition

Additional info:
Comment 1 Johan Kok 2006-09-17 09:29:48 EDT
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 206869 ***

Note You need to log in before you can comment on or make changes to this bug.