Bug 206965 - virt-manager can't create new virtual machine
virt-manager can't create new virtual machine
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
: 208247 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 11:12 EDT by Phil Hale
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 11:49:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Hale 2006-09-18 11:12:44 EDT
Description of problem:
When I try to create a new virtual machine, I get through the wizard and click
on "Finish" but no new virtual machine is created.  When I look in /etc/xen for
the config file, it doesn't exist.  xenguest-install seems to have the same issue.

Version-Release number of selected component (if applicable):
virt-manager-0.2.1-2
xen-3.0.2-33

How reproducible:
everytime

Steps to Reproduce:
1. Start virt-manager, and click on the "New" button. 
2. Run through the new Virtual system, selecting to create a Fully Virtualized
system, in this case CentOS, but it happens when I try to create a Windows XP
too.  Select a already mounted CentOS 4.4 x86_64 Disk on for the install media.
  Select a Simple file "/var/xen/images/centos.img" at 8000 MB for storage
space.  Use the up and down arrows to define max memory of 512 MB and 256 as
starting Memory with 1 virtual CPU. 
3. After running through this setup, I click next and get to the Ready to begin
screen.  I click on finish and nothing happens.
  
Actual results:
No virtual machine is created.  Nothing exists in the /etc/xen folder.

Expected results:
Xen should create the new virtual machine configuration and start the install.


Additional info:

Tailing the /var/log/xen/xend.log file shows the following errors:
[2006-09-18 10:08:35 xend.XendDomainInfo 2756] ERROR (XendDomainInfo:200) Domain
construction failed
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
193, in create
    vm.initDomain()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
1273, in initDomain
    self.info['device'])
  File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 47, in create
    return findImageHandlerClass(imageConfig)(vm, imageConfig, deviceConfig)
  File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 77, in __init__
    self.configure(imageConfig, deviceConfig)
  File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 293, in
configure
    self.dmargs = self.parseDeviceModelArgs(imageConfig, deviceConfig)
  File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 370, in
parseDeviceModelArgs
    raise VmError('Disk image does not exist: %s' %
VmError: Disk image does not exist: /media/CentOS 4.4 Final x86_64 bin1of4
[2006-09-18 10:08:35 xend.XendDomainInfo 2756] DEBUG (XendDomainInfo:1415)
XendDomainInfo.destroy: domid=2
[2006-09-18 10:08:35 xend.XendDomainInfo 2756] DEBUG (XendDomainInfo:1423)
XendDomainInfo.destroyDomain(2)
[2006-09-18 10:08:35 xend 2756] ERROR (SrvBase:87) Request create failed.
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/web/SrvBase.py", line 85, in perform
    return op_method(op, req)
  File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDomainDir.py",
line 82, in op_create
    raise XendError("Error creating domain: " + str(ex))
XendError: Error creating domain: Disk image does not exist: /media/CentOS 4.4
Final x86_64 bin1of4
Comment 1 Daniel Berrange 2006-09-18 13:03:36 EDT
The logfile snippet posted above shows that it failed to setup a virtual disk
device pointing to

  /media/CentOS 4.4 Final x86_64 bin1of4

Looks like the install code is mistakenly passing the mount point through to
XenD, rather than the device node (ie it should have passed in /dev/cdrom, or
similar).
Should be fairly simple to fix
Comment 2 Daniel Berrange 2006-09-27 08:34:07 EDT
*** Bug 208247 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Berrange 2006-09-27 11:49:40 EDT
This issue is fixed in virt-manager-0.2.3-1.fc6 which will appear in rawhide
within the next day.

Note You need to log in before you can comment on or make changes to this bug.