Bug 208247 - creating new HVM fails silently
creating new HVM fails silently
Status: CLOSED DUPLICATE of bug 206965
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 08:00 EDT by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 08:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/xen/xend.log (6.37 KB, text/plain)
2006-09-27 08:00 EDT, Andy Burns
no flags Details

  None (edit)
Description Andy Burns 2006-09-27 08:00:54 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Name   : virt-manager
Arch   : x86_64
Version: 0.2.2
Release: 1.fc6

Name   : xen
Arch   : x86_64
Version: 3.0.2
Release: 36


How reproducible:
100%

Steps to Reproduce:
1. start virt-manager
2. create new vm, 
name=xptest
method=fully virtualised
dvd location=/media/xpdisk (not using .iso file)
disk=lvm partition /dev/mapper/vg0-lv2_xphome (also tried simple file)
guest memory =500Mb
host memory=2GB
vcpu count=1
host cpu count=2 (this is a single CPU Xeon 5110)

confirm all details on summary screen, click finish
 
Actual results:

a dialog box is raised and closed so quickly I can't see it's contents
if using a simple disk file, then it is created, otherwise notjhing happens


tried running v-rt-manager from console to catch any stdout/stderr messages, but
none given, checked dmesg and saw a coiple of selinux denied messages, 

# dmesg
SELinux: initialized (dev hdb, type iso9660), uses genfs_contexts
audit(1159360699.813:13): avc:  denied  { search } for  pid=3536 comm="python"
name="media" dev=dm-0 ino=360449 scontext=system_u:system_r:xend_t:s0
tcontext=system_u:object_r:mnt_t:s0 tclass=dir
audit(1159360699.813:14): avc:  denied  { getattr } for  pid=3536 comm="python"
name="/" dev=hdb ino=1536 scontext=system_u:system_r:xend_t:s0
tcontext=system_u:object_r:iso9660_t:s0 tclass=dir

re-tried with selinux permissive mode instead of enforcing mode, no better

"xm dmesg" doesn't seem to show anything erelated to creating a new VM

"xm list" only shows dom-0


Expected results:

new VM created :-)
Comment 1 Andy Burns 2006-09-27 08:00:54 EDT
Created attachment 137217 [details]
/var/log/xen/xend.log
Comment 2 Daniel Berrange 2006-09-27 08:33:54 EDT
The problem is that we mistakenly passed the CDROM mount point, rather than
device node to Xen. This is a dup of bz 206965 so closing this ticket. 

*** This bug has been marked as a duplicate of 206965 ***
Comment 3 Andy Burns 2006-09-27 11:54:17 EDT
I saw the reference to the mountpoint in the log file so created an .iso file
from the CD using dd, when I specified the iso file instead of the optical
device, virt-manager seemed to gop a stage further, but xen rebooted the host
machine :-(

If I can duplicate I'll log a new bug ...
Comment 4 Daniel Berrange 2006-09-27 12:01:13 EDT
If its got as far as starting the VM, then this is likely a bug in the HVM part
of xen, so file it against 'xen' component. For HVM guests its also useful to
include 'xm dmesg' output as well as regular qemu-dm & xen & xen-debug  logs
from /var/log/xen/

Note You need to log in before you can comment on or make changes to this bug.