Bug 206977 - x86_64 FC5 to FC6test3 Upgrade crash on "Unknown header tag %s" % tag
x86_64 FC5 to FC6test3 Upgrade crash on "Unknown header tag %s" % tag
Status: CLOSED DUPLICATE of bug 206913
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 12:01 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 14:02:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-09-18 12:01:27 EDT
Traceback (most recent call first):
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 612, in tagByName
    raise Errors.MiscError, "Unknown header tag %s" % tag
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 629, in returnSimple
    return self.tagByName(thing)
  File "/usr/lib/anaconda/sortedtransaction.py", line 17, in __getMedia
    uri = po.returnSimple('basepath')
  File "/usr/lib/anaconda/sortedtransaction.py", line 42, in add
    id = self.__getMedia(txmember.po)
  File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 298, in
addObsoleted
    self.add(txmbr)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1840, in update
    self.tsInfo.addObsoleted(installed_pkg, obsoleting_pkg)
  File "/usr/lib/anaconda/yuminstall.py", line 960, in doPostSelection
    self.ayum.update()
  File "/usr/lib/anaconda/backend.py", line 154, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)

  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 919, in nextClicked
    self.anaconda.dispatch.gotoNext()
MiscError: Unknown header tag basepath

Local variables in innermost frame:
self: glibc-kernheaders - 3.0-5.2.x86_64
tag: basepath
e: 'unknown header tag'

Full details...
http://devserv.devel.redhat.com/~wtogami/anacrash/

It seemed to do this on every package that was no longer shipped in FC6.  We
removed each, the tried upgrade again, then it would crash again.  We repeated
this until it crashed on dbus-devel in this same manner... which did not fit
this pattern.
Comment 1 Jeremy Katz 2006-09-18 14:02:47 EDT

*** This bug has been marked as a duplicate of 206913 ***

Note You need to log in before you can comment on or make changes to this bug.