Bug 206913 - Anaconda exception after "Retrieving install information..." (HTTP install, upgrade from FC5)
Anaconda exception after "Retrieving install information..." (HTTP install, u...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 205961 206531 206811 206888 206921 206977 207632 207749 209621 209984 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-17 23:12 EDT by Bojan Smojver
Modified: 2007-11-30 17:11 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 08:13:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash dump (100.15 KB, text/plain)
2006-09-17 23:12 EDT, Bojan Smojver
no flags Details
Anaconda dump file (87.79 KB, text/plain)
2006-09-18 07:55 EDT, Gilboa Davara
no flags Details
Anaconda log file (14.47 KB, text/plain)
2006-09-18 07:56 EDT, Gilboa Davara
no flags Details

  None (edit)
Description Bojan Smojver 2006-09-17 23:12:44 EDT
Description of problem:
On install started from either boot.iso or Rescue CD and using the HTTP method
from download.fedora.redhat.com, Anaconda crashes with an exception. Full dump
will be attached. This was an upgrade from FC5.


Version-Release number of selected component (if applicable):
The one shipped with FC6T3.


How reproducible:
Always.


Steps to Reproduce:
1. Attempt to install FC6T3 on x86_64 using HTTP method, upgrade from FC5.

  
Actual results:
Anaconda exception


Expected results:
Should work.


Additional info:
See attached dump file.
Comment 1 Bojan Smojver 2006-09-17 23:12:45 EDT
Created attachment 136503 [details]
Anaconda crash dump
Comment 2 Gilboa Davara 2006-09-18 07:50:08 EDT
Same here.

Anaconda dies when trying to upgrade a FC5/i386 vmware (server) image using DVD ISO.
Logs attached.

- Gilboa
Comment 3 Gilboa Davara 2006-09-18 07:55:06 EDT
Created attachment 136534 [details]
Anaconda dump file
Comment 4 Gilboa Davara 2006-09-18 07:56:28 EDT
Created attachment 136535 [details]
Anaconda log file
Comment 5 Miloš Komarčević 2006-09-18 12:51:34 EDT
I got pretty much the same dump (java-1.4.2-gcj-compat-plugin package implicated
instead of valgrand reported here) when doing a FC6test2->FC6test3 upgrade using
the i386 rescuecd for an ftp install.
Comment 6 Jan "Yenya" Kasprzak 2006-09-18 13:27:55 EDT
Same here (FC6t2 -> FC6t3 upgrade using diskboot.img on an USB flashdisk, FTP
install from a local Fedora mirror, i386 arch, the package in question is
glibc-kernheaders-3.0-45.3.i386 here instead of valgrind).
Comment 7 Gilboa Davara 2006-09-18 13:39:37 EDT
FC6T2 -> T3 is not support.
FC5 -> FC6 -should- be.

I really hope we'll get to see a fixed FC6T4 before the release.
As it is, FC6 is looking like a disaster waiting to happen.

- Gilboa
Comment 8 Jeremy Katz 2006-09-18 14:01:46 EDT
*** Bug 206921 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2006-09-18 14:02:59 EDT
*** Bug 206977 has been marked as a duplicate of this bug. ***
Comment 10 Miloš Komarčević 2006-09-18 15:21:26 EDT
FWIW, looks like this is only related to handling of obsoleted packages. After
removing a few of those manually from FC6T2, the upgrade goes ahead fine (I know
it's not supported, but hope it can still be useful in fleshing out bugs).
Comment 11 Bojan Smojver 2006-09-18 17:44:36 EDT
Regarding comment #10 - this is how I fixed my upgrade from FC4 to FC5 on x86_64
- by removing packages that were conflicting. Unfortunately, I didn't bother
filing a bug report, thinking "somebody else *must* have bumped into this before
me". Well, apparently not :-(
Comment 12 Gilboa Davara 2006-09-19 04:48:05 EDT
Milos,

I never got to the package selection dialog.
Anaconda dies right after the previous Fedora detection.

- Gilboa
Comment 13 Miloš Komarčević 2006-09-19 05:23:48 EDT
Re comment #12: never said I did any package selection and removal in anaconda
during upgrade, and in fact you're right, there is no such step. You have to do
it from your current system before booting the CD. The tedious part is finding
those obsoleted packages, either by removing the one from the anaconda dump,
rebooting back and forth the current system and install CD, and repeating that
process as many times as needed, or from the current system try a yum update to
rawhide just to get the list of obsoleted packages, without actually accepting
the yum update.
Comment 14 Gilboa Davara 2006-09-19 05:37:52 EDT
Oh... Sorry my bad.

- Gilboa
Comment 15 Paul Nasrat 2006-09-19 07:28:13 EDT
*** Bug 206888 has been marked as a duplicate of this bug. ***
Comment 16 Paul Nasrat 2006-09-19 07:33:04 EDT
I see what is happening here, it's fallout from some yum changes. I've a
proposed patch I'm just testing out before commiting.
Comment 17 Paul Nasrat 2006-09-19 08:13:45 EDT
Fixed this should be in tomorrows rawhide
Comment 18 Gilboa Davara 2006-09-19 08:20:42 EDT
... Any chance of getting test4 (or even mastering a RAWHIDE iso) before
FC6-release is out?
This does seem like a major bug that requires some regression testing.

- Gilboa
Comment 19 Paul Nasrat 2006-09-19 08:39:15 EDT
*** Bug 205961 has been marked as a duplicate of this bug. ***
Comment 20 Miloš Komarčević 2006-09-19 10:42:57 EDT
Re comment #18: there is already a rescuecd iso being made in rawhide daily,
which can be used for a network install.
Comment 21 Paul Nasrat 2006-09-19 11:37:52 EDT
Also re comment #18 please read 

http://fedoraproject.org/wiki/Testing

The upgrade path involved in hitting the bug for an NFS/HTTP/FTP install is the
same in this case. 
Comment 22 Paul Nasrat 2006-09-20 03:07:06 EDT
*** Bug 206811 has been marked as a duplicate of this bug. ***
Comment 23 Paul Nasrat 2006-09-20 04:40:25 EDT
For those who wish to test with FC6T3 there is an updates.img available:

1) Grab http://people.redhat.com/pnasrat/206913-updates.img

Take the updates.img and use dd to write it to a USB key, then use
that with "linux updates" at the bootloader prompt.

You will need to dd it to the entire USB device, so make sure you backup
whatever may be on the USB drive first.  As root, ensure the device is seen by
the OS but not mounted.


dd if=206913-updates.img of=/dev/sda

Replace /dev/sda with the name of your USB key drive.
Comment 24 Andrew Overholt 2006-09-20 08:25:20 EDT
(In reply to comment #23)
> For those who wish to test with FC6T3 there is an updates.img available:
> 
> 1) Grab http://people.redhat.com/pnasrat/206913-updates.img

Will this work on ppc as well?
Comment 25 Paul Nasrat 2006-09-20 08:50:41 EDT
Yes the updates.img in this case is not architecture specific.  Type linux
updates at yaboot's boot: prompt.
Comment 26 Jeremy Katz 2006-09-22 00:38:25 EDT
*** Bug 207632 has been marked as a duplicate of this bug. ***
Comment 27 Chris Bagwell 2006-09-22 08:56:09 EDT
Yesterday I was able to successfully upgrade my FC5 using the "linux updates"
method described above.  I did get one or two strange messages as the USB thumb
drive confused anaconda and it wanted to format it at times.  But that would be
a different bug and may well be a feature.

This update to anaconda appears to have fixed the problem for me.
Comment 28 Paul Nasrat 2006-09-23 08:28:13 EDT
*** Bug 207749 has been marked as a duplicate of this bug. ***
Comment 29 Chris Lumens 2006-10-06 09:43:36 EDT
*** Bug 209621 has been marked as a duplicate of this bug. ***
Comment 30 Steve 2006-10-06 11:44:11 EDT
Bug related to Anaconda:
SYSTEM: Inspiron 9300 - 915 chipset, i386

install freezes at "Detecting Fedora Installations"
and may be due to the other bug that my internal drives are not found.
Comment 31 Paul Nasrat 2006-10-09 05:49:03 EDT
*** Bug 209984 has been marked as a duplicate of this bug. ***
Comment 32 Chris Wright 2007-03-19 18:39:52 EDT
*** Bug 206531 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.