Bug 207000 - openoffice crashes while enter Chinese text with scim
openoffice crashes while enter Chinese text with scim
Status: CLOSED DUPLICATE of bug 206845
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 13:55 EDT by Scott Tsai
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 14:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2006-09-18 13:55:49 EDT
Description of problem:
openoffice crashes while enter Chinese text with scim

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.4-3.1
scim-1.4.4-34.fc6
scim-libs-1.4.4-34.fc6
scim-chewing-0.3.1-4.fc6


How reproducible:
always

Steps to Reproduce:
1.start oowriter
2.activate scim with <Ctrl>+Space
3.type some Chinese characters
  
Actual results:
"OOo has crashed!" window appears.

Expected results:
Not crashing.

Additional info:
Willing to install -debuginfo packages if required.
(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/i810_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/vga_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers/fbdev_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers/vesa_drv.so
(II) Unloading /usr/lib/xorg/modules/drivers/vga_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-20-i386
(V)    kernel is: Linux 2.6.17-1.2647.fc6 #1 SMP Wed Sep 13 12:51:50 EDT 2006
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-3.1-i386
(VII)  accessibility is: false
(VIII) fedora release is: Fedora Core release 5.92 (FC6 Test3)
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0xb7fbe000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x00111000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x00590000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x00f32000)
	libdl.so.2 => /lib/libdl.so.2 (0x002cb000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00fbb000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x00ad3000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x003b1000)
	libm.so.6 => /lib/libm.so.6 (0x00983000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x009d8000)
	libc.so.6 => /lib/libc.so.6 (0x00594000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00928000)
	/lib/ld-linux.so.2 (0x4d435000)
...end sample ldd details ...
0x4ed142cc: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x202cc
0x4ed14b01: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x20b01
0xb7f18420:  + 0x420 (__kernel_sigreturn + 0x0)
0x4e26e67e: /usr/lib/libfontconfig.so.1 + 0x1467e (FcFontSetMatch + 0xfe)
0x4eb1f484: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x35484
0x4eb1f171: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x35171
(psp::PrintFontManager::Substitute(_STL::vector<String, _STL::allocator<String>
> const&, _STL::vector<unsigned short, _STL::allocator<unsigned short> >&,
ByteString const&, psp::italic::type, psp::weight::type, psp::width::type,
psp::pitch::type) const + 0x19f)
0x4f2a94a5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1064a5
0x4f2aec3a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10bc3a
0x4f2af044: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10c044
0x4f2af535: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10c535
0x4f2b0551: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10d551
(OutputDevice::GetTextArray(String const&, long*, unsigned short, unsigned
short) const + 0x6f)
0x425f3b6e: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x31bb6e
0x425fccb8: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x324cb8
0x425b6944: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2de944
0x425b882e: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2e082e
0x425d6c23: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2fec23
0x425d6836: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2fe836
0x425c6202: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2ee202
0x425b6517: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2de517
0x425889a1: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b09a1
0x425889a1: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b09a1
0x4258922d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b122d
0x424a527b: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1cd27b
(ViewShell::ImplEndAction(unsigned char) + 0x5af)
0x42481185: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1a9185
0x424895d4: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1b15d4
(SwCrsrShell::EndAction(unsigned char) + 0x7a)
0x42480e6e: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1a8e6e
(SwEditShell::EndAllAction() + 0x30)
0x42477d64: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x19fd64
(SwEditShell::SetExtTextInputData(CommandExtTextInputData const&) + 0xdc)
0x428e0745: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x608745
0x4f3924d0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1ef4d0
0x4f3927a3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1ef7a3
0x4f395354: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1f2354
0x6085da: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x315da
0x608497: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x31497
0x4e172259: /lib/libgobject-2.0.so.0 + 0x16259 (g_cclosure_marshal_VOID__VOID +
0x49)
0x4e164f0b: /lib/libgobject-2.0.so.0 + 0x8f0b (g_closure_invoke + 0x12b)
0x4e175e83: /lib/libgobject-2.0.so.0 + 0x19e83
0x4e17737f: /lib/libgobject-2.0.so.0 + 0x1b37f (g_signal_emit_valist + 0x89f)
0x4e178dbe: /lib/libgobject-2.0.so.0 + 0x1cdbe (g_signal_emit_by_name + 0xee)
0x4e58cfe7: /usr/lib/libgtk-x11-2.0.so.0 + 0x110fe7
0x4e172259: /lib/libgobject-2.0.so.0 + 0x16259 (g_cclosure_marshal_VOID__VOID +
0x49)
0x4e164f0b: /lib/libgobject-2.0.so.0 + 0x8f0b (g_closure_invoke + 0x12b)
0x4e175e83: /lib/libgobject-2.0.so.0 + 0x19e83
0x4e17737f: /lib/libgobject-2.0.so.0 + 0x1b37f (g_signal_emit_valist + 0x89f)
0x4e178dbe: /lib/libgobject-2.0.so.0 + 0x1cdbe (g_signal_emit_by_name + 0xee)
0x92e24d: /usr/lib/gtk-2.0/immodules/im-scim.so + 0x1024d
0x938210: /usr/lib/gtk-2.0/immodules/im-scim.so + 0x1a210
(scim::FunctionSlot3<void, scim::IMEngineInstanceBase*,
std::basic_string<wchar_t, std::char_traits<wchar_t>, std::allocator<wchar_t> >
const&, std::vector<scim::Attribute, std::allocator<scim::Attribute> >
const&>::call(scim::IMEngineInstanceBase*, std::basic_string<wchar_t,
std::char_traits<wchar_t>, std::allocator<wchar_t> > const&,
std::vector<scim::Attribute, std::allocator<scim::Attribute> > const&) const + 0x20)
0x15c5f7a: /usr/lib/libscim-1.0.so.8 + 0x62f7a
(scim::IMEngineInstanceBase::update_preedit_string(std::basic_string<wchar_t,
std::char_traits<wchar_t>, std::allocator<wchar_t> > const&,
std::vector<scim::Attribute, std::allocator<scim::Attribute> > const&) + 0x7a)
0xa3d6fe: /usr/lib/scim-1.0/1.4.0/IMEngine/socket.so + 0xa6fe
0xa3eda6: /usr/lib/scim-1.0/1.4.0/IMEngine/socket.so + 0xbda6
0xa3fd53: /usr/lib/scim-1.0/1.4.0/IMEngine/socket.so + 0xcd53
0x9344ed: /usr/lib/gtk-2.0/immodules/im-scim.so + 0x164ed
0x4e5a7897: /usr/lib/libgtk-x11-2.0.so.0 + 0x12b897 (gtk_main_do_event + 0x387)
0x4e8621da: /usr/lib/libgdk-x11-2.0.so.0 + 0x411da
0x4e0e7342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x4e0ea31f: /lib/libglib-2.0.so.0 + 0x2e31f
0x4e0ea885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x5ea213: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13213
0x440a9e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45a9e
(X11SalInstance::Yield(bool, bool) + 0x2c)
0x4f237473: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94473
(Application::Yield(bool) + 0x53)
0x4f237508: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94508
(Application::Execute() + 0x28)
0x41ff1186: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24186
(desktop::Desktop::Main() + 0x164e)
0x4f23b2de: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x982de
0x4f23b3d3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x983d3
(SVMain() + 0x2b)
0x41fead09: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd09 (sal_main
+ 0x5d)
0x41fead55: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd55 (main + 0x27)
0x4de19f2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4a1
Comment 1 Caolan McNamara 2006-09-18 14:01:52 EDT

*** This bug has been marked as a duplicate of 206845 ***

Note You need to log in before you can comment on or make changes to this bug.