Bug 206845 - Openoffice.org crash on FC6T3
Openoffice.org crash on FC6T3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 206848 207000 207070 207496 207561 207662 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-17 03:39 EDT by Mihai Harpau
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.0.4-4.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 08:05:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OO.org crash log (7.60 KB, text/plain)
2006-09-17 03:39 EDT, Mihai Harpau
no flags Details

  None (edit)
Description Mihai Harpau 2006-09-17 03:39:25 EDT
Description of problem:
OO.org crash when user want to display some settings

Version-Release number of selected component (if applicable):
[mihai@sysop ~]$ rpm -qa openoffice.org\*
openoffice.org-impress-2.0.4-3.1
openoffice.org-xsltfilter-2.0.4-3.1
openoffice.org-calc-2.0.4-3.1
openoffice.org-core-2.0.4-3.1
openoffice.org-writer-2.0.4-3.1
openoffice.org-graphicfilter-2.0.4-3.1
openoffice.org-draw-2.0.4-3.1
openoffice.org-math-2.0.4-3.1

How reproducible:


Steps to Reproduce:
1.click on Tools -> Options -> Language Settings -> Languages
2.
3.
  
Actual results:
crash

Expected results:
display specified setting

Additional info:
see this behavior on laptop HP Compaq nc6120
Comment 1 Mihai Harpau 2006-09-17 03:39:25 EDT
Created attachment 136467 [details]
OO.org crash log
Comment 2 Caolan McNamara 2006-09-18 04:39:52 EDT
*** Bug 206848 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2006-09-18 04:41:19 EDT
fontconfig related crashes, something has changed
Comment 4 Mihai Harpau 2006-09-18 09:27:44 EDT
indeed if I downgrade from fontconfig-2.4.0-1.fc6 (rawhide-20060915) to
fontconfig-2.3.95-11.fc6 (original FC6T3 DVD) OO.org won't crash anymore.
Comment 5 Caolan McNamara 2006-09-18 11:01:35 EDT
...

FcPattern* pResult = FcFontSetMatch( pConfig, &pFontSet, 1, pPattern, &eResult );

if( pResult )
{
        FcFontSet*  pSet = FcFontSetCreate();
        FcFontSetAdd( pSet, pResult );

        ...

        //Calling FcFontSetDestroy on pSet seems to unexpectedly 
        //corrupt/additionally elease patterns resources belonging
        //to pFontSet
        FcFontSetDestroy( pSet );
}
Comment 6 Caolan McNamara 2006-09-18 14:01:56 EDT
*** Bug 207000 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2006-09-19 03:30:27 EDT
Gotcha I think, fix checked in.
Comment 8 Caolan McNamara 2006-09-19 03:39:21 EDT
*** Bug 207070 has been marked as a duplicate of this bug. ***
Comment 9 William Murray 2006-09-21 07:18:58 EDT
I see much the same crash dump, but I wasn't obviously changing fonts.
Hopefully the fix will take effect...
Comment 10 Caolan McNamara 2006-09-21 09:19:34 EDT
*** Bug 207496 has been marked as a duplicate of this bug. ***
Comment 11 Caolan McNamara 2006-09-21 13:33:20 EDT
*** Bug 207561 has been marked as a duplicate of this bug. ***
Comment 12 Caolan McNamara 2006-09-22 08:28:04 EDT
*** Bug 207662 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.