Bug 207036 - ext3 recovery needed after reboot
ext3 recovery needed after reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 207117 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-18 17:04 EDT by ctm
Modified: 2014-03-16 23:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 12:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Portion of yum.log that lists updates between bad and good reboots (2.38 KB, text/plain)
2006-09-21 12:48 EDT, ctm
no flags Details

  None (edit)
Description ctm 2006-09-18 17:04:49 EDT
Description of problem:
After rebooting (via the command line "reboot" command or the Reboot button on the greeter), I get
kernel: EXT3-fs: INFO: recovery required on readonly filesystem.
sometimes I see orphan inodes deleted.

Version-Release number of selected component (if applicable):
initscripts-8.39-1
SysVinit-2.86-11
kernel-2.6.17-1.2647.fc6

How reproducible: 5 out of 5 reboots


Steps to Reproduce:
1. reboot
2. look for "INFO: recovery required"
3.
  
Actual results:
Error message present

Expected results:
No error message


Additional info:
I'm marking this as initscripts, but I really don't know where the problem is.  This is on completely new 
FC6t3 installation (i.e. I didn't upgrade or reuse pre-existing filesystems).
Comment 1 Bill Nottingham 2006-09-19 10:57:13 EDT
*** Bug 207117 has been marked as a duplicate of this bug. ***
Comment 2 Janne Pikkarainen 2006-09-19 12:19:08 EDT
So I'm not the only one having this problem.

One thing I just noticed is that during shutdown the system complains something
about unable to unmount LVM volume group. This does not happen every time, though.
Comment 3 ctm 2006-09-20 17:04:45 EDT
After upgrading to initscripts-8.41-1, I've rebooted my machine three times and no recovery has been 
needed.
Comment 4 Bill Nottingham 2006-09-21 11:54:10 EDT
That's... odd. Nothing of relevance changed in that area.
Comment 5 ctm 2006-09-21 12:16:49 EDT
Initscripts could be a red herring.

Typically I do yum update at least once a day, so much more than initscripts was updated, but the kernel 
wasn't nor was SysVinit.  I'll make the system reboot in a loop and see if I get any errors.  I'll report back 
either way, but if I don't get any errors, I'll attach a copy of my yum.log.

BTW, I removed orca, because I don't need it and it was interfering with my ability to update.  I doubt 
that's related, but I try to be complete.
Comment 6 ctm 2006-09-21 12:48:35 EDT
Created attachment 136881 [details]
Portion of yum.log that lists updates between bad and good reboots
Comment 7 ctm 2006-09-21 12:51:13 EDT
I've now done 10 reboots since my last round of yum updates.  None of them required ext3 recovery.  
Prior to that round of yum updates, 5 of the last 5 had recoveries.  Attached to comment #6 is the portion 
of yum.log that  lists those updates.

I can provide copies of my messages file or other logs if it will help.
Comment 8 Bill Nottingham 2006-10-10 12:13:28 EDT
Closing, then - I can't reproduce this either. Please reopen if it comes back.

Note You need to log in before you can comment on or make changes to this bug.