Bug 207117 - FC6 Test 3 fails to shutdown cleanly with IBM ThinkPad R51
FC6 Test 3 fails to shutdown cleanly with IBM ThinkPad R51
Status: CLOSED DUPLICATE of bug 207036
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 10:53 EDT by Janne Pikkarainen
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 10:57:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (52.98 KB, text/plain)
2006-09-19 10:53 EDT, Janne Pikkarainen
no flags Details

  None (edit)
Description Janne Pikkarainen 2006-09-19 10:53:31 EDT
Description of problem:

First of all, my apologies I haven't used Red Hat / Fedora in years. Anyway, I
decided to give Fedora Core 6 Test 3 a go and installed it in my laptop, which
is an IBM ThinkPad R51.

This is a very much stock install - I just clicked through the installation
process without changing default. After finishing the install I applied all the
updates pup offered me.

It seems that every single time something goes wrong during shutdown. During
every startup the boot sequence tells me

---
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: dm-0: orphan cleanup on readonly fs
ext3_orphan_cleanup: deleting unreferenced inode 8307245
ext3_orphan_cleanup: deleting unreferenced inode 8307252
EXT3-fs: dm-0: 2 orphan inodes deleted
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
---

... where the number and location of unreferenced inodes differ every time.

hdparm reports that drive write cache is on. Maybe FC6 shuts the system down so
fast that buffers doesn't get flushed to disk? :-) Anyway, this very same laptop
has worked fine in the past with CentOS 4.4, (K)Ubuntu Breezy 5.10 and (K)Ubuntu
Dapper 6.06, so this problem has something to do with FC6 and its init scripts /
 kernel / you decide.

Version-Release number of selected component (if applicable):

Fedora Core 6 Test 3 with all the current updates.

How reproducible:

Every time.

Steps to Reproduce:
1. Install FC6 Test 3 to IBM ThinkPad R51.
2. Shutdown and reboot.
3. See it complaining about dirty filesystem.
  
Actual results:


Expected results:


Additional info:
Comment 1 Janne Pikkarainen 2006-09-19 10:53:32 EDT
Created attachment 136645 [details]
dmesg output
Comment 2 Bill Nottingham 2006-09-19 10:57:10 EDT

*** This bug has been marked as a duplicate of 207036 ***

Note You need to log in before you can comment on or make changes to this bug.