Bug 207045 - grub gives Error 28: selected item cannot fit into memory
grub gives Error 28: selected item cannot fit into memory
Status: CLOSED DUPLICATE of bug 116311
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-09-18 18:50 EDT by Garrett Mitchener
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-26 16:46:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Garrett Mitchener 2006-09-18 18:50:30 EDT
I'm using a Dell Precision 690 workstation.  I finally managed to install grub
on the MBR of my first SCSI hard disk.  (It didn't install during the regular
fc6 test3 install -- see bug #207008.)  Now when I try to boot linux, it gives
me an error:

Error 28: selected item cannot fit into memory

I made a grub boot floppy with knoppix 5.0.1, and that *is* able to boot my
system: I used the grub-floppy command in knoppix, then booted from the
resulting floppy.  Then in grub:

configfile (hd1,0)/boot/grub.conf

and I select the linux kernel and it boots without error 28.
Comment 3 Greg Neely 2006-09-22 11:50:44 EDT
I have experienced the same issue with the the following hardware configuration. 
supermicro X7DBE+ Rev 2.01 with 4 GIGS of Ram DDR II Buffered. 
200Gig SATA Harddrive using on-board sata controller. Only 1 HD. 
Using 2 Dual Core Intel Xeon CPUs. I get the same exact issue. 

Tried going back to FC5 everything works except the NIC cards on the motherboard
are not recognized during the installation. However the OS will load and reboot
Comment 4 Garrett Mitchener 2006-09-25 12:45:51 EDT
I tried again with the new grub-0.97-12 and kernel-2.6.18-1.2689.fc6 packages,
and grub still fails with the same error message.  Grub from knoppix still works.

Also, I discovered today that in order to install grub from within linux (using
/sbin/grub), I had to add my second hard drive (/dev/sdb as (hd1)) to
/boot/grub/device.map manually.  Maybe anaconda didn't detect all the hard
drives correctly, which might be why grub didn't get installed initially.
Comment 5 Peter Jones 2006-09-26 16:46:38 EDT

*** This bug has been marked as a duplicate of 116311 ***

Note You need to log in before you can comment on or make changes to this bug.