Bug 116311 - Grub refuses to load initrd claiming it does not fit in memory.
Grub refuses to load initrd claiming it does not fit in memory.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
: Reopened
: 206876 207045 (view as bug list)
Depends On:
Blocks: FC6Blocker 207486
  Show dependency treegraph
 
Reported: 2004-02-19 17:54 EST by Aleksey Nogin
Modified: 2016-02-22 04:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 14:55:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-02-19 17:54:04 EST
THe recent versions of grub are no longer willing to load the initrd
from 2.6 kernels claiming they are too big to fit in memory! Of
course, this is pretty bogus - the grub image is about 650K
compresses, 8M uncompresses and the machine has 16GB or RAM. If I
repackage the image (the current image is only 21% full) into a 2MB
ext2, grub still complains. On the other hand, the 2.4.20-18.9 image
left from earlier days (and created using the tools in exiting Raw
Hide at that time) - 600KB compressed, 5MB uncompressed loads correctly.

Earlier versions of grub did not have this problem (OTOH because of
bug 112906 I was not able to run "install-grub" after grub upgrades
for quite a while, so I have no idea when it broke), even on the exact
same entries that it refuses to load today.
Comment 1 Jeremy Katz 2004-02-22 22:04:11 EST
Hmmm... I wasn't noticing this problem on my box when I was doing test
installs on Friday.  Will look further.
Comment 2 Bill Nottingham 2004-02-24 16:32:07 EST
Do you have >= 4GB of memory?
Comment 3 Aleksey Nogin 2004-02-24 16:34:22 EST
As I said, this machine has 16GB.
Comment 4 Bill Nottingham 2004-02-24 17:17:11 EST
Woops, I can't read today. Passing mem=4096M (or less) should work.
Comment 5 Bill Nottingham 2004-02-24 17:56:27 EST
In fact, mem=999999999M works, oddly enough.
Comment 7 Jeremy Katz 2004-02-25 14:46:31 EST
Worked around in grub-0.94-3.... I still think the kernel is being bogus.
Comment 8 Aleksey Nogin 2004-03-05 21:22:53 EST
Confirming, WFM with grub-0.94-3
Comment 9 David Lawrence 2006-09-20 12:32:35 EDT
Reopening. This bug is now occuring in latest trees of FC6-Test3 on x86_64 with
>4GB ram. Entering mem=<4G in the kernel cmdline args allows the machine to boot
properly.
Comment 10 Peter Jones 2006-09-21 14:33:43 EDT
Can you see if this still happens with grub-0.97-12 ?
Comment 11 Peter Jones 2006-09-26 16:47:02 EDT
*** Bug 207045 has been marked as a duplicate of this bug. ***
Comment 12 Peter Jones 2006-09-27 18:01:03 EDT
*** Bug 206876 has been marked as a duplicate of this bug. ***
Comment 13 Bojan Smojver 2006-09-28 21:13:51 EDT
Appears to work (0.97-12) on my HP dc-7600 with 2.5 GB or RAM. Previously, I had
to specify "uppermem 2000000" to get it going.
Comment 14 Garrett Mitchener 2006-09-29 10:35:23 EDT
After reading these comments, I added mem=4096M to the kernel command line in
grub.conf.  Now grub boots properly, no complaints about initrd. *shrug* (This
is on a dell precision 690 with 4GB of memory, x86_64, fc6 test 3, grub-0.97-12,
various kernels.)
Comment 15 Jeremy Katz 2006-10-02 14:55:01 EDT
This should be fixed back with 0.97-12 
Comment 16 Sami Farin 2006-12-06 05:52:07 EST
I have Intel DQ965GF motherboard (version CO96510J.86A.5493.2006.1102.1728)
and Pentium D CPU.

With 512 MB grub works (boots Linux kernel 2.6.19 and memtest.bin OK).
With 1024 MB grub does not work (boots Linux kernel 2.6.19 but with memtest.bin
I get "Error 28: Selected item cannot fit into memory.").

I made .iso which I boot from PATA CDRW, and my other disk is 160 GB PATA hd.
I haven't had floppy drive for 8 years, so I can't tell would grub work from a
floppy.

What do you have to say about the patch to memcheck() ?
http://savannah.gnu.org/bugs/?3404
Comment 17 Sami Farin 2006-12-06 05:53:08 EST
I have grub-0.97-13.

Note You need to log in before you can comment on or make changes to this bug.