Bug 207048 - restorecon segfaults on nonexistent file
Summary: restorecon segfaults on nonexistent file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils   
(Show other bugs)
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-18 23:04 UTC by Garrett Mitchener
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 14:09:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Garrett Mitchener 2006-09-18 23:04:13 UTC
Description of problem:

In another bug #207046, I found a segfault in a call to restorecon in
/etc/rc.d/rc.sysinit.  The problem seems to be that if you call restorecon with
a nonexistant file, it segfaults.  This ought to be handled more gracefully.

Version-Release number of selected component (if applicable):

policycoreutils-1.30.29-1

Comment 1 Daniel Walsh 2006-09-19 17:04:39 UTC
Fixed in policycoreutils-1.30.29-3

Comment 2 Matthew Miller 2007-04-06 18:11:54 UTC
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]



Note You need to log in before you can comment on or make changes to this bug.