Bug 207110 - [si_LK] sinhala input problem with 1st and 2nd modifiers - Priority A
[si_LK] sinhala input problem with 1st and 2nd modifiers - Priority A
Status: CLOSED DUPLICATE of bug 206261
Product: Fedora
Classification: Fedora
Component: scim-sinhala (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: Sinhala
  Show dependency treegraph
Reported: 2006-09-19 10:08 EDT by Satyabrata Maitra
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-28 07:20:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2006-09-19 10:08:58 EDT
Description of problem:
The 1st and 2nd modifier in sinhala does not appear in gedit properly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. open gedit
2. activate SCIM
3. select RAWCODE (if know the scim-sinhala key sequence for same combinations, 
   one can try with selecting sinhala layout in scim - result will be the same)
4. type the unicode combinations or unicodes or the key sequences(list will be 
   given soon in the comment)
5. observe the result

Actual results:
Shapes of the comjunct characters are not showing properly.

Expected results:
The shapes should be shown properly.

Additional info:
The list of unicodes and the Unicode combinations will be attached as file in
the comment as those are long list!!
Comment 1 Rahul Bhalerao 2006-09-26 19:05:17 EDT
What is the meaning of '1st modifier' and '2nd modifier'? I never used or
encountered these terms for any other Indic fonts/scripts. Could you please
provide the list of combinations as soon as possible.
Comment 2 Mayank Jain 2006-09-27 03:35:25 EDT
Hi Rahul,

I'm not very much into the fonts stuff or language internals, but according to
what I discussed with Tyronne yesterday...

1st modifiers...
type "ii" or "uu" or "oo" or "dH" with scim-sinhala

2nd modifiers
type "kRoo" with scim-sinhala

Hoping this helps...
Comment 3 Rahul Bhalerao 2006-09-27 11:29:39 EDT
All of the 1st modifier and 2nd modifier issues are related to scim-sinhala.
Font renders correctly with pango and rawcode. Scim-sinhala maps combination of
two different keys to one unicode characters. This function is not working on gnome.
It can be related to scim-bridge or any other mechanism within input method, but
not to the font or Pango.
Comment 4 Jens Petersen 2006-09-28 07:08:23 EDT
This also sounds similar to bug 206261.
Comment 5 Jens Petersen 2006-09-28 07:20:25 EDT

*** This bug has been marked as a duplicate of 206261 ***

Note You need to log in before you can comment on or make changes to this bug.