Bug 207112 - No XFS filesystem .ko or xfsutils in distro RFE
No XFS filesystem .ko or xfsutils in distro RFE
Status: CLOSED DUPLICATE of bug 205935
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 10:29 EDT by Berkley Shands
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 23:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Berkley Shands 2006-09-19 10:29:56 EDT
Description of problem:

Once again, XFS is not included in the standard distribution. Suse has an
Enterprise distro, they include XFS in theirs. All the Super Computer sites use
XFS. Why not RedHat? Centos provides XFS rpms.

Under 2.6.17 and 2.6.18 EXT3 yeilds ~680MB/Sec reading 4 hardware raid0 devices.
(in this case either hardware raid0 sata drives, or LSI SAS raid drives). Using
XFS I obtain 1.2GB/Sec from the identical hardware. This is 99% line rate.
I get at best 200MB/Sec write rates with EXT3, but 1.04GB/Sec with XFS. What
gives? Do I have to roll my own kernel and fustrate the security types who want
*ONLY* a standard redhat kernel, or just discard the FibreChannel connections
just to get a HUGE performance increase? We are in the business of HIGH
performance. I cannot justify spending $2,500 on a distro that will not provide
one kernel module and 2 support RPMS. XFS is standard in the linux distro.

I'm not asking for /root to be XFS, just data partitions.

Berkley Shands
Software Architect, R & D Manager for Exegy, Inc.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Needle 2006-09-20 11:40:05 EDT
Filed against rhel5-rc1, which doesn't exist.  Moving to rhel5-beta1.
Comment 2 Bill Nottingham 2006-09-21 23:02:35 EDT

*** This bug has been marked as a duplicate of 205935 ***

Note You need to log in before you can comment on or make changes to this bug.