Bug 20722 - how to force update installation with dirty filesystem
how to force update installation with dirty filesystem
Status: CLOSED DUPLICATE of bug 18305
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-12 09:44 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-15 11:18:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-12 09:44:12 EST
Afte a crash during an update - i could not install redhat 7.0
on my intel box. The installation stop - and force me to boot my
old system. Unfortuneatly I reclaim space on the root file system, as
a result the old installation is not usable. How could I fsck the
filesystem without using the old system ?
The anaconda script waste disk space after he found that not enough
disk space is available on the root file system. Multiple installations
waste diskspace due multiple copies of the rpm package in various 
anaconda subdirectories.

-> If the installation process stops due to insuffiecent disk space
on the root file system, the process should clean all temporary
wasted disk space.
-> Other solutions for the fsck a highly appreciated !
Comment 1 Michael Fulbright 2000-11-13 14:19:55 EST
What error do you get when you try to boot the old system?

At what point in the install did it fail?
Comment 2 Need Real Name 2000-11-13 20:35:22 EST
I reclaim space and delete the old kernal, so no booting of the old 
installation is possible - sorry.

The installation told me that I need additinal 3 MB for installation,
than you have no chance to abort. Your recycle again over the installation,
which tell you that you have not enough space..... Clever installation
script would give you a change to reclaim space ...not redhat.
Comment 3 Michael Fulbright 2000-11-15 11:18:13 EST
I believe this is a duplicate of bug 18305.

We are working on improving the estimates of free space requirements and it is
an ongoing process.  Thank you for contributing your suggestions on how we can
improve the installer.

You can use the rescue mode of the Red Hat Linux 7 CDROM to fsck the system.

Start with:

http://www.redhat.com/support/manuals/RHL-7-Manual/ref-guide/s1-sysadmin-rescue.html

for some help on how to do this.

*** This bug has been marked as a duplicate of 18305 ***

Note You need to log in before you can comment on or make changes to this bug.