Bug 207275 - [si_LK] All Repaya form of the conjuncts in sinhala with 200D is appearing wrongly - Priority - C
[si_LK] All Repaya form of the conjuncts in sinhala with 200D is appearing wr...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-sinhala (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
Depends On:
Blocks: FC6Target Sinhala 211958
  Show dependency treegraph
 
Reported: 2006-09-20 07:46 EDT by Satyabrata Maitra
Modified: 2008-08-02 19:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 01:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix all rephaya problems (11.35 KB, patch)
2006-09-28 05:34 EDT, Rahul Bhalerao
no flags Details | Diff
Tested Images for verification (200.42 KB, image/png)
2007-05-02 08:23 EDT, A S Alam
no flags Details
Tested Image2 for verification (75.20 KB, image/png)
2007-05-02 08:24 EDT, A S Alam
no flags Details

  None (edit)
Description Satyabrata Maitra 2006-09-20 07:46:30 EDT
Description of problem: this problem is quite confusing, so describing it
throughly. Repaya form of the conjuncts can be prosuced in two ways. 1st is with
200D (Zero width Non-Joiner) and 2nd is without 200D. The shape of any
combination for both the cases should be different.
Now for Both, with and without 200D, the shape appearing, is the same.
Now the 1st problem is the shape appearing now for both, should be for the
combination which is without 200D only.
And 2nd problem is there is not correct shape available with the combination
which is with 200D.

For Example :

Combination with 200D : 0D9A + 0DBB + 0DCA + 200D + 0D9A : Actually for this
type of combination, there is no proper shape available now. This is to be
implemented still.

Combination without 200D : 0D9A + 0DBB + 0DCA + 0D9A : The shape now showing, is
the proper shape for this type of combination which is without 200D.

Version-Release number of selected component (if applicable):
fonts-sinhala-0.2-4
pango-1.14.4-1.cf6
scim-sinhala-0.2.0-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Open gedit
2. Activate SCIM with CTRL+SPACE.
3. Select RAWCODE from the scim-table in Others
4. Type the unicode sequentially as given in the 1st comment but without 'U' and 
   '+'.
5. Observe the result.
  
Actual results:
Shapes are showing same for both the set of repaya form

Expected results:
Shape should different for each set of Repaya form.

Additional info:
The list of Combinations with and without 200D is given in the first comment as
its a big list!!
Comment 1 Satyabrata Maitra 2006-09-20 07:57:00 EDT
Unicode Combinations with 200D :

U+0D9A U+0DBB U+0DCA U+200D U+0D9A
U+0D9B U+0DBB U+0DCA U+200D U+0D9A
U+0D9C U+0DBB U+0DCA U+200D U+0D9A
U+0D9D U+0DBB U+0DCA U+200D U+0D9A
U+0D9E U+0DBB U+0DCA U+200D U+0D9A
U+0D9F U+0DBB U+0DCA U+200D U+0D9A
U+0DA0 U+0DBB U+0DCA U+200D U+0D9A
U+0DA1 U+0DBB U+0DCA U+200D U+0D9A
U+0DA2 U+0DBB U+0DCA U+200D U+0D9A
U+0DA3 U+0DBB U+0DCA U+200D U+0D9A
U+0DA4 U+0DBB U+0DCA U+200D U+0D9A
U+0DA5 U+0DBB U+0DCA U+200D U+0D9A
U+0DA6 U+0DBB U+0DCA U+200D U+0D9A
U+0DA7 U+0DBB U+0DCA U+200D U+0D9A
U+0DA8 U+0DBB U+0DCA U+200D U+0D9A
U+0DA9 U+0DBB U+0DCA U+200D U+0D9A
U+0DAA U+0DBB U+0DCA U+200D U+0D9A
U+0DAB U+0DBB U+0DCA U+200D U+0D9A
U+0DAC U+0DBB U+0DCA U+200D U+0D9A
U+0DAD U+0DBB U+0DCA U+200D U+0D9A
U+0DAE U+0DBB U+0DCA U+200D U+0D9A
U+0DAF U+0DBB U+0DCA U+200D U+0D9A
U+0DB0 U+0DBB U+0DCA U+200D U+0D9A
U+0DB1 U+0DBB U+0DCA U+200D U+0D9A
U+0DB3 U+0DBB U+0DCA U+200D U+0D9A
U+0DB4 U+0DBB U+0DCA U+200D U+0D9A
U+0DB5 U+0DBB U+0DCA U+200D U+0D9A
U+0DB6 U+0DBB U+0DCA U+200D U+0D9A
U+0DB7 U+0DBB U+0DCA U+200D U+0D9A
U+0DB8 U+0DBB U+0DCA U+200D U+0D9A
U+0DB9 U+0DBB U+0DCA U+200D U+0D9A
U+0DBA U+0DBB U+0DCA U+200D U+0D9A
U+0DBB U+0DBB U+0DCA U+200D U+0D9A
U+0DBD U+0DBB U+0DCA U+200D U+0D9A
U+0DC0 U+0DBB U+0DCA U+200D U+0D9A
U+0DC1 U+0DBB U+0DCA U+200D U+0D9A
U+0DC2 U+0DBB U+0DCA U+200D U+0D9A
U+0DC3 U+0DBB U+0DCA U+200D U+0D9A
U+0DC4 U+0DBB U+0DCA U+200D U+0D9A
U+0DC5 U+0DBB U+0DCA U+200D U+0D9A
U+0DC6 U+0DBB U+0DCA U+200D U+0D9A
U+0D9A U+0DBB U+0DCA U+200D U+0DBA U+0DCA U+200D U+0DBA

Unicode Combinations without 200D :

U+0D9A U+0DBB U+0DCA U+0D9A
U+0D9B U+0DBB U+0DCA U+0D9A
U+0D9C U+0DBB U+0DCA U+0D9A
U+0D9D U+0DBB U+0DCA U+0D9A
U+0D9E U+0DBB U+0DCA U+0D9A
U+0D9F U+0DBB U+0DCA U+0D9A
U+0DA0 U+0DBB U+0DCA U+0D9A
U+0DA1 U+0DBB U+0DCA U+0D9A
U+0DA2 U+0DBB U+0DCA U+0D9A
U+0DA3 U+0DBB U+0DCA U+0D9A
U+0DA4 U+0DBB U+0DCA U+0D9A
U+0DA5 U+0DBB U+0DCA U+0D9A
U+0DA6 U+0DBB U+0DCA U+0D9A
U+0DA7 U+0DBB U+0DCA U+0D9A
U+0DA8 U+0DBB U+0DCA U+0D9A
U+0DA9 U+0DBB U+0DCA U+0D9A
U+0DAA U+0DBB U+0DCA U+0D9A
U+0DAB U+0DBB U+0DCA U+0D9A
U+0DAC U+0DBB U+0DCA U+0D9A
U+0DAD U+0DBB U+0DCA U+0D9A
U+0DAE U+0DBB U+0DCA U+0D9A
U+0DAF U+0DBB U+0DCA U+0D9A
U+0DB0 U+0DBB U+0DCA U+0D9A
U+0DB1 U+0DBB U+0DCA U+0D9A
U+0DB3 U+0DBB U+0DCA U+0D9A
U+0DB4 U+0DBB U+0DCA U+0D9A
U+0DB5 U+0DBB U+0DCA U+0D9A
U+0DB6 U+0DBB U+0DCA U+0D9A
U+0DB7 U+0DBB U+0DCA U+0D9A
U+0DB8 U+0DBB U+0DCA U+0D9A
U+0DB9 U+0DBB U+0DCA U+0D9A
U+0DBA U+0DBB U+0DCA U+0D9A
U+0DBB U+0DBB U+0DCA U+0D9A
U+0DBD U+0DBB U+0DCA U+0D9A
U+0DC0 U+0DBB U+0DCA U+0D9A
U+0DC1 U+0DBB U+0DCA U+0D9A
U+0DC2 U+0DBB U+0DCA U+0D9A
U+0DC3 U+0DBB U+0DCA U+0D9A
U+0DC4 U+0DBB U+0DCA U+0D9A
U+0DC5 U+0DBB U+0DCA U+0D9A
U+0DC6 U+0DBB U+0DCA U+0D9A
U+0D9A U+0DBB U+0DCA U+0DBA U+0DCA U+0DBA
Comment 2 Rahul Bhalerao 2006-09-26 19:01:45 EDT
1. The entire bug can be summerized as:

Combination of:
     consonant + u0DCA + u0D9A 
does not produce the repaya form.

2. The bug description says, 
      consonant + u0DCA + u0D9A
    should not produce any substitution and
     
      consonant + u0DCA + u200D + u0D9A should produce substitution.

This description is logically wrong since it demands use of
Zero-Width-Non-Joiner(u200D) for combining two consonants and a straight
combination to be desplayed without any substitution. Though its technically
possible, it can not be recommanded.

I will need to study this issue in detail and verify the implementations in the
font for other similar cases.
Comment 3 Rahul Bhalerao 2006-09-26 19:33:01 EDT
CORRRECTION:
In previous comment, the combinations are:

1. u0DBB + u0DCA + consonant (and not consonant + u0DCA + u0D9A )
2. u0DBB + u0DCA + u200D + consonant (and not consonant + u0DCA + u200d + u0D9A )
Comment 4 Rahul Bhalerao 2006-09-27 03:35:00 EDT
The character u0DBB gets a post-base *reph* form. In pango its class bit is
currently '_ct', it should be '_rv' similar to u0930 of devanagari.
Comment 5 Rahul Bhalerao 2006-09-27 03:35:46 EDT
The character u0DBB gets a above-base *reph* form. In pango its class bit is
currently '_ct', it should be '_rv' similar to u0930 of devanagari.
Comment 6 Rahul Bhalerao 2006-09-27 03:37:03 EDT
The Comment #5 is correction to Comment #4.
Comment 7 Rahul Bhalerao 2006-09-27 14:14:57 EDT
According to the standards accepted by govt. agencies in Srilanka, the rephaya
form should be displayed as a combination of 

0DBB + 0DCA + 200D + Consonant

Though it technically adds lot of redendancy work in font development, this
standard is accepted by most of the Sinhala fonts. Also its not very convincing
to use rephaya(reph) forms in this way while all other Indic scripts have a
general standard for it. Though this is what Sinhala community has been using
for developing i18n tools. Changing it all would be lot difficult.

I found the glyphs for most rephaya forms present in the font but they are
missing the ligature rules. Thus this bug can be solved in font, no modification
needed in Pango.
Comment 8 Rahul Bhalerao 2006-09-28 05:34:10 EDT
Created attachment 137294 [details]
Patch to fix all rephaya problems

Font was missing GSUB rules for the rephaya forms. I have added these rules.
Comment 9 Leon Ho 2006-09-28 07:04:45 EDT
Thanks Rahul. Built into fonts-sinhala-0.2.1-1
Comment 10 A S Alam 2007-05-02 08:23:12 EDT
Created attachment 153939 [details]
Tested Images for verification
Comment 11 A S Alam 2007-05-02 08:24:07 EDT
Created attachment 153941 [details]
Tested Image2 for verification
Comment 12 A S Alam 2007-05-02 08:37:53 EDT
snavin,
can you please check above combination whether those are correct or not?
Comment 13 Danishka Navin 2007-05-03 07:20:14 EDT
A S Alam,
I have checked above combination, those are correct.
Comment 14 Jens Petersen 2007-10-23 03:09:59 EDT
So this is fixed now?
Comment 15 A S Alam 2007-11-16 01:06:07 EST
based on comment #13, it is marked fixed, if found further issue, please reopen
issue,
thanks

Note You need to log in before you can comment on or make changes to this bug.