Bug 20728 - Anaconda crash even with the update RHBA-2000:084-04 (ftp://updates.redhat.com/7.0/images/i386/update-disk-20001009.img)
Summary: Anaconda crash even with the update RHBA-2000:084-04 (ftp://updates.redhat.co...
Status: CLOSED DUPLICATE of bug 17928
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-12 19:14 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-13 19:15:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-12 19:14:53 UTC
After the RPMs are installed 
Anaconda crashes and dump:
*****************************
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/tmp/updates/todo.py", line 1651, in doInstall
    self.writeConfiguration ()
  File "/tmp/updates/todo.py", line 1402, in writeConfiguration
    self.writeRootPassword ()
  File "/tmp/updates/todo.py", line 660, in writeRootPassword
    self.setPassword("root", pure)
  File "/tmp/updates/todo.py", line 1151, in setPassword
    stdin = p[0], stdout = devnull)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 40, in 
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/bin/passwd can not be run

Local variables in innermost frame:
argv: ['/usr/bin/passwd', '--stdin', 'root']
root: /mnt/sysimage
stdin: 16
newPgrp: 0
stdout: 15
stderr: 2
command: /usr/bin/passwd
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2000-11-13 19:15:30 UTC

*** This bug has been marked as a duplicate of 17928 ***


Note You need to log in before you can comment on or make changes to this bug.