Bug 207322 - yum -y update results in error due to file conflict for bind (see below)
yum -y update results in error due to file conflict for bind (see below)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
:
: 186367 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 13:12 EDT by Chuck Adams
Modified: 2014-01-21 17:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 06:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chuck Adams 2006-09-20 13:12:08 EDT
Description of problem: yum -y update  gives error


Transaction Check Error:   file /etc/named.conf from install of
bind-9.3.2-33.fc5 conflicts with file from package caching-nameserver-7.3-5.FC5

Version-Release number of selected component (if applicable):


How reproducible:
Use above command   yum -y update

Steps to Reproduce:
1.  su -
2.  yum -y update
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Stransky 2006-09-20 15:03:25 EDT
Hm, it's strange because /etc/named.conf should not be installed as a part of
bind/caching-nameserver...
Comment 2 Aleksander Adamowski 2006-09-21 04:36:05 EDT
Configming the problem. On a freshly installed FC5 (a Xen guest) for x86_64,
I-ve launched yum upgrade and got the error:

Transaction Check Error:   file /etc/named.conf from install of
bind-9.3.2-33.fc5 conflicts with file from package caching-nameserver-7.3-5.FC5
Comment 3 Martin Stransky 2006-09-21 08:45:57 EDT
okay, I'll fix it in a new update for FC5, we need to obsolete the
caching-nameserver-7.3-5.FC5
Comment 4 Darlene J. Ford 2006-09-21 23:39:02 EDT
Same problem occurs with pup upgrade from gnome desktop menu in FC5 on Athlon 64..
Comment 5 Martin Stransky 2006-10-26 03:33:33 EDT
*** Bug 186367 has been marked as a duplicate of this bug. ***
Comment 6 Martin Stransky 2006-10-26 06:16:22 EDT
patched in CVS, hopefully fixed in 9.3.3-0.2.rc2
Comment 7 Darlene J. Ford 2006-11-05 19:48:05 EST
Got error message when I tried to run pup today:

('file /etc/named.conf from install of bind-9.3.3-0.1.rc2.fc5 conflicts with
file from package caching-nameserver-7.3-5.FC5', (7, '/etc/named.conf', 0L))

This is somewhat confusing as caching-nameserver did not appear on the list of
packages to be updated...

Specific bind updates listed for my system:
bind - 30:9.3.3-0.1.rc2.fc5.x86_64 updates bind - 30:9.3.2-4.1.x86_64
bind-libs - 30:9.3.3-0.1.rc2.fc5.x86_64 updates bind-libs - 30:9.3.2-4.1.x86_64
bind-utils - 30:9.3.3-0.1.rc2.fc5.x86_64 updates bind-utils - 30:9.3.2-4.1.x86_64
Comment 8 Adam Tkac 2007-05-30 06:08:23 EDT
Looks like fixed. If still exists, please reopen.

Regards, Adam

Note You need to log in before you can comment on or make changes to this bug.