Bug 186367 - bind and caching-nameserver packages conflicts on /etc/named.conf file
Summary: bind and caching-nameserver packages conflicts on /etc/named.conf file
Status: CLOSED DUPLICATE of bug 207322
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Reopened
: 187729 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-23 07:46 UTC by Kir Kolyshkin
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 07:31:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kir Kolyshkin 2006-03-23 07:46:55 UTC
Description of problem:

bash-3.1# rpm -q bind
bind-9.3.2-12.FC5
bash-3.1# rpm -i caching-nameserver-7.3-5.FC5.noarch.rpm
        file /etc/named.conf from install of caching-nameserver-7.3-5.FC5
conflicts with file from package bind-9.3.2-12.FC5


Version-Release number of selected component (if applicable):

bind-9.3.2-12.FC5
caching-nameserver-7.3-5.FC5.noarch.rpm
rpm-4.4.2-15.2

How reproducible:
Always

Steps to Reproduce:
1. install bind
2. try to install caching-nameserver
  
Actual results:
Inability to install caching-nameserver due to a file conflict

Expected results:
caching-nameserver succesfully installed

Additional info:
bind is from fc5 updates

Comment 1 Jason Vas Dias 2006-03-23 15:27:25 UTC
The caching-nameserver RPM is now obsoleted by the bind-config package,
which 'Provides: caching-nameserver'. 

If you obtained bind-9.3.2-12.FC5 via a 'yum update' command, then 
caching-nameserver would be correctly 'obsoleted' by bind-config.

You do not need to install caching-nameserver if you have bind-config installed.
 

Comment 2 Ignacio Vazquez-Abrams 2006-04-03 10:03:58 UTC
*** Bug 187729 has been marked as a duplicate of this bug. ***

Comment 3 Denis Leroy 2006-10-04 14:56:05 UTC
I'm still seeing this problem. Essentally the update path from a vanilla FC-5 to
the current FC-5 updates in Core, Updates and Extras.

On a vanilla system: 

# rpm -q bind
bind-9.3.2-4.1
# rpm -q caching-nameserver
caching-nameserver-7.3-5.FC5
# rpm -qf /etc/named.conf 
caching-nameserver-7.3-5.FC5

Trying to update:
# yum -y update
[...]
bind                    x86_64     30:9.3.2-33.fc5  updates           941 k
[...]
Transaction Check Error:   file /etc/named.conf from install of
bind-9.3.2-33.fc5 conflicts with file from package caching-nameserver-7.3-5.FC5

The problem is that bind-config is not part of the vanilla install, and
therefore doesn't get a chance to Obsolete caching-nameserver. I'm guessing the
answer is having bind Requires: bind-config ?


Comment 4 Martin Stransky 2006-10-26 07:31:46 UTC

*** This bug has been marked as a duplicate of 207322 ***


Note You need to log in before you can comment on or make changes to this bug.