Bug 20740 - create Cdrom os.symlink during install failed
create Cdrom os.symlink during install failed
Status: CLOSED DUPLICATE of bug 16214
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-12 22:36 EST by Tim
Modified: 2007-03-26 23:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-17 14:28:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim 2000-11-12 22:36:28 EST
Second time this happened.  This time used anaconda 1009update disk which 
made no difference.

Installation was FTP, using bootnet.img.  Used "linux updates text" start 
option.  System: PPro 200 with 56MB RAM and 2.5GB IDE; IDE CDROM attached 
to second IDE controller built into motherboard.

Here's the dump info:


Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
  File "/tmp/updates/todo.py", line 1638, in doInstall
    self.createCdrom()
  File "/tmp/updates/todo.py", line 1189, in createCdrom
    os.symlink(device, self.instPath + "/dev/" + cdname)
OSError: [Errno 28] No space left on device

Local variables in innermost frame:
device: hdc
list: ['hdc']
self: <todo.ToDo instance at 82a1dc8>
cdname: cdrom
count: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://ftp-
linux.cc.gatech.edu/pub/linux/distributions/redhat/current/i386/en'
sbsS'initlevel'
p7
I3
sS'skipLilo'
p8
I0
sS'progressWindow'
p9
(itext
ProgressWindow
(dp10
S'scale'
p11
(isnack
Scale
(dp12
S'w'

<failed>
Comment 1 Michael Fulbright 2000-11-13 12:05:46 EST
This is a dupe of bug 18403.

Before I close it as a dupe, could you include information on how you
partitioned your system, included the sizes of the different mount points?

Also any other information you could include to help us reproduce this problem
would be wonderful.
Comment 2 Tim 2000-11-13 22:27:54 EST
Ok - all numbers in MB

51   /
51   /boot
200  /tmp
62   swap
1082 /usr
303  /home
500  /opt
86   /export/home
102  /var


The error happens at the end of the package installation process - at the very 
end, the installation of 4 or so packages appear to fail, as they appear 
briefly on the screen without a red progress bar; the error appears immediately 
afterward.  At least three of the packages that appear to fail are: dhcp, squid 
and tripwire.

Network card is a 3c905 - installed static ip (no dhcp/no bootp)
PPro 180chip overclocked to 200Mhz
DTK Motherboard
56MB RAM - all 6 simm slots filled:16MB*2, 8MB*2, 4MB*2
2.5 GB Western Digital AH32500 IDE
52x max delta (cheap) ide cdrom on secondary ide controller
Video:S3 Trio 64V2, 4MB


Installation steps:
1 use "linux updates text" install option (use anaconda 1009 update disk)
2 English language
3 US keyboard
4 Custom System 
5 Use Disk Druid to partition disk. Label existing partitions (or delete them 
all and recreate them, it doesn't seem to matter - however note that the drive 
has partitions to start with)
6 Format all
7 Lilo config - leave linear mode enabled
8 install lilo /dev/hda (MBR)
9 Lilo config - hit ok
10 enter hostname
11 network config - configure static ip address (no bootp/dhcp)
12 2 button PS/2 mouse, emulate 3 buttons
13 America/NY time zone
14 Select root pw; then add one user account
15 Leave Shadow and MD5 passwords enabled
16 Select the following package groups along with select individual packages:
Printer Support
X Window Sys
KDE
Networked Workstation
SMB Server
Web Server
Network Management Workstation
Kernel Development
17 Add/remove the following:
Add Amusements/Graphics kdetoys
Remove App/Archiving rmt
Rem App/Archiving sharutils
Rem App/Communications pilot-link
Rem App/Internet ncftp
Add App/Internet rsync
Rem App/Internet talk
Add App/System iproute, kdeadmin
Rem App/System modemtool, mt-st
Add App/System tripwire
Rem Devt/Libraries pilot-link-devel
Add Sys Env/Daemons dhcp, ppp, rp-pppoe
Rem Sys Env/Daemons rsh-server, rusers, rusers-server, rwall-server, rwho
Add Sys Env/Daemons squid
Rem Sys Env/Daemons talk-server, telnet-server, tftp-server
Add Sys Env/Daemons wu-ftpd
Add Sys Env/Shells mc


Any idea for a workaround?

Thanks,

Tim R.
Comment 3 Michael Fulbright 2000-11-15 11:08:51 EST
Thank you very much for the complete bug report.  I've seen many reports of this
problem, but none had enough information to duplicate. I am hopeful which your
help we can get to the bottom of this issue.

My guess is if you made your / partition bigger (like 100M to be sure) it would
work. Could you try that and let us know if it helps?

I think you've uncovered a case which has turned up before because you made your
'/' partition smaller than most people do (which is not bad, btw).  It appears
for some reason our check that you have enough space before starting the install
is not adequare in this case.

Assigned to a QA engineer to reproduce locally.
Comment 4 Brock Organ 2000-11-15 15:40:24 EST
Tim, thanks for the detailed (and excellent! :)) test steps above ... using
them, we are able to reproduce the problem locally ... :)
Comment 5 Michael Fulbright 2000-11-15 15:49:59 EST
Ok you ran out of inodes.

This is related to bug 16214.
Comment 6 Tim 2000-11-15 22:06:55 EST
Thanks, however I get a "permission denied" message when I try to access bug 
16214.  Is the workaround to have fewer mount points? Larger root partition? 
Both or neither?

Thanks again,

Tim R.
Comment 7 Michael Fulbright 2000-11-17 14:27:57 EST
Hi,

 Sorry I fixed the other bug so you could see it.

The fix is to make '/' larger.  I think you really don't need so many partitions
unless you have a special requirement. Most people use a '/', swap, and a
'/home' for desktop use.



*** This bug has been marked as a duplicate of 16214 ***

Note You need to log in before you can comment on or make changes to this bug.