Bug 16214 - RFE:Available inodes are not apparently being checked for.
RFE:Available inodes are not apparently being checked for.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
RFE
: FutureFeature
: 17935 20740 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-14 23:03 EDT by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 23:11:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2000-08-14 23:03:04 EDT
I ran out of inodes on the root partition upgrading beta5 to RC1, resulting
in a hopelessly confused system that will have to be rebuilt.  Apparently I
had enough disk space for the installer to start, but not enough inodes.

Now, it seems to me that it's much easier to calculate the required inode
usage than the required disk space usage, so I think that this should be
checked for.

I think the installer needs to check how many new files will be installed,
and ensure that enough inodes are available.
Comment 1 Michael Fulbright 2000-08-16 13:12:13 EDT
Added to feature request list.
Comment 2 Michael Fulbright 2000-09-26 12:09:46 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 3 Michael Fulbright 2000-09-26 12:55:28 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 4 Michael Fulbright 2000-10-02 18:45:23 EDT
*** Bug 17935 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2000-11-17 14:27:54 EST
*** Bug 20740 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2000-11-17 14:36:00 EST
We are going to enforce a minimum size for '/' which will workaround this
problem in most cases. We realize we need a better long term solution.
Comment 7 Michael Fulbright 2000-12-19 16:47:33 EST
Implemnted minimum size of '/' check (see bug 21029).
Comment 8 Michael Fulbright 2001-02-13 23:10:50 EST
RPM checks for this now.
Comment 9 Brock Organ 2001-02-19 10:54:42 EST
verified fix in qa0217.1 ...

Note You need to log in before you can comment on or make changes to this bug.