Bug 207448 - Installer expects a ipv6 address as a must, when using the static ip address
Installer expects a ipv6 address as a must, when using the static ip address
Status: CLOSED DUPLICATE of bug 206148
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-09-21 02:40 EDT by Naresh
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-21 10:46:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 206588 None None None Never

  None (edit)
Description Naresh 2006-09-21 02:40:05 EDT
Description of problem:

Anaconda is expecting both IPV4 and IPV6 addresses irrespective of the check box

Even if i disable the IPV6 checkbox and tried to proceed with the static IPV4
address, its asking me to enter the static IPV6 address.

I think the connection between the 'check box' and the 'text box which takes
input' has to be checked in the code.

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1. Start the Installation of Fedora Core 6 Test 3
2. In the Networking section, use the Static IP Address mechanism
3. Uncheck the IPV6 check-box.
4. Click on next after you are done with IPV4 address / mask.
5. Installer raises a popup asking to enter the IPV6 address, even if the 'text
fields' for IPV6 are disabled.
Actual results:

Installer is not allowing me to proceed without the static IPV6 address

Expected results:

Installer should take only IPV4 address, if the IPV4 address is checked.
Take only IPV6 address, if IPV6 address is checked.

If none are checked. Raise a popup asking to user to skip the networking section.

Additional info:

Related Bug : #206588 , I tried to enter some garbage for IPV6 address and the
installer aborted with a backtrace. The above bug has more details.
Comment 1 David Cantrell 2006-09-21 10:46:46 EDT

*** This bug has been marked as a duplicate of 206148 ***

Note You need to log in before you can comment on or make changes to this bug.