Bug 207496 - OOo crashes when seeing Languages option
OOo crashes when seeing Languages option
Status: CLOSED DUPLICATE of bug 206845
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 09:14 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 09:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2006-09-21 09:14:07 EDT
Description of problem:
After opening an option dialog from the menu Tools->Options on oowriter, when I
click the Languages item in Language Settings, it causes segfault.

Version-Release number of selected component (if applicable):
openoffice.org-langpack-zh_TW-2.0.4-3.1
openoffice.org-langpack-ko_KR-2.0.4-3.1
openoffice.org-langpack-cs_CZ-2.0.4-3.1
openoffice.org-langpack-ta_IN-2.0.4-3.1
openoffice.org-langpack-ga_IE-2.0.4-3.1
openoffice.org-langpack-el_GR-2.0.4-3.1
openoffice.org-langpack-es-2.0.4-3.1
openoffice.org-langpack-ru-2.0.4-3.1
openoffice.org-langpack-ja_JP-2.0.4-3.1
openoffice.org-langpack-sk_SK-2.0.4-3.1
openoffice.org-impress-2.0.4-3.1
openoffice.org-writer-2.0.4-3.1
openoffice.org-langpack-da_DK-2.0.4-3.1
openoffice.org-langpack-gu_IN-2.0.4-3.1
openoffice.org-langpack-hi_IN-2.0.4-3.1
openoffice.org-graphicfilter-2.0.4-3.1
openoffice.org-langpack-pa_IN-2.0.4-3.1
openoffice.org-langpack-af_ZA-2.0.4-3.1
openoffice.org-langpack-sr_CS-2.0.4-3.1
openoffice.org-langpack-ms_MY-2.0.4-3.1
openoffice.org-math-2.0.4-3.1
openoffice.org-langpack-sl_SI-2.0.4-3.1
openoffice.org-xsltfilter-2.0.4-3.1
openoffice.org-langpack-it-2.0.4-3.1
openoffice.org-langpack-hr_HR-2.0.4-3.1
openoffice.org-calc-2.0.4-3.1
openoffice.org-langpack-ca_ES-2.0.4-3.1
openoffice.org-langpack-lt_LT-2.0.4-3.1
openoffice.org-langpack-fr-2.0.4-3.1
openoffice.org-langpack-he_IL-2.0.4-3.1
openoffice.org-langpack-zh_CN-2.0.4-3.1
openoffice.org-langpack-bn-2.0.4-3.1
openoffice.org-langpack-nl-2.0.4-3.1
openoffice.org-langpack-cy_GB-2.0.4-3.1
openoffice.org-draw-2.0.4-3.1
openoffice.org-langpack-pt_PT-2.0.4-3.1
openoffice.org-langpack-bg_BG-2.0.4-3.1
openoffice.org-langpack-th_TH-2.0.4-3.1
openoffice.org-core-2.0.4-3.1
openoffice.org-langpack-nn_NO-2.0.4-3.1
openoffice.org-langpack-pl_PL-2.0.4-3.1
openoffice.org-langpack-ar-2.0.4-3.1
openoffice.org-langpack-eu_ES-2.0.4-3.1
openoffice.org-langpack-et_EE-2.0.4-3.1
openoffice.org-langpack-fi_FI-2.0.4-3.1
openoffice.org-langpack-de-2.0.4-3.1
openoffice.org-langpack-pt_BR-2.0.4-3.1
openoffice.org-langpack-sv-2.0.4-3.1
openoffice.org-langpack-hu_HU-2.0.4-3.1
openoffice.org-langpack-gl_ES-2.0.4-3.1
openoffice.org-langpack-nb_NO-2.0.4-3.1

How reproducible:
always

Steps to Reproduce:
1.run oowriter
2.choose Options from the menu Tools
3.choose Languages in Language Settings
  
Actual results:
segfault

Expected results:
should displays Languages page

Additional info:
this happens regardless of current locale. I can reproduce this with even LANG=C.

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/nv_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-23-i386
(V)    kernel is: Linux 2.6.17-1.2647.fc6PAE #1 SMP Wed Sep 13 13:09:07 EDT 2006
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-3.1-i386
(VII)  accessibility is: false
(VIII) fedora release is: Fedora Core release 5.92 (FC6 Test3)
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          permissive
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0xb7fdb000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x00111000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x002cb000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x0051a000)
	libdl.so.2 => /lib/libdl.so.2 (0x002cf000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x0061c000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x00d9c000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x002d3000)
	libm.so.6 => /lib/libm.so.6 (0x00774000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x009e9000)
	libc.so.6 => /lib/libc.so.6 (0x003c1000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00e89000)
	/lib/ld-linux.so.2 (0x006d0000)
...end sample ldd details ...
0x539e2cc: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x202cc
0x539eb01: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x20b01
0xb7f3c420:  + 0x420 (__kernel_sigreturn + 0x0)
0x80764e: /usr/lib/libfontconfig.so.1 + 0x1464e (FcFontSetMatch + 0xfe)
0x566a484: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x35484
0x566a171: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x35171
(psp::PrintFontManager::Substitute(_STL::vector<String, _STL::allocator<String>
> const&, _STL::vector<unsigned short, _STL::allocator<unsigned short> >&,
ByteString const&, psp::italic::type, psp::weight::type, psp::width::type,
psp::pitch::type) const + 0x19f)
0x5bde4a5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1064a5
0x5be3c3a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10bc3a
0x5be4044: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10c044
0x5be4535: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10c535
0x5be5551: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10d551
(OutputDevice::GetTextArray(String const&, long*, unsigned short, unsigned
short) const + 0x6f)
0x5be5636: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10d636
(OutputDevice::GetTextWidth(String const&, unsigned short, unsigned short) const
+ 0x26)
0x5cf83ae: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x2203ae
0x5cf94d3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x2214d3
0x5cf9604: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x221604
0x5d01866: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x229866
(ListBox::InsertEntry(String const&, unsigned short) + 0x34)
0x288dc56: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x7ac56
0x288e048: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x7b048
0x289bd57: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x88d57
0x289cd7b: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x89d7b
0x289d6d0: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x8a6d0
0x5b63e50: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8be50
0x5b708ec: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x988ec
(Timer::Timeout() + 0x1c)
0x5b70a2a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x98a2a
(Timer::ImplTimerCallbackProc() + 0x78)
0x65f473: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3e473
0x65f2ac: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3e2ac
(X11SalData::Timeout() const + 0x24)
0x57d527: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13527
0x57d54b: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1354b
0x8d2916: /lib/libglib-2.0.so.0 + 0x2b916
0x8d2342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x8d531f: /lib/libglib-2.0.so.0 + 0x2e31f
0x8d5885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x57d213: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13213
0x666a9e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45a9e
(X11SalInstance::Yield(bool, bool) + 0x2c)
0x5b6c473: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94473
(Application::Yield(bool) + 0x53)
0x5c6dbf9: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x195bf9
(Dialog::Execute() + 0x15f)
0x289fef8: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x8cef8
0x286af52: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x57f52
0x62ac4a3: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xae4a3
0x62a3014: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa5014
0x63b3ee4: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b5ee4
0x63b2c2c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b4c2c
0x63b2f8b: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b4f8b
(SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&, unsigned short)
+ 0x12f)
0x63aa7fc: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ac7fc
0x63c4b06: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c6b06
0x63c557d: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c757d
0x6b5636b: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xba36b
0x6b563f6: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xba3f6
0x5b63e50: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8be50
0x5c8187f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a987f
(Menu::Select() + 0x43)
0x5c7c7ef: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a47ef
0x5c7c802: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1a4802
0x5b63e50: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8be50
0x5cca2fe: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1f22fe
0x63ec58: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1dc58
0x664396: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x43396
(SalDisplay::DispatchInternalEvent() + 0x64)
0x57d3bc: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x133bc
0x57d3e3: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x133e3
0x8d05e1: /lib/libglib-2.0.so.0 + 0x295e1
0x8d2342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x8d531f: /lib/libglib-2.0.so.0 + 0x2e31f
0x8d5885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x57d213: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13213
0x666a9e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45a9e
(X11SalInstance::Yield(bool, bool) + 0x2c)
0x5b6c473: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94473
(Application::Yield(bool) + 0x53)
0x5b6c508: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94508
(Application::Execute() + 0x28)
0x6e21186: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24186
(desktop::Desktop::Main() + 0x164e)
0x5b702de: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x982de
0x5b703d3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x983d3 (SVMain()
+ 0x2b)
0x6e1ad09: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd09 (sal_main
+ 0x5d)
0x6e1ad55: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd55 (main + 0x27)
0xe57f2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4a1
Comment 1 Caolan McNamara 2006-09-21 09:19:32 EDT

*** This bug has been marked as a duplicate of 206845 ***

Note You need to log in before you can comment on or make changes to this bug.