Bug 207753 - plugin - invalid sytax
plugin - invalid sytax
Status: CLOSED DUPLICATE of bug 207453
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 16:44 EDT by Darwin H. Webb
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 17:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2006-09-22 16:44:52 EDT
Description of problem:
Many errors at start up of stroubleshootd

Version-Release number of selected component (if applicable):
setroubleshoot-0.42-2

How reproducible:
always since Sep 20 updates

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
error message sample
setroubleshoot: 2006-09-22 13:25:08,637 [plugin.ERROR] failed to load
httpd_unified plugin Traceback (most recent call last):   File
"/usr/lib/python2.4/site-packages/setroubleshoot/util.py", line 312, in
load_plugins     mod = imp.load_module(module_name,
*imp.find_module(plugin_name, [plugin_dir]))   File
"/usr/share/setroubleshoot/plugins/httpd_unified.py", line 22, in ?     from
setroubleshoot.Plugin import Plugin   File
"/usr/lib/python2.4/site-packages/setroubleshoot/Plugin.py", line 123     rpm =
get_rpm_nvr_by_file_path(self.path.strip('"')))                                
                        ^ SyntaxError: invalid syntax 
Sep 22 13:25:08 Jade-38 kernel: tulip0:  MII transceiver #1 config 1000 status
786d advertising 05e1.
Sep 22 13:25:09 Jade-38 setroubleshoot: 2006-09-22 13:25:08,819 [plugin.ERROR]
failed to load allow_rsync_anon_write plugin Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/setroubleshoot/util.py", line 312, in
load_plugins     mod = imp.load_module(module_name,
*imp.find_module(plugin_name, [plugin_dir]))   File
"/usr/share/setroubleshoot/plugins/allow_rsync_anon_write.py", line 20, in ?   
 from setroubleshoot.Plugin import Plugin   File
"/usr/lib/python2.4/site-packages/setroubleshoot/Plugin.py", line 123     rpm =
get_rpm_nvr_by_file_path(self.path.strip('"')))                                
                        ^ SyntaxError: invalid syntax 
Sep 22 13:25:08 Jade-38 kernel: eth0: ADMtek Comet rev 17 at f885ec00,
00:14:BF:56:69:3A, IRQ 201.
Sep 22 13:25:09 Jade-38 setroubleshoot: 2006-09-22 13:25:08,819 [plugin.ERROR]
failed to load allow_rsync_anon_write plugin Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/setroubleshoot/util.py", line 312, in
load_plugins     mod = imp.load_module(module_name,
*imp.find_module(plugin_name, [plugin_dir]))   File
"/usr/share/setroubleshoot/plugins/allow_rsync_anon_write.py", line 20, in ?   
 from setroubleshoot.Plugin import Plugin   File
"/usr/lib/python2.4/site-packages/setroubleshoot/Plugin.py", line 123     rpm =
get_rpm_nvr_by_file_path(self.path.strip('"')))                                
                        ^ SyntaxError: invalid syntax
Comment 1 John Dennis 2006-09-29 17:15:02 EDT

*** This bug has been marked as a duplicate of 207453 ***

Note You need to log in before you can comment on or make changes to this bug.