Bug 207800 - Compiz opens Nautilus Windows in wrong Workspace
Compiz opens Nautilus Windows in wrong Workspace
Status: CLOSED DUPLICATE of bug 200292
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Depends On:
  Show dependency treegraph
Reported: 2006-09-23 09:03 EDT by teamwassily
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-27 16:28:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description teamwassily 2006-09-23 09:03:31 EDT
Description of problem:
If you open the home folder (nautilus) in workspace foo but the home folder is
already open in workspace bar then the cube will slingshot over to workspace bar.

Version-Release number of selected component (if applicable):
latest compiz as of sept 23 2006

How reproducible:

Steps to Reproduce:
1. Open home folder in workspace foo.
2. go to workspace bar.
3. Open home folder in workspace bar.
4. Cube slingshots over to workspace foo.
Actual results:
Cube slingshots over to workspace foo.

Expected results:
The home folder should have opened in workspace bar.  In the past the nautilus
window would disappear from workspace foo and be reopened in workspace bar.

Additional info:
Comment 1 Bastien Nocera 2006-09-25 17:55:03 EDT
Confirming, the expected result is the way it works with Metacity.
Comment 2 Søren Sandmann Pedersen 2006-09-27 16:28:22 EDT
When nautilus (or gtk+ really) opens an existing window, it first queries the
current desktop, then moves the window to that desktop. But compiz doesn't
support workspaces, only viewports, so the "current desktop" is always the only
one there is.

A hack could possibly be applied that would make compiz move the window to the
current viewport instead, but I think that might have really strange side
effects for things like modal dialogs etc.

So, basically, yet another dup of 200292.

*** This bug has been marked as a duplicate of 200292 ***

Note You need to log in before you can comment on or make changes to this bug.