Bug 207804 - monitor out of range in many instances
monitor out of range in many instances
Status: CLOSED DUPLICATE of bug 203570
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-23 11:07 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-14 09:37:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File generated with X -configure (5.27 KB, text/plain)
2006-09-23 11:07 EDT, Jim Cornette
no flags Details
Previous startup log when error occured (66.40 KB, text/plain)
2006-09-23 11:09 EDT, Jim Cornette
no flags Details
Launching GL-117 game (61.63 KB, text/plain)
2006-09-27 22:48 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2006-09-23 11:07:06 EDT
Description of problem:
If I try to Install FC6T3 Graphically, I will get an out of range error in the
monitor. The out of range frequencies vary with each failure, The vertical
Frequency goes out way beyond 100 HZ. The Horizontal frequency also seems to be
way out of specified values.
With X installed, I first noticed this problem whewn launching the game
viruskiller. The monitor showed the out of range. I then checked the working FC5
xorg.conf and the values seemed to be rational.
Afterwards, I ran X -configure which made a new configuration in /root. I
replaced the old xorg.conf file with the newly generated file. It works, but
does not show the 1280x1024 resolution that I used before with FC5. It gives me
1152x864 at 75HZ that works. If I change the resolution to a lower resolution
like 1024x768, I get the out of range displayed on my monitor.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.1-5.fc6

How reproducible:
GUI installs, Launch game that changes screen resolutions, change to a lower
setting via screen resolution in system > Preferences.

Steps to Reproduce:
1. Try to install GUI or switch screen resolutions.
2. Try to use X -configure and replace once working xorg.conf
3. try to reconfigure X with system-config-display --reconfig
  
Actual results:
Each method shows errors. S-c-display does not even get the monitor type
correctly with this version of X. It was able to get the correct monitor
previously with FC5 version of X

Expected results:
Being able to install with the GUI, being able to play games which switch screen
resolutions, the ability to adjust screen resolutions to desired values.

Additional info:
Comment 1 Jim Cornette 2006-09-23 11:07:06 EDT
Created attachment 137002 [details]
File generated with X -configure
Comment 2 Jim Cornette 2006-09-23 11:09:50 EDT
Created attachment 137003 [details]
Previous startup log when error occured

This log was generated when I lowered my screen resolution.
Comment 3 Jim Cornette 2006-09-23 11:12:17 EDT
One note, I do not have a monitor hooked up to the nvidia video amd am not using
it presently.
Comment 4 Féliciano Matias 2006-09-24 05:01:13 EDT
This bus seems very similar to these bugs :
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=197033
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=203570
Comment 5 Jim Cornette 2006-09-24 18:56:55 EDT
I checked out the reports and feel that they all are related to the config file
and the way the mga driver is compiled for FC6. Thanks for the info.

Also, I added reference to this bug within the two other bug reports. If bugs
are combined and a solution is found, I'm fine with this approach.

Thanks!
Jim Cornette
Comment 6 Jim Cornette 2006-09-27 22:48:50 EDT
Created attachment 137284 [details]
Launching GL-117 game

I got another out of range error when trying to launch a game. I am able to use
X with the mga driver after changing the maximum vertical from 190 Hz to 70 Hz.


This is the first failure after the X -configure file was generated. I	have no
luck with s-c-display doing anything useful.
Comment 7 Féliciano Matias 2006-10-13 23:53:30 EDT
Does xorg-x11-drv-mga v1.4.2 fix this bug ?
=> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=203570#c19

Is this bug related to #203570 ?
Comment 8 Jim Cornette 2006-10-14 09:37:37 EDT
The problem is corrected by version 1.4.2 that you compiled and made available
for bug 203570. I guess we can mark this as a duplicate, since different
problems are corrected by the same fix. Marking as duplicate of 203570.

*** This bug has been marked as a duplicate of 203570 ***

Note You need to log in before you can comment on or make changes to this bug.