Bug 203570 - Starting X brings up a blank screen
Starting X brings up a blank screen
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 197033 207804 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 10:49 EDT by Brent Fox
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 10:47:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg config file (501 bytes, text/plain)
2006-08-22 10:49 EDT, Brent Fox
no flags Details
X log (53.59 KB, text/plain)
2006-08-22 10:50 EDT, Brent Fox
no flags Details
updated X log (49.78 KB, text/plain)
2006-08-22 11:02 EDT, Brent Fox
no flags Details
[mschwendt] X log with xorg-x11-drv-mga-1.2.1.3-1.2 (54.45 KB, text/plain)
2006-10-05 15:52 EDT, Michael Schwendt
no flags Details
[mschwendt] X log with xorg-x11-drv-mga-1.4.1-5.fc6 (53.46 KB, text/plain)
2006-10-05 15:53 EDT, Michael Schwendt
no flags Details
Log on recently installed system. (49.84 KB, text/plain)
2006-10-05 22:20 EDT, Jim Cornette
no flags Details
X log (42.31 KB, text/plain)
2006-10-12 16:29 EDT, Orion Poplawski
no flags Details
Log when checking effects of resolution changes. (62.28 KB, text/plain)
2006-10-13 21:57 EDT, Jim Cornette
no flags Details
Log after running system-config-display --reconfig (46.45 KB, text/plain)
2006-10-13 22:18 EDT, Jim Cornette
no flags Details

  None (edit)
Description Brent Fox 2006-08-22 10:49:45 EDT
Description of problem:  I installed the nightly rawhide tree on Aug. 21.  X
worked fine with anaconda.  After rebooting, firstboot came up just fine as
well, so X was working there.  After firstboot, gdm failed to start.  Machine
has a Matrox G400 and is connected via a KVM, although this setup has worked
before on previous releases.

I dropped to runlevel 3 and ran "/usr/X11R6/bin/X".  I could see the monitor
status light blink like it normally does when starting X.  Then the screen
turned blank.  No graphics, no pointer, nothing.  I went back to the virtual
console that I ran "X" from but did not see any error messages.  Nothing in the
X logs looks suspicious to me.

However, the xorg.conf file looks suspiciously small to me, and it lacks any
resolution modes or module information.  Maybe firstboot just mangled the config
file?  I'm attaching the X log and the xorg.conf file.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-26.fc6.i386.rpm

How reproducible:  every time on my test machine
Comment 1 Brent Fox 2006-08-22 10:49:45 EDT
Created attachment 134639 [details]
xorg config file
Comment 2 Brent Fox 2006-08-22 10:50:35 EDT
Created attachment 134640 [details]
X log
Comment 3 Brent Fox 2006-08-22 11:02:17 EDT
Created attachment 134641 [details]
updated X log
Comment 4 Brent Fox 2006-08-22 11:19:38 EDT
Another data point:  When I specify the "vesa" driver, X will start.  So maybe
the problem is specific to the mga driver.
Comment 5 Adam Jackson 2006-08-22 12:51:39 EDT
Do you happen to have an X log from starting the machine with an older version
of X?  Say, FC5.
Comment 6 Brent Fox 2006-08-22 14:20:25 EDT
I don't have an old log handy.  I can reinstall the box with FC5 if necessary. 
Just let me know.
Comment 7 Adam Jackson 2006-08-25 11:24:08 EDT
(In reply to comment #6)
> I don't have an old log handy.  I can reinstall the box with FC5 if necessary. 
> Just let me know.

That would be helpful.
Comment 8 Michael Schwendt 2006-09-06 09:16:35 EDT
Most likely the same than bug 197033 (X doesn't work anymore with Matrox G400).

I'm affected, too. My work-around is to downgrade to the driver
from FC5 (xorg-x11-drv-mga-1.2.1.3-1.2).
Comment 9 Féliciano Matias 2006-09-24 04:58:46 EDT
> I'm affected, too.

Me too.
Comment 10 Jim Cornette 2006-09-24 18:53:05 EDT
I have an MGA G200 and have it up an running. I did have out of range errors
with the xorg.conf file that worked fine for FC5 version. See bug 207804
X -configure followed by changing the vertical refresh rate from *190* Hz to 70
Hz does not cause out of range errors for games now.
Comment 11 Michael Schwendt 2006-10-05 15:52:41 EDT
Created attachment 137839 [details]
[mschwendt] X log with xorg-x11-drv-mga-1.2.1.3-1.2
Comment 12 Michael Schwendt 2006-10-05 15:53:25 EDT
Created attachment 137840 [details]
[mschwendt] X log with xorg-x11-drv-mga-1.4.1-5.fc6
Comment 13 Jim Cornette 2006-10-05 22:20:07 EDT
Created attachment 137893 [details]
Log on recently installed system.

This is with no xorg.conf file at all. I am using xorg-x11-drv-mga-1.4.1-5.fc6
Comment 14 Michael Schwendt 2006-10-06 09:35:13 EDT
*** Bug 197033 has been marked as a duplicate of this bug. ***
Comment 15 Michael Schwendt 2006-10-06 09:36:27 EDT
As suggested by Alexei Podtelezhnikov, I've tried reducing the
screen resolution:

  800x600, true-colour : works
 1024x768, true-colour : works
 1152x768, true-colour : works
 1280x960, true-colour : -FAILS-
 1280x1024, true-colour: -FAILS-  (*)

(*) is the resolution I've used for a very long time and which works
flawlessly with FC5 and older!
Comment 16 Michael Schwendt 2006-10-07 05:27:55 EDT
s/true-colour/Thousands of Colors/

is what system-config-display says about the colour resolution,
and it's right (I mixed that up with a different machine, seems
s-c-d uses the "Millions of Colors" there).
Comment 17 Alexei Podtelezhnikov 2006-10-11 13:32:11 EDT
Historically, I learned about videoram in bug 25920. I hope there is an option 
for the new driver to disable some advanced feature that eats up to much 
videoram. We do want old 16Mb hardware to work.
Comment 18 Orion Poplawski 2006-10-12 16:29:16 EDT
Created attachment 138374 [details]
X log

Today's (20061012) rawhide.  Stock xorg.conf.  Panel says display is using
Hsync of 82.4kHz, Vref of 103Hz which is out of range, and out of the detected
values.

# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen	    0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver	    "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver	    "mga"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device	   "Videocard0"
	DefaultDepth	 24
	SubSection "Display"
		Viewport   0 0
		Depth	  24
	EndSubSection
EndSection
Comment 19 Orion Poplawski 2006-10-12 16:47:33 EDT
I rebuilt xorg-x11-drv-mga with version 1.4.2 and it works for me.
Comment 20 Féliciano Matias 2006-10-12 21:14:42 EDT
With xorg-x11-drv-mga 1.4.2 => it works for me.
Comment 21 Jim Cornette 2006-10-12 22:32:49 EDT
Where is this version at? I checked development and updates-testing. Neither is
up to 1.4.2.
Thanks!
Comment 22 Féliciano Matias 2006-10-12 23:04:47 EDT
> Where is this version at?

At x.org :
ftp://ftp.x.org/pub/individual/driver/

rpm (with no warranty) : http://feliciano.matias.free.fr/xorg-x11-drv-mga/
Comment 23 Michael Schwendt 2006-10-13 05:37:20 EDT
$ rpm -q xorg-x11-drv-mga
xorg-x11-drv-mga-1.4.2-0.fc6.mat.1

works for me, too.

And 1.4.2 is from Sep 18th, it seems.
Comment 24 Jim Cornette 2006-10-13 20:42:57 EDT
Thanks for the link to the driver sources. Especially thanks for the binary rpm
version.

rpm itself is acting up for me, so I'll test later, after getting it to install.
Comment 25 Jim Cornette 2006-10-13 21:57:01 EDT
Created attachment 138483 [details]
Log when checking effects of resolution changes.

The screens are not working as desired. They do not cause the display to go out
of range as was the case previously
Comment 26 Jim Cornette 2006-10-13 22:18:27 EDT
Created attachment 138484 [details]
Log after running system-config-display --reconfig

100 percent better response with this compilation for the driver. This means it
is possible to fix.
As a note, I changed to the mga only instead of dual head.

Works for me too!
Comment 27 Féliciano Matias 2006-10-13 23:52:28 EDT
Perhaps bug #207804 is related to this one.
Comment 28 Jim Cornette 2006-10-14 09:37:49 EDT
*** Bug 207804 has been marked as a duplicate of this bug. ***
Comment 29 Jim Cornette 2006-10-14 09:40:02 EDT
As noted, the problem is corrected by the better version of the driver. As
above, I closed as duplicate of this bug. Thanks!
Comment 30 Dave Malcolm 2006-10-16 11:34:04 EDT
Possible dupe of this bug I filed upstream against the mga driver:
https://bugs.freedesktop.org/show_bug.cgi?id=6821

Would be good to get this fixed for FC6
Comment 31 Jim Cornette 2006-10-16 19:59:07 EDT
The reference to out of range for Horizontal matches the problem that I was
experiencing. The vertical max range was also out of bounds. MGA G200 also in
reports.
Comment 32 Jim Cornette 2006-10-18 20:34:14 EDT
Supposing that the xorg-x11-drv-mga-1.4.2-1.fc6 will be included when FC6 is
finalized, this bug seems to be resolved though the status is still new.
xorg-x11-drv-mga-1.4.2-1.fc6 from rawhide works when I change resolutions to
lower settings. Changing to lower settings did cause out of range with the
previous driver.
Thanks for the fix.
Comment 33 Kristian Høgsberg 2006-10-23 13:08:19 EDT
Brent, could you confirm that xorg-x11-drv-mga-1.4.2-1.fc6 does indeed fix the
issue and close this bug if so. Thanks, Kristian
Comment 34 Benjamin Bennett 2006-10-29 13:36:03 EST
Same problem with ATI  9600 M10. Solved problem by downloading ati-prop driver
and installing it. The x11 config was blank as described . Ran aticonfig
--initial and it made a new x11 config file. 
Comment 35 Adam Jackson 2007-04-10 17:44:18 EDT
NEEDINFO as per comment #33.  Did 1.4.2 work any better?  Does F7 exhibit the
same problem?
Comment 36 Matěj Cepl 2007-07-12 11:26:11 EDT
Reporter, could you please reply to the previous question? If you won't reply in
two weeks, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 37 Matěj Cepl 2007-08-13 10:47:50 EDT
No information requested was provided, so I close this bug as INSUFFICIENT_DATA.
Reporter, if you could, please, reopen with additional information.

Note You need to log in before you can comment on or make changes to this bug.